Jump to content
Delan

Cura 3.5.0 won't load under Windows 10

Recommended Posts

Posted · Cura 3.5.0 won't load under Windows 10

Downloaded Cura 3.6.0, installed, double click. Nothing happens. Well, just the Cura.exe program appears in the Task Manager. Uninstalled completely. Reinstalled. Same behavior. Is there a fix for this? 
Tried running as admin too, same thing. Running in Windows 10.

Share this post


Link to post
Share on other sites
Posted · Cura 3.5.0 won't load under Windows 10

I too am on windows 10 I installed it and it started once then wouldn’t load again. I went here to this site and couldn’t see an answer so..

i ran it as admin and if I remember the order correctly went to compatibility settings it went through it’s series of test, it  set it to run under Windows 8 and it works. Hope it does for you too.

kind regards 

Graham 

  • Like 1

Share this post


Link to post
Share on other sites
Posted · Cura 3.5.0 won't load under Windows 10

Hi all,

I facing the same issue. However, any compatible mode is not working for me. While I uninstall and install again and migrate my configuration file, I found the root cause.

 

My Env: Windows 10 Home, Cura 3.6.

Root cause: In the folder C:\Users\comcr\AppData\Roaming\cura\3.6 that store user setting, there is a file named cura.lock, once this file exist, then Cura startup in the background but UI didn't show.

Fix: Terminate the background Cura program. delete cura.lock and start again.

 

Hope this help.

comcrazy

Share this post


Link to post
Share on other sites
Posted · Cura 3.5.0 won't load under Windows 10

Hello everyone & @nallath, just to point out that I had the same issue, Cura suddenly not launching anymore,

I was running the v3.6 then it happen I don't know why,

same issue with another colleague,

then I tried updating to the 4.0, same issue,

then tried in admin mode, same issue

then erased the Appdata cura 4.0 folder, and it worked, for now at least, I don't know for how long...

 

 

PS: running win10, i7, latest drivers etc...

Share this post


Link to post
Share on other sites
Posted · Cura 3.5.0 won't load under Windows 10

Can confirm this is a problem on my Win10 machine as well for latest Cura (4.2.1).  Running the compatibility troubleshooter fixed it for me as well.  (Manually setting Win8 compatibility does not fix it, btw)

Share this post


Link to post
Share on other sites
Posted · Cura 3.5.0 won't load under Windows 10

Same here been using this great program for a few years updated to 4.3 and a few days later started cura and it shows in task manager but no window. Runs in windows 8 compatibility mode, this is so weird.

Share this post


Link to post
Share on other sites
Posted · Cura 3.5.0 won't load under Windows 10

I Found the fix Guys, Go to cura folder in program files> ultimaker cura 4.3, scroll all the way to the bottom and install ''vcredist_64'', if it does not install its because you have a newer version, go to control panel> uninstall a program> and uninstall all the newer versions of ''microsoft c++ redistributable'' , then try installing it, Then open cura and enjoy!

 


After days of research finally i figure that out. Happy prints!

Share this post


Link to post
Share on other sites
Posted · Cura 3.5.0 won't load under Windows 10

Be sure to reinstall the later versions after you get Cura working or you may have newer programs failing (like the ones that caused those later versions to be installed).

 

 

Share this post


Link to post
Share on other sites
Posted · Cura 3.5.0 won't load under Windows 10

I couldn't get any version of this program to run at all.  I'm very experienced at troubleshooting installations.  I am also a first time 3D Printer owner.  This was very frustrating, spending so much time just to install software to get started.  I could only imagine someone without my knowledge sending there printer as an RMA instead of trying to work through the issues.  I hope this will help the developer.

This took me around 5 hours and a very odd culprit.  My Asus overlay for fps games would not allow this program to load.  If you have any secondary overlays running (ie.. FPS Counter for games) this program won't load at all.  I run an ASUS overlay to show my fps in games.

Also, the software installation is not verifying the C++ 2015 installation files.

  • Like 1

Share this post


Link to post
Share on other sites
Posted · Cura 3.5.0 won't load under Windows 10

We might have found a solution for this! So i would like to ask everyone to download and test the 4.4 beta once that is available (should be in the next few weeks).

  • Like 1

Share this post


Link to post
Share on other sites
Posted · Cura 3.5.0 won't load under Windows 10

Awesome, i just talked to a microsoft advisor from microsoft forums and they said that it was that the problem, they told me that cura needs to have a patch to be used with newer versions of microsoft c++ 2015 redistributable. This is what they said:

 

That is a Cura issue and has nothing to do with Microsoft. They must write their programs to work with Visual Studio or Net Frameworks, not the other way around. Microsoft just provides these as programming tools.

Share this post


Link to post
Share on other sites
Posted · Cura 3.5.0 won't load under Windows 10

I've just had this happen to me and deleting the packages.json and running Cura again fixed it for me.

Share this post


Link to post
Share on other sites
Posted · Cura 3.5.0 won't load under Windows 10

Nallath! i tried the beta version and still wont open up, please tell the developers to update cura to work with latest version of Microsoft c++ redistributables!! Remember what microsoft said!

 

"That is a Cura issue and has nothing to do with Microsoft. They must write their programs to work with Visual Studio or Net Frameworks, not the other way around. Microsoft just provides these as programming tools."

Share this post


Link to post
Share on other sites
Posted · Cura 3.5.0 won't load under Windows 10
On 11/6/2019 at 10:59 PM, mrtinfy said:

"That is a Cura issue and has nothing to do with Microsoft. They must write their programs to work with Visual Studio or Net Frameworks, not the other way around. Microsoft just provides these as programming tools."

I am one of the developers, but this makes no sense what so ever.

Share this post


Link to post
Share on other sites
Posted · Cura 3.5.0 won't load under Windows 10

I not a cura developer but a developer using Microsoft technologies and I concur with @nallath above...it makes no sense

  • Like 1

Share this post


Link to post
Share on other sites
Posted · Cura 3.5.0 won't load under Windows 10

It makes perfect sense if you are a support person when a non-programmer user of software not written by Microsoft is asking Microsoft to fix an issue. I’m sure @mrtinfy means well, but he needs to stop trying to wield that comment like a cudgel.
 

He also needs to understand that in many open source projects, there are many packages that are used, but not written or supported by the developers of the product. If Package “X, version 1.23” is being used by the project, and that version has a hard dependency on msvc redistributables 2015, that could make the project as a whole not work with the fully backward compatible later version.

 

It is possible that Package X v1.45 has remedied the problem, and you might ask why the project is still using the old version.

 

It is common in many software development scenarios to use “outdated” versions. The first is that it is often not clear which package is causing the problem. Is it Package X or Package Y? The second is that it can be a lot of work to bring in a later version of the package. In addition to fixing the msvc issue, it may have changed fundamental things about how the package works.


I am sure Team Ultimaker will fix the issue when they are able, but insinuating they are clueless is not useful.

 

 

 

 

  • Like 1

Share this post


Link to post
Share on other sites
Posted · Cura 3.5.0 won't load under Windows 10

“mrtinfy” was simply doing as able to help by conveying that which he was told.

 

I have no comment as associated with this seemingly protracted issue for the a Ultimaker development team but rather a thank you to “mrtinfy” for trying.

 

Takes care,

 

Shadowman

  • Like 1

Share this post


Link to post
Share on other sites
Posted · Cura 3.5.0 won't load under Windows 10

The thing is Microsoft offers a package of redistributables from 2015 to 2019 in a single file which cura installer seems not to detect the  C++ 2015 installation files. The only way to run cura in my computer (and many other people with the same problem) is to install the redistributable that is included in the installation file from cura, but the only way to do it is uninstalling all newer versions of redistributables then i am stuck trying to open other software that need newer versions, and if i try to install the package from Microsoft it deletes the previous version i installed from cura. There is people that actually bough a printer from ultimaker and end up returning them since they were never able to use the slicer and did not know that there were other slicers softwares, since they were not very experienced in the 3D printing field.

Share this post


Link to post
Share on other sites
Posted · Cura 3.5.0 won't load under Windows 10

@mrtinfy 

Yes. There is an issue...but it is not as simple as you think. Many of us run Cura on systems that have the newer redistributables with no problem. My Surface Book v2 runs it fine in its laptop configuration that uses the NVidia GPU in the keyboard. But it will not launch properly when in tablet mode where it uses the integrated Intel GPU. I have given this info to the team both here in the forums and on the Github issues section, but I don’t pester the team asking, “Is it done yet?”

 

One of the truly frustrating things in software development is to have bugs that a small group of customers see, but that you cannot reproduce on the computers you have available for testing.

 

Letting other users know what worked for you, as you did in your initial posts about this issue, is good because it gave others who have the problem a possible workaround. It also let others add to that, for example my comments about needing to reinstall the later redistributables one Cura was installed so as to not break other programs. This is collaborative troubleshooting. And these points of information may provide clues to the development team.

 

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!