Jump to content
Ultimaker Community of 3D Printing Experts

Recommended Posts

Posted · Steps per mm

Hi all,

 

could someone help me.  The steps per mm given by bond tech aren’t right.  Major under extrusion. 

 

What is the best way to perform a move material by a fixed amount under control. 

 

I have used used the developer access although I struggle to actually get it to do something when I want it to. 

 

I lost my original value for E steps. ?

  • Link to post
    Share on other sites
    Posted · Steps per mm

    Hi this may not be the best answer for you, I do not know what bond tech is, but this is how I do it. Load Repetier Host software (free), onto a laptop. Attach your laptop to your printer by USB. You will need to do a bit of printer setup in Repetier but is should not be difficult and most of the settings will be in your printer definition in you slicer. Load the STL file, on your laptop, into Repetier and use the Repetier GUI to move the material a measured amount.

     

    Once fixed think about using the wonderful Repetier to control your printer on an ongoing basis

  • Link to post
    Share on other sites
    Posted · Steps per mm

    @rebekah_harper you mention 'developer access', so you are using an UM3 or S5 machine. Then yellowshark's suggestion for using a program with USB connection won't work.

     

    What machine type do you have?

    Which Bond Tech extruder model are you using?

     

    For the UM3/S5:

    - Enable developer mode

    - Make an SSH connection and login with user name 'ultimaker' and password 'ultimaker'

    - 'sendgcode T0' (or T1)  this will select the left or right nozzle

    - 'sendgcode M302 S0' disables the cold extrusion prevention, so you can move filament even when cold.

    - 'sendgcode G0 E10' will move the filament 10mm.

  • Link to post
    Share on other sites
    Posted · Steps per mm

    If you're logged in as "ultimaker" you are already in the command util (there's a "(Cmd)" prompt, correct?)  - and you can just type the "sendgcode..." commands.

     

    The instructions from @CarloK are complete:

     

    On 10/26/2018 at 11:10 PM, CarloK said:

    For the UM3/S5:

    - Enable developer mode

    - Make an SSH connection and login with user name 'ultimaker' and password 'ultimaker'

    - 'sendgcode T0' (or T1)  this will select the left or right nozzle

    - 'sendgcode M302 S0' disables the cold extrusion prevention, so you can move filament even when cold.

    - 'sendgcode G0 E10' will move the filament 10mm.

     

  • Link to post
    Share on other sites
    Posted · Steps per mm

    Nope, no CMD prompt.

  • Link to post
    Share on other sites
    Posted · Steps per mm

    With the info I have right now I can't explain the missing CMD prompt.

    When you connect over SSH and login with the ultimaker / ultimaker account, then you should be directed to the python command utility. Only in the first UM3 releases this was different, I think it was there since v3.4.

     

    What is your UM3 firmware version?

  • Link to post
    Share on other sites
    Posted · Steps per mm

    Hiya,

     

    its the the latest version.

     

    managed to figure it out.

     

    once I logged in I had to type: cd /usr/share/ plus the rest which escapes me. Once I did this I then typed in python3 commands_util.py 

    this gave me the CMD prompt.  However I have to do this after every time I sendgcode. For some reason I have to turn off and on the printer then log in the send the GCode for it to move. Once it moves it won’t respond to any GCode command, so I have to turn off and on again followed by logging in. 

    I don’t get it. ?  I type the exact same thing and it doesn’t respond. 

    But I managed to dial in the step/mm for the bond tech. Which was 513 ish. Managed to check it and he presto. 

  • Link to post
    Share on other sites
    Posted · Steps per mm

    Something is broken on your machine.

    Did you modify the um3.json file for the new steps/mm setting? If yes, then I suspect you made a typo. Accidentally deleting a comma or something like that can corrupt the file.

     

    Easiest solution: install the firmware again (from network download or a USB stick) and then apply your new steps/mm setting to the um3.json

  • Link to post
    Share on other sites
    Posted · Steps per mm

    If you need some handy tool for the X,Y,Z and E-stepper calibration, check this: https://www.thingiverse.com/thing:3706923

     

    ;-) Arthur

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    ×
    ×
    • Create New...