Jump to content
Ultimaker Community of 3D Printing Experts
guanu

Auto inserted M104 T0 S0 during print with dual extrusion.

Recommended Posts

I use 2 extruders with 1 hotend, and everything works great, except Cura keeps putting in a M104 T0 S0 at the end of tool 0's model.  

If I have a model that is 2 colors, and tool 0 ends and tool 1 continues the rest of the print without going back to tool 0, Cura will insert a M104 T0 S0 at the last layer of tool 0's model.  This is a problem when running with a single hotend and will turn off the temp for the hotend for the rest of the print and ruin the print.  Is there any way to prevent cura from inserting this command in the gcode and let me control shutting off the heat with the end gcode?  This seems to be a serious problem for single hotend with dual extruder machines depending on the model. 

*quick edit:  I have both printing temps and standby temps set to full temp on both extruders in the slice settings.

Screenshot_110918_095722_AM.jpg

Edited by guanu

Share this post


Link to post
Share on other sites

I'm running into the same problem with my Geeetech A10M + Cura.

I have attached a sample file exhibiting the problem. I have yellow color mounted on the second extruder, so I sliced this yellow model to be printed using the second extruder. However, the nozzle turns off after printing the skirt.

 

I will look into the source code next to find out where the erroneous M104 is emitted.

 

In the meantime, a workaround is to run a postprocessing script that replaces "m104 t0 s0", "m104 t1 s0", and so on, with an empty string.

CFFFP_fuesse_schnabel.gcode

Share this post


Link to post
Share on other sites

Yeah, that is the current workaround one of our distributors is doing.  Having to load the gcode and do a search and remove the line is a workaround, just kind of a pain when that line should not be put in there in the first place.  I have not had the time or knowledge to fix it in the software and wanted to bring it to attention since it needs to be addressed for people using a single hotend with multiple extruders.  Hopefully it gets noticed.

Share this post


Link to post
Share on other sites

I have the same problem with my Geeetech A10M (one nozzle two extruders). It's very frustrating, I cannot print a bicolor model with Cura.

My printer works in bicolor models in Repetier-Host using Cura profile where the gcode is situated in one place for both the printer and the extruders. The dual extruder is configurable (one nozzle for 2 extruders), while in Cura this configuration doesn't exist....

Share this post


Link to post
Share on other sites

I use Cura 3.6.0

Here is my configuration :

 

Printer 
Start G-code

; Custom Start G-code
G28 ; Home all axes
G92 E0 ; Reset Extruder
G1 Z2.0 F3000 ; Move Z Axis up little to prevent scratching of Heat Bed
G1 X0.1 Y20 Z0.3 F5000.0 ; Move to start position
G1 X0.1 Y200.0 Z0.3 F1500.0 E15 ; Draw the first line
G1 X0.4 Y200.0 Z0.3 F5000.0 ; Move to side a little
G1 X0.4 Y20 Z0.3 F1500.0 E30 ; Draw the second line
G92 E0 ; Reset Extruder
G1 Z2.0 F3000 ; Move Z Axis up little to prevent scratching of Heat Bed
; End of custom start GCode
End G-code


; Custom End G-code
G4 ; Wait
M220 S100 ; Reset Speed factor override percentage to default (100%)
M221 S100 ; Reset Extrude factor override percentage to default (100%)
G91 ; Set coordinates to relative
G1 F1800 E-3 ; Retract filament 3 mm to prevent oozing
G1 F3000 Z20 ; Move Z Axis up 20 mm to allow filament ooze freely
G90 ; Set coordinates to absolute
G1 X0 Y{machine_depth} F1000 ; Move Heat Bed to the front for easy print removal
M84 ; Disable stepper motors
; End of custom end GCode

-----------------------------------------------------------------------------------
Etruder 1
Extruder Start G-code 

G1 X{prime_tower_position_x} Y{prime_tower_position_y} F20000
T0 P0
G92 E0
G1 E3 F5000
G92 E0
M18 E1


Etruder 1
Extruder End G-code 

G1 X{prime_tower_position_x} Y{prime_tower_position_y} F20000
G92 E0
G1 E-3 F5000
G92 E0
-----------------------------------------------------------------------------------
Etruder 2
Extruder Start G-code 

G1 X{prime_tower_position_x} Y{prime_tower_position_y} F20000
T0 P0
G92 E0
G1 E3 F5000
G92 E0
M18 E1


Etruder 2
Extruder End G-code 

G1 X{prime_tower_position_x} Y{prime_tower_position_y} F20000
G92 E0
G1 E-3 F5000
G92 E0

 

With the 1rst extruder all is correct, the prints are perfect.

But when I want to print with 2 colors, after printing the 1rst color the nozzle stay in place for several seconds, doesn't move to the prime tower and, before beginning the 2nd color of the model, the temperature fall (in the LCD screen to 175°) so the extrusion isn't hot enough for the 2nd color.
I've tried to put some M104 instructions in some places but with no result...

 

Thanks for your help !

Share this post


Link to post
Share on other sites

Try adding to your extruder start code

M104 S{material_print_temperature} after your G92 E0 on both extruders. That is where I used it on my Creality CR-X. But as for the 1st extruder swap.  where it never goes to the prime tower,  I posted that problem earlier, the only way I know to cure that is to make sure you have skirt big enough to handle the color purge.

Share this post


Link to post
Share on other sites

At last, I've found the solution : there are two versions of Cura json files for the A10M. One of them doesn't works for me.

 

The good one is on Geeetech forum:

http://www.geeetech.com/forum/viewtopic.php?p=89761&sid=c51926817bf3f514d4c61542c44767f7 

 

There are some changes to make in Cura Machine Settings : size of the printer setting is wrong, change the width, depth and height (X 235 Y 235 Z 260. And in Left and Right extruders tab: Size nozzle 0.4 and material 1.75 mm.

 

In Cura all the G-code is in the Printer tab. Extruders tabs are empty. And it works fine even for the prime tower. I think I'll need to configure its size for a better purge but it is already a big improvement.

 

In Start G-code, I've added G-code for drawing two straight lines before beginning printing and in End G-code to bring the bed at the front for easy removal of the print.

 

Here is my Start G-code

G28 ;Home

G29 ;For ABL

G1 Z15.0 F6000 ;Move the platform down 15mm

;Prime the extruder

G92 E0

G1 X7 Y25 Z.3 F5000

G1 X7 Y180 Z0.3 F1500 E0

G1 X11 Y180 Z0.3 F5000

G1 X11 Y25 Z0.3 F1500 E0

G92 E0

 

End G-code

M104 S0;Cooling the heat end

M140 S0;Cooling the heat bed

G92 E1

G1 E-1 F300

G28 X0 Y0;Home X axis and Y axis

G1 Y220 F6000

M84

 

Left Extruder and Right Extruder tabs are empty

 

Hope it will help some users. If someone want the explanation in French, let me know.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • Ultimaker Cura | a new interface
      We're not only trying to always make Ultimaker Cura better with the usual new features and improvements we build, but we're also trying to make it more pleasant to operate. The interface was the focus for the upcoming release, from which we would already like to present you the first glance. 
        • Like
      • 114 replies
    • "Back To The Future" using Generative Design & Investment Casting
      Designing for light-weight parts is becoming more important, and I’m a firm believer in the need to produce lighter weight, less over-engineered parts for the future. This is for sustainability reasons because we need to be using less raw materials and, in things like transportation, it impacts the energy usage of the product during it’s service life.
        • Like
      • 12 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!