Jump to content
Rene6

Nozzel temp set to zero mid print.

Recommended Posts

Posted · Nozzel temp set to zero mid print.

Hi

 

I'm using a builder3d printer with Cura. Latest version. I have some prints where the nozzel temp is set to zero while printing. I actually thought it might be a firmware protection but I recently noticed that there actually is a "M104 T1 S0" command in my g-code after layer 93 in this case. I also printed some other dual color files with similar results but at later layers. I also tried with std profile settings and got same issue. Anybody know this?

 

R

 

IMG_7694.jpg

Share this post


Link to post
Share on other sites
Posted · Nozzel temp set to zero mid print.

So, I tried again, manually removing "M104 T1 S0" from my g-code. Now it prints fine. So:

 

Good: I know whats wrong

Bad: Why is Cura adding this line mid-print?

 

Summary: 

- I load a file with support and print everything with extruder 1. No issues. 

- Same file but I select the support to be printed with extruder 2 -> Cura adds "M104 T1 S0" to the g-code. Mid print the nozzel temperature goes to zero and the extruders blocks. Printer keeps going. 

 

Anybody? As I print dual feed nozzel I have all temperatures set to 200. Incl the standby once. And I use Cura 3.6.0

 

 

Share this post


Link to post
Share on other sites
Posted · Nozzel temp set to zero mid print.

Found a answer:

 

"

Yes, Cura turns off the heating for an extruder that will no longer be used for the remainder of the print (something like M104 T1 S0). If there is only one extruder and one heater, then the printer just ignores the T1 and sees M104 S0 and this then turns off the heating currently printing nozzle, causing the print to fail.

 

"

Share this post


Link to post
Share on other sites
Posted · Nozzel temp set to zero mid print.

And a work around

 

Extensions -> Post-Procession -> Modify G-Code and select "Search And Replace" as modification.
Next one can do the following for correct replacement:

  • Search: "M104 T1 S0"
  • Replace ";Removed M104 T1 S0"

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Our picks

    • Ultimaker Cura | a new interface
      We're not only trying to always make Ultimaker Cura better with the usual new features and improvements we build, but we're also trying to make it more pleasant to operate. The interface was the focus for the upcoming release, from which we would already like to present you the first glance. 
        • Like
      • 181 replies
    • "Back To The Future" using Generative Design & Investment Casting
      Designing for light-weight parts is becoming more important, and I’m a firm believer in the need to produce lighter weight, less over-engineered parts for the future. This is for sustainability reasons because we need to be using less raw materials and, in things like transportation, it impacts the energy usage of the product during it’s service life.
        • Like
      • 12 replies
×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!