Jump to content
Ultimaker Community of 3D Printing Experts

Nozzel temp set to zero mid print.


Recommended Posts

Posted · Nozzel temp set to zero mid print.



I'm using a builder3d printer with Cura. Latest version. I have some prints where the nozzel temp is set to zero while printing. I actually thought it might be a firmware protection but I recently noticed that there actually is a "M104 T1 S0" command in my g-code after layer 93 in this case. I also printed some other dual color files with similar results but at later layers. I also tried with std profile settings and got same issue. Anybody know this?





  • Link to post
    Share on other sites

    Posted · Nozzel temp set to zero mid print.

    So, I tried again, manually removing "M104 T1 S0" from my g-code. Now it prints fine. So:


    Good: I know whats wrong

    Bad: Why is Cura adding this line mid-print?



    - I load a file with support and print everything with extruder 1. No issues. 

    - Same file but I select the support to be printed with extruder 2 -> Cura adds "M104 T1 S0" to the g-code. Mid print the nozzel temperature goes to zero and the extruders blocks. Printer keeps going. 


    Anybody? As I print dual feed nozzel I have all temperatures set to 200. Incl the standby once. And I use Cura 3.6.0



  • Link to post
    Share on other sites

    Posted · Nozzel temp set to zero mid print.

    Found a answer:



    Yes, Cura turns off the heating for an extruder that will no longer be used for the remainder of the print (something like M104 T1 S0). If there is only one extruder and one heater, then the printer just ignores the T1 and sees M104 S0 and this then turns off the heating currently printing nozzle, causing the print to fail.



  • Link to post
    Share on other sites

    Posted · Nozzel temp set to zero mid print.

    And a work around


    Extensions -> Post-Procession -> Modify G-Code and select "Search And Replace" as modification.
    Next one can do the following for correct replacement:

    • Search: "M104 T1 S0"
    • Replace ";Removed M104 T1 S0"
  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

    • Our picks

      • The Ultimaker Showcase — October 14. What's new?
        Your dear friends at Ultimaker have some exciting news and insights for you!
        • 0 replies
      • New here? Get ahead with a free onboarding course
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 10 replies
    • Create New...