Jump to content
Ultimaker Community of 3D Printing Experts

Part by automatically moved by Cura


Recommended Posts

Posted · Part by automatically moved by Cura

I am trying to load 2 files. On is at a higher Z height because I am changing filament and starting next file. But Cura will not position them the way I designed them in Fusion360 and they are on there side for some reason. I could really use some help. I am a little new to 3D printing

 

  • Link to post
    Share on other sites
    Posted · Part by automatically moved by Cura

    Cura will try to avoid placing models on top of each other.

     

    To get them to work together, right click and choose 'slect all' or 'CTRL-+A'. Then right click and click on 'Merge Models'. Provided they are modeled correctly, they will align themselves as they were made and then group them.

     

    The difference between merge and group is that merge places them in their proper locations and then groups them. Group will just group them wherever they are placed as a unit on the buildplate.

  • Link to post
    Share on other sites
    Posted · Part by automatically moved by Cura

    You can rotate the group and it will retain the relationship. Then click on the part you want to move while holding down the CTRL key (if on a Windows keyboard) and you will be able to move it separately).

  • Link to post
    Share on other sites
    Posted · Part by automatically moved by Cura

    So the way I designed it in Fusion was a cylinder standing vertically with 2 bodies. When I import them into cura however, they are placed horizontally and I am unable to get the 2nd body in the air. Then I need to only print one of the bodies. The one on top is where I am going to change the filament

     

  • Link to post
    Share on other sites
    Posted · Part by automatically moved by Cura

    It is flipped because of a difference in Y up or Z up axis.

     

    Have you tried to manually rotate the objects after being merged?

  • Link to post
    Share on other sites
    Posted · Part by automatically moved by Cura

    Yes that works but then it is one body

  • Link to post
    Share on other sites
    Posted · Part by automatically moved by Cura
    On 11/25/2018 at 9:31 PM, kmanstudios said:

    Then click on the part you want to move while holding down the CTRL key (if on a Windows keyboard) and you will be able to move it separately).

    There you go...

  • Link to post
    Share on other sites
    Posted · Part by automatically moved by Cura

    I did that but it is ONE body and if I make it seperate bodies the top one moves down because it is suspended in the air on nothing

     

  • Link to post
    Share on other sites
    Posted · Part by automatically moved by Cura

    I am not sure what you are doing wrong. When you hold down the CTRL key (or the apple keyboard equivalent) and click on a part, it selects that part and you can move it wherever you need it to go.

     

    At this point,  screenshots provided by you are the only way to get an idea of this. on this end of things.

  • Link to post
    Share on other sites
    Posted · Part by automatically moved by Cura

    Sketchup 2 simple cylinders or even just one. Try changing the Z height and try to move it up. Because I can't

  • Link to post
    Share on other sites
    Posted · Part by automatically moved by Cura

    I will send screenshots later

  • Link to post
    Share on other sites
    Posted · Part by automatically moved by Cura

    Well, sketchup is going to create a whole other set of issues. But one thing at a time.

     

    7 minutes ago, Luke67 said:

    Try changing the Z height and try to move it up.

    I do it all the time using the steps I quoted above. That is why I cannot figure what the issue could be.

  • Link to post
    Share on other sites
    Posted · Part by automatically moved by Cura
    7 hours ago, Luke67 said:

    I did that but it is ONE body and if I make it seperate bodies the top one moves down because it is suspended in the air on nothing

    But that's exactly what Merge do, it takes 2 or more bodies and merges them into one body. 

     

    If you want 2 separate bodies, you have to uncheck these settings and then you should be able to place the objects where you want. But I still not understand why you want it to have separately.

    2099606619_Bildschirmfoto2018-11-29um10_15_24.png.f82964da7987fe0cc6228923c4702989.png

  • Link to post
    Share on other sites
    Posted · Part by automatically moved by Cura

    Okay, I think the step you are missing is Step 3 in this tutorial: https://ultimaker.com/en/blog/34012-get-started-with-cura-printing-with-two-colors

     

    So assign the extruders to the model parts, and then merge+rotate.

  • Link to post
    Share on other sites
    Posted · Part by automatically moved by Cura

    Yes the settings I a, looking for is in that screenshot. I need 2 bodies because I need it to print one in black filament. Then I am going to change the filament and print the next piece without removing the previous fro the build plate. So the 2nd parts starts at 12.5 Z height on top of the black.

  • Link to post
    Share on other sites
    Posted · Part by automatically moved by Cura

    Not sure if that guide will work as I only have 1 extruder

  • Link to post
    Share on other sites
    Posted · Part by automatically moved by Cura

    But then I don't understand why you need 2 bodies? If you print with one body you have to pause the print at the specific height to change the filament. If you use two bodies, then you still have to pause the print at the specific height. There is no difference for you with just one extruder. Or did I miss something?

  • Link to post
    Share on other sites
    Posted (edited) · Part by automatically moved by Cura

    @Luke67: As you mentioned two bodies and the merge tool, I was under the impression you were using dual extrusion. As smithy mentioned, you don't need two bodies. Instead, use pause at height (Extension->Post Processing->Modify G-Code->Add script->Pause at height) and then change filaments.

     

    For future posts, I think you will get a solution faster if you not only tell us the very specific thing you have been trying, but also what you are trying to achieve in general.

    Edited by P3D
  • Link to post
    Share on other sites
    Posted · Part by automatically moved by Cura

    Yeah I saw a youtube video for that but I can't find the settings or how to add the pause at layer height

  • Link to post
    Share on other sites
    Posted · Part by automatically moved by Cura
    10 minutes ago, P3D said:

    For future posts, I think you will get a solution faster if you not only tell us the very specific thing you have been trying, but also what you are trying to achieve in general.

    Screenshots. Otherwise it is complete guesswork.

  • Link to post
    Share on other sites
    Posted · Part by automatically moved by Cura

    Ok let me try the stop at layer height

  • Link to post
    Share on other sites
    Posted · Part by automatically moved by Cura

    I did. I am trying to design a piece that can be 2 different colors. But when I import to cura I have to manually rotate objects. And I have need tell it what layer height to stop. Not to print one body and stop.

  • Link to post
    Share on other sites
    Posted · Part by automatically moved by Cura

    And still no screenshots.....

  • Link to post
    Share on other sites
    Posted · Part by automatically moved by Cura

    You have more than one issue, so step by step.

     

    That you have to rotate your object is caused due different x/y/z settings between Fusion 360 and Cura. You have to configure Fusion 360 to have your z in the vertical direction instead of the default horizontal one.

    608462176_Bildschirmfoto2018-11-29um13_11_01.thumb.png.bf26d5a48168f54ea865df2134549d7a.png

     

    And then you have to understand how a dual color print works. With a dual extruder you design your object, then cut it in two or more parts, import these parts into Cura and configure which extruder should print which part. Then you merge the parts together and start the print. The printer changes itself the extruder which is needed during the print.

     

    With a single extruder this is not possible and the printer will also not stop after the first part. If you place a multipart object like described above in Cura, then our printer will print the whole object, all parts without stopping. The printer will never stop after one part is done by itself. So if you want to pause the printer to change the filament you have to do it manually, by sitting beside the printer and pressing pause or by using the pause at z plugin. But in any way it doesn't matter if you have one part or multiple parts, because you have to pause at a specific z height, the printer ignores your parts.
     

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    ×
    ×
    • Create New...