Jump to content
Ultimaker Community of 3D Printing Experts

S5 Autodisconnect completely from WIFI


Recommended Posts

Posted · S5 Autodisconnect completely from WIFI

So, the printer has been going for a few days now. Decided to disconnect from Cura Connect (again). Decided to do a manual connect and found this information.

NoWifi.thumb.jpg.073ec2e53767d3a348cb2a3bbdcbde60.jpg

 

The disconnection seems to be during long prints...give it a dy or two and it will bail in most cases. Once in a while, within a few hours.

 

But this is the first time I have seen it just completely drop out like this.

  • Link to post
    Share on other sites
    • 2 years later...
    Posted · S5 Autodisconnect completely from WIFI

    My S5 has never worked on Wifi. Exact same issue. Stays on for some minutes. It has been like this on three separate locations with totally different network setup (one corporate office, one home with fiber modem supplied wifi and one house with a home wifi router)

     

    I have read so many posts here with people experiencing the same. I have never read that anybody has gotten wifi to work on the S5. Is it totally broken? 

     

    The two last locations I solved it by connecting a LAN cable. But at my current location that is not an option. So back to the old days of USB stick :-/

     

    It would be so nice if anybody had a fix for the wifi.

  • Link to post
    Share on other sites
    Posted · S5 Autodisconnect completely from WIFI
    On 1/21/2021 at 6:31 PM, MaxQ said:

    My S5 has never worked on Wifi. Exact same issue. Stays on for some minutes. It has been like this on three separate locations with totally different network setup (one corporate office, one home with fiber modem supplied wifi and one house with a home wifi router)

     

    I have read so many posts here with people experiencing the same. I have never read that anybody has gotten wifi to work on the S5. Is it totally broken? 

     

    The two last locations I solved it by connecting a LAN cable. But at my current location that is not an option. So back to the old days of USB stick 😕

     

    It would be so nice if anybody had a fix for the wifi.

     

    It could be that your wifi chip on that specific machine has issues? We literally have hundreds of S5's connected with wifi. Wifi is not as stable as ethernet of course, but it should work in most cases. What version of firmware are you using btw? 

    • Like 1
    Link to post
    Share on other sites
    Posted · S5 Autodisconnect completely from WIFI
    On 1/26/2021 at 10:41 AM, sj3fk3 said:

     

    It could be that your wifi chip on that specific machine has issues? We literally have hundreds of S5's connected with wifi. Wifi is not as stable as ethernet of course, but it should work in most cases. What version of firmware are you using btw? 

    @sj3fk3 Neither of my Ultimakers (3 Extended, S5) have ever worked on wifi reliably. Nor does the one at the Uni that ive worked with or the Ultimakers resellers demo machine. Basically 4/4 does not work reliably on wifi. The idea that wifi isnt as stable as ethernet is a 10+yr old idea that does not really make sense today. If you are in an office thats got tons of glass walls then maybe yea but my router is and has been less then 3m away from the machine, still disconnects constantly from both network and cloud. I and im sure many other people would really appreciate a real explanation for this. Is it just a weak chip? coded for a specific router and we should look for some specifics when choosing an router? Help us out here other then saying its our machine with no way of actually fixing it.

  • Link to post
    Share on other sites
    Posted · S5 Autodisconnect completely from WIFI
    On 1/30/2021 at 12:35 AM, Hops said:

    @sj3fk3 Neither of my Ultimakers (3 Extended, S5) have ever worked on wifi reliably. Nor does the one at the Uni that ive worked with or the Ultimakers resellers demo machine. Basically 4/4 does not work reliably on wifi. The idea that wifi isnt as stable as ethernet is a 10+yr old idea that does not really make sense today. If you are in an office thats got tons of glass walls then maybe yea but my router is and has been less then 3m away from the machine, still disconnects constantly from both network and cloud. I and im sure many other people would really appreciate a real explanation for this. Is it just a weak chip? coded for a specific router and we should look for some specifics when choosing an router? Help us out here other then saying its our machine with no way of actually fixing it.

     

    WiFi will always (also in 2021) be less reliable than ethernet. That has nothing to do with 10+ yr old ideas but with 100+ yr old physics. There will always be more interference on the 2.4Ghz band (try wifi near a microwave) and 5Ghz (not supported by the printers btw) only works well when you are really near to the AP. Ethernet with UTP has near to none interference (unless your cable is more than 100m). The UM3 and S5 have different wifi chipsets as far as I know. Like I stated before, there a literally hundreds of UM printers that work well with wifi, but we always recommend using ethernet just because it's more reliable (obviously), that does not mean wifi will not work at all. If you have issues, I would suggest to contact support about it.

  • Link to post
    Share on other sites
    Posted · S5 Autodisconnect completely from WIFI
    On 1/21/2021 at 6:31 PM, MaxQ said:

    My S5 has never worked on Wifi. Exact same issue. Stays on for some minutes. It has been like this on three separate locations with totally different network setup (one corporate office, one home with fiber modem supplied wifi and one house with a home wifi router)

     

    I have read so many posts here with people experiencing the same. I have never read that anybody has gotten wifi to work on the S5. Is it totally broken? 

     

    The two last locations I solved it by connecting a LAN cable. But at my current location that is not an option. So back to the old days of USB stick :-/

     

    It would be so nice if anybody had a fix for the wifi.

     

    Has exactly the same... Tried it 5 times. After that I used a LAN cable ...till today.

  • Link to post
    Share on other sites
    Posted · S5 Autodisconnect completely from WIFI
    On 2/13/2021 at 9:09 PM, sj3fk3 said:

     

    WiFi will always (also in 2021) be less reliable than ethernet. That has nothing to do with 10+ yr old ideas but with 100+ yr old physics. There will always be more interference on the 2.4Ghz band (try wifi near a microwave) and 5Ghz (not supported by the printers btw) only works well when you are really near to the AP. Ethernet with UTP has near to none interference (unless your cable is more than 100m). The UM3 and S5 have different wifi chipsets as far as I know. Like I stated before, there a literally hundreds of UM printers that work well with wifi, but we always recommend using ethernet just because it's more reliable (obviously), that does not mean wifi will not work at all. If you have issues, I would suggest to contact support about it.

    No sorry thats just not meaningfully true anymore. Maybe in the extremes that you are talking about like putting your router near a microwave but in everyday normal use that you find in most offices and houses it's just not true. My S5 is about 2 meters from the wifi router which is in the ceiling behind ONE layer of gyproc. EVERYTHING else that connects to wifi in this office has a sustainable connection (or at least reconnects itself seamlessly so that ive never noticed) this includes, 3 smartwatches, 4 phones, 3 laptops, apple tv, a desktop running on wifi, home security cameras... everything runs without issue. You saying that wifi isnt a reliable enough technology to run a 3D printer on is kind of ridiculous.

     

    To be honest the Ultimaker itself is connected to the router via wifi and shows its MAC address is registered and everything. The broken part seems to be the printer connection to Cura or the cloud. Maybe this is where you need to look.

     

    Also the S5 does indeed see (and connect to) 5G connections from the router. We only have 5g in the office and when it stays connected, its via 5G

     

    There may be hundreds of printers that run ok on the specific wifi set up that you have tailored to your specific environment. Im just gonna guess here that you have sold many thousands of printers. There are constant complaints about the wifi connectivity of these printers and have been for years and years. This is really something you should look into instead of just saying that wifi as a technology isn't reliable enough and use a cable...

     

  • Link to post
    Share on other sites
    Posted · S5 Autodisconnect completely from WIFI
    10 minutes ago, Hops said:

    cameras... everything runs without issue. You saying that wifi isnt a reliable enough technology to run a 3D printer on is kind of ridiculous.

     

    Hold on! I did not say that. Not even close! I said: "of course ethernet is going to be more reliable than wifi". I did not say you could not connect you printer with wifi. You even quote me saying that we connect hundreds of printers over wifi. And we use ordinary office wifi like any other office and it works. I also have printers at home and they also 100% connect to wifi. I also have devices that have difficulty connecting to wifi (mostly homebrew ESP32 devices). I do not however have devices that have difficulty connecting over ethernet, because it's more reliable or less prone to interference.

     

    10 minutes ago, Hops said:

    There may be hundreds of printers that run ok on the specific wifi set up that you have tailored to your specific environment. Im just gonna guess here that you have sold many thousands of printers. There are constant complaints about the wifi connectivity of these printers and have been for years and years. This is really something you should look into instead of just saying that wifi as a technology isn't reliable enough and use a cable...

     

    We have been looking into it, we still are looking into it. We have uptil now not found anything technically wrong with the wifi setup that could explain any of the symptoms that are been described by some customers. Maybe we have to look more into the connection between Cura / Digital Factory and the printer. Maybe it's not wifi but something else, or maybe it's 2 completely different issues, but they look the same. Because the WifI on the UM2 and UM3 is completely different from the WiFi on the S3 / S5. Different chipset, different drivers, different OS even.  

  • Link to post
    Share on other sites
    Posted · S5 Autodisconnect completely from WIFI
    On 3/3/2021 at 8:39 PM, sj3fk3 said:

     

    Hold on! I did not say that. Not even close! I said: "of course ethernet is going to be more reliable than wifi". I did not say you could not connect you printer with wifi. You even quote me saying that we connect hundreds of printers over wifi. And we use ordinary office wifi like any other office and it works. I also have printers at home and they also 100% connect to wifi. I also have devices that have difficulty connecting to wifi (mostly homebrew ESP32 devices). I do not however have devices that have difficulty connecting over ethernet, because it's more reliable or less prone to interference.

     

     

    We have been looking into it, we still are looking into it. We have uptil now not found anything technically wrong with the wifi setup that could explain any of the symptoms that are been described by some customers. Maybe we have to look more into the connection between Cura / Digital Factory and the printer. Maybe it's not wifi but something else, or maybe it's 2 completely different issues, but they look the same. Because the WifI on the UM2 and UM3 is completely different from the WiFi on the S3 / S5. Different chipset, different drivers, different OS even.  

    You are right, you didnt say that specifically. I have contacted support and have sent logs a few times, i think i also did so for the UM3 years ago but we never got it solved. I really hope its something that your teams are looking into and that it does one day get fixed. Other then this wifi issue ive had great support from Ultimaker so i dont want you to think i have all around bad feelings. I just hope you understand that its frustrating when the most expensive piece of equipment that we have what uses wifi does not stay connected to the software built for it. 

     

    Has your team been able to reproduce the issue ever or is it like ghost hunting? 

     

     

  • Link to post
    Share on other sites
    Posted · S5 Autodisconnect completely from WIFI
    4 hours ago, Hops said:

    I just hope you understand that its frustrating when the most expensive piece of equipment that we have what uses wifi does not stay connected to the software built for it. 

     

    I think it's almost just as frustrating for us as it is for you. We really care about our product, all the engineers working on our printers do. Everybody in the S-Line firmware team is an active user also for instance, so we all use the printers daily, not only to test but also to create things for ourselves.

     

    4 hours ago, Hops said:

    Has your team been able to reproduce the issue ever or is it like ghost hunting? 

     

    That's the problem! It's like hunting a ghost, we don't see it.. Logs don't show us any information that we can use.. We even had several printers dedicated to testing wifi only (24/7) but don't see any reproducible issues.

     

    You mentioned 5.8Ghz wifi in the other post. While the chipset in some S5's is capable of doing 5Ghz, we don't actually support it. I know that having a so called mixed network (2.4Ghz and 5.8Ghz networks with the same SSID) can cause connection issues. In those cases it's better to append _5G to the 5.8Ghz network. (Many wifi Access Points recommend this by default). 

  • Link to post
    Share on other sites
    Posted · S5 Autodisconnect completely from WIFI

    Got S3. Abandoned WiFi for cable because not working. Constant disconnects.

  • Link to post
    Share on other sites
    Posted · S5 Autodisconnect completely from WIFI
    1 hour ago, Skaegget said:

    Got S3. Abandoned WiFi for cable because not working. Constant disconnects.

     

    Do you maybe have a 2.4 Ghz and 5.8Ghz wifi network with the same SSID?

  • Link to post
    Share on other sites
    Posted · S5 Autodisconnect completely from WIFI
    18 hours ago, sj3fk3 said:

     

    Do you maybe have a 2.4 Ghz and 5.8Ghz wifi network with the same SSID?

    Yes ..

  • Link to post
    Share on other sites
    Posted · S5 Autodisconnect completely from WIFI
    1 hour ago, Jonas98 said:

    Yes ..

     

    Ah, that might very well be the issue. Could you try to append the 5G SSID with _5G for instance? I think that might solve your problem.

  • Link to post
    Share on other sites
    Posted (edited) · S5 Autodisconnect completely from WIFI
    On 3/30/2021 at 11:22 AM, sj3fk3 said:

     

    Ah, that might very well be the issue. Could you try to append the 5G SSID with _5G for instance? I think that might solve your problem.

    Okey. But sadly this is no Option for me. I use a FritzBox with some Mesh repeaters. This works fine. Everywhere are the same SSID and I dont have to switch between WIfis. Every other (about  20 Devices) works fine with this. So I dont want to change a nice working System just because of one Device is not able to handle this. If you know what I mean. So I have to use LAN till this is been fixed.

    Edited by Jonas98
  • Link to post
    Share on other sites
    Posted · S5 Autodisconnect completely from WIFI

    Please add me to the list of S5 users with problems connecting the wifi. 

     

    Thanks to the UM team for continuing to look at this and the understanding that it's frustrating for all of us (UM and UM users). My S5 had no issues for about 6 months and then it just would not work one day. It won't even accept the WiFi ON selection now! I have tried to setup the WiFi about a dozen-thousand times on 5 different networks. I have tried the resets, renaming the WiFis, changing the WiFi settings, changing the S5 settings, changing the location of the WiFi and the printer, and several other things. The only thing that works is to plug the computer directly into the printer or passing via the USB card. While that is a fix, it limits one of the greatest advantages of the printer - the ability to create and monitor from separated locations.

     

    I'm willing to try anything to help fix this problem. Since you're not experiencing it there at UM, I would humbly suggest working through a few users like the ones who are sending you the problems. If you tell me what to try, I can video my attempt or document it in any way that might help - and I'm sure others would be willing to do the same.


    Thanks!

  • Link to post
    Share on other sites
    Posted · S5 Autodisconnect completely from WIFI
    On 4/8/2021 at 6:52 PM, mjhangge said:

    I'm willing to try anything to help fix this problem. Since you're not experiencing it there at UM, I would humbly suggest working through a few users like the ones who are sending you the problems. If you tell me what to try, I can video my attempt or document it in any way that might help - and I'm sure others would be willing to do the same.

     

    Can you tell us a little bit about the wifi setup? If you want just send me a pvt message on the forum. I would be specifically be interested in: Is it: 2.4Ghz / 5Ghz ? Does it use the same SSID? What kind of security? (WEP/WPA/WPA2), what is the brand of WiFi access points (or router)?

     

    Also, you could try to setup wifi via USB this way: https://support.ultimaker.com/hc/en-us/articles/360018123920-Network-setup-via-USB- 

  • Link to post
    Share on other sites
    Posted · S5 Autodisconnect completely from WIFI
    On 3/29/2021 at 3:25 PM, sj3fk3 said:

     

    Do you maybe have a 2.4 Ghz and 5.8Ghz wifi network with the same SSID?

    I don't know. I use the wired connection from now on.

    I still have some disconnections though. I have my printer connected both via LAN and Cloud. Could that be a problem?

    The cloud-version of the printer is quicker and more reliable with updates after material- and core changes.

  • Link to post
    Share on other sites
    Posted · S5 Autodisconnect completely from WIFI
    On 5/25/2021 at 2:00 PM, Skaegget said:

    I don't know. I use the wired connection from now on.

    I still have some disconnections though. I have my printer connected both via LAN and Cloud. Could that be a problem?

    The cloud-version of the printer is quicker and more reliable with updates after material- and core changes.

     

    When you say disconnects you mean you don't see the printer online in Cura or when you go to the Digital Factory page? In that case there is a fix on the way for that issue! \o/

  • Link to post
    Share on other sites
    Posted · S5 Autodisconnect completely from WIFI
    21 hours ago, sj3fk3 said:

     

    When you say disconnects you mean you don't see the printer online in Cura or when you go to the Digital Factory page? In that case there is a fix on the way for that issue! \o/

    It got offline in Cura. I don't know its status in Digital Factory at that time.

  • Link to post
    Share on other sites
    Posted · S5 Autodisconnect completely from WIFI
    35 minutes ago, Skaegget said:

    It got offline in Cura. I don't know its status in Digital Factory at that time.

     

    Ok, thanks! We will have a fix for that in version 6.5 (expect around 3rd week of june). 

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Ultimaker turns 10: A look back
        Ultimaker is turning 10 years old and that means it is story telling time! We'll explore 2010-2014, traveling through the evolution of the business from the Protobox and Ultimaker Original, to the major leaps forward with the Ultimaker 2 and Ultimaker 3.
          • Like
        • 0 replies
      • Ultimaker Transformation Summit
        Visit our virtual showroom and learn more about the Ultimaker ecosystem!
        • 14 replies
      • New here? Register your Ultimaker for free 3D printer onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 4 replies
    ×
    ×
    • Create New...