Jump to content
SandervG

Ultimaker Cura | a new interface

Recommended Posts

Posted · Ultimaker Cura | a new interface

It looks like the answer is yes to both, but you can get the plugin you need from the creator here:

 

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
Posted (edited) · Ultimaker Cura | a new interface

Yesterday I tested the Cura V4 Beta.
1.) Extremely slow on both Mac OSX 10.13.5 and Windows 7.
2.) I don't know what to teach people at Gui-Design today but this user interface gets the badest grade.
- I know my model. I just want to slice it. So it has a much higher priority for me to see the settings than the model. The window with the settings is fixed in size, but on my 24"monitor has only a third of the screen height. For what purpose should I use the whole area below it? Maybe sticky notes? It's an endless scrolling and clicking back and forth. Today you have a bigger monitor, or like me multiple monitors. If the programmers only have money for 17 inches, you should make a collection. Why, when the surface is being renovated, not even the possibility to arrange the palettes on several monitors in the desired size is built in, that would be a step forward. 
What I see here is just the arrangement of familiar elements according to questionable taste. This has nothing to do with "new user interface". 
Since the interface already disqualifies itself on such a low level, the speed is again so extreme in the basement, I don't see the learning ability of the programmers either. With the 3.6 it went well, after upgrade to osx 10.13.5. Apart from the new user interface, I don't see any great changes. So what's going on?
I'm out testing new versions. You start with 0 every time. 

greetings
and a healthy, quiet and successful new year
ralf

 

Edited by ralfg

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura | a new interface
2 hours ago, goose_busters said:

will this version include the CR-X model so we don't have to manually do it?

As far as I can see, no-one contributed a profile, so it won't be in the next beta.

  • Like 1

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura | a new interface
2 hours ago, nallath said:

As far as I can see, no-one contributed a profile, so it won't be in the next beta.

will it be easy to set up as it is a dual extruder printer? I had tried to put the profile onto cura 3.6.0 but failed 

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura | a new interface

New interface looks good, but....

 

As a Linux user, I am still faced with the issue of every time I start (since 3.5), it complains that my printer profiles are corrupted (they're not).  This happens even after I have written down the pertinent info, and recreated them (Hictop 3DP-17 & Hictop CR-10S).  Also, since it is an appimage and not a true installer, getting plugins to work takes a bit of hacking.  I really wish there were packages that could be installed.  Having been a Linux developer for ~20 years, this is really easy to do, for both deb and rpm based distributions (which covers the vast majority).  Or, maybe look into the new Snap package system as it is getting strong traction on both sides.

 

I'll do a more extensive test this weekend when I have more time.

Share this post


Link to post
Share on other sites
Posted (edited) · Ultimaker Cura | a new interface

At machine settings i do not see the extruder settings folder. Must change "Number of Extruders" to 2 and then change back to 1. After restarting Cura 4.0 Beta the extruder settings folder disappeared again.

Same behavior at Cura 3.2.1.

Extruder settings.jpg

Edited by PatK

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura | a new interface
On 1/3/2019 at 4:11 PM, GrueMaster said:

New interface looks good, but....

 

As a Linux user, I am still faced with the issue of every time I start (since 3.5), it complains that my printer profiles are corrupted (they're not).  This happens even after I have written down the pertinent info, and recreated them (Hictop 3DP-17 & Hictop CR-10S).  Also, since it is an appimage and not a true installer, getting plugins to work takes a bit of hacking.  I really wish there were packages that could be installed.  Having been a Linux developer for ~20 years, this is really easy to do, for both deb and rpm based distributions (which covers the vast majority).  Or, maybe look into the new Snap package system as it is getting strong traction on both sides.

 

I'll do a more extensive test this weekend when I have more time.

We used to be on deb packages, but it was a complete nightmare. Mostly due to Ubuntu, which has a dreadful history of suddenly no longer supporting dependencies.
Why would you need to hack anything to get plugins to work? You can install them via the marketplace or just place them in the ~/.local/share/cura/4.0/plugins/ folder.

As for the corruption thing, could you share your logs / local configuration?

Share this post


Link to post
Share on other sites
Posted (edited) · Ultimaker Cura | a new interface

What @Steverc1572 and @PatK say together just about describes an issue. I'm guessing it's the same issue.

 

PSA: please be a bit more descriptive when reporting something. What did you do (step-by-step), what did you think would happen, and what happened instead. Especially that step-by-step description is often important to be able to reproduce a bug. A bug that cannot be reproduced often can not be fixed. Finally, it is very helpful if you mention what printer type you added in Cura.

Edited by ahoeben
  • Like 3

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura | a new interface

@ahoeben Ok, here are the steps (with my win10 64bit pc)

1. Start Cura 4.0.0 beta

2. At preferences go to printers and add a new custom FFF printer

3. Go to this printer machine settings (default is 1 extruder) and there is the extruder tab

4. Quit Cura and start it again, the extruder tab is gone now! This is the issue.

5. To get the tab back go to machine settings and select i.e. 2 extruders. Two extruder tabs appear

 

Sorry for my bad english

 

Regards Patrick

  • Thanks 1

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura | a new interface
11 hours ago, PatK said:

@ahoeben Ok, here are the steps (with my win10 64bit pc)

1. Start Cura 4.0.0 beta

2. At preferences go to printers and add a new custom FFF printer

3. Go to this printer machine settings (default is 1 extruder) and there is the extruder tab

4. Quit Cura and start it again, the extruder tab is gone now! This is the issue.

5. To get the tab back go to machine settings and select i.e. 2 extruders. Two extruder tabs appear

 

Sorry for my bad english

 

Regards Patrick

I've just tried to reproduce this with the latest 4.0 code, and it seems to have already been fixed.

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura | a new interface
6 hours ago, nallath said:

I've just tried to reproduce this with the latest 4.0 code, and it seems to have already been fixed.

I downloaded the beta again from this link:

https://ultimaker.com/en/products/ultimaker-cura-software/download-request/209

Deinstalled old V4beta and reinstalled actual version.

Then created a new Custom FFF printer. After relaunching Cura the extruder tab is still vanished here.

Maybe you have a alter version then me?

Version number is still the same v4.0.0-beta

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura | a new interface

 

2 minutes ago, PatK said:

I downloaded the beta again from this link:

https://ultimaker.com/en/products/ultimaker-cura-software/download-request/209

Deinstalled old V4beta and reinstalled actual version.

Then created a new Custom FFF printer. After relaunching Cura the extruder tab is still vanished here.

Maybe you have a alter version then me?

Version number is still the same v4.0.0-beta

I'm running it from source, which has a number of changes not yet in the released beta.

  • Like 1

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura | a new interface

I have written a plugin that adds an alternative interface to the Cura 4.0 beta. A beta version of that plugin can be downloaded here:

 

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura | a new interface
On 1/3/2019 at 6:04 AM, nallath said:

As far as I can see, no-one contributed a profile, so it won't be in the next beta.

I have one written and waiting on Creality's permission to submit it. How do I go about submitting the profile?

 

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura | a new interface
5 minutes ago, Steverc1572 said:

I have one written and waiting on Creality's permission to submit it. How do I go about submitting the profile?

 

Why would you need permission from Creality to post their publicly available settings to an open source project?  Other than the name reference, I'm not seeing a problem here, and if they complain about using their name in a project w/o permission, the Cura devs can fire back as they have an old release they ship with their systems.

 

Just file a pull request on the github repo and get it in.

Share this post


Link to post
Share on other sites
Posted (edited) · Ultimaker Cura | a new interface
On 1/4/2019 at 8:36 AM, nallath said:

We used to be on deb packages, but it was a complete nightmare. Mostly due to Ubuntu, which has a dreadful history of suddenly no longer supporting dependencies.
Why would you need to hack anything to get plugins to work? You can install them via the marketplace or just place them in the ~/.local/share/cura/4.0/plugins/ folder.

As for the corruption thing, could you share your logs / local configuration?

As a former Ubuntu developer, I have yet to see a 'sudden drop in dependency support' that isn't discussed with the community during release development.  Unless you are referring to LTS-LTS changes (which occur over a 2 year period with 3 development releases in between to cover this exact issue).  Spin up VMs in your CI environment to do your testing.  Very low overhead for this, and it can be automated quite well (this is what I do and have 10+ years just with Jenkins).

 

As to hacking to get plugins to work, I can't remember off the top of my head but one plugin that was broken in the appimage (3.4 release iirc) required a few extra steps to get working semi-stable (as long as I didn't kill that cura session, it worked fine).  I think what it was is the marketplace dumps plugins into the tmp directory structure created when runnning the appimage, not in the .local/share/... directories.  Will have to check when I am back home on that system (and have spare time again).

 

As to the file corrupt errors, I posted them once before (3.5 beta or 3.6 beta).  Also, why does it keep resetting the values for my filaments (spool weight, cost, link to Amazon for refill in the notes)? 

Edited by GrueMaster

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura | a new interface
8 hours ago, Steverc1572 said:

How do I go about submitting the profile?

 

These are typically added in a "Pull Request" on Github.

* clone the master branch of the Cura repository,

* create a new branch on your cloned repository

* add your files to that branch

* use the Github interface to create a pull request of your branch against the origin master branch

 

https://github.com/ultimaker/cura

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura | a new interface
On 1/10/2019 at 2:41 AM, GrueMaster said:

As a former Ubuntu developer, I have yet to see a 'sudden drop in dependency support' that isn't discussed with the community during release development.  Unless you are referring to LTS-LTS changes (which occur over a 2 year period with 3 development releases in between to cover this exact issue).  Spin up VMs in your CI environment to do your testing.  Very low overhead for this, and it can be automated quite well (this is what I do and have 10+ years just with Jenkins).

 

As to hacking to get plugins to work, I can't remember off the top of my head but one plugin that was broken in the appimage (3.4 release iirc) required a few extra steps to get working semi-stable (as long as I didn't kill that cura session, it worked fine).  I think what it was is the marketplace dumps plugins into the tmp directory structure created when runnning the appimage, not in the .local/share/... directories.  Will have to check when I am back home on that system (and have spare time again).

 

As to the file corrupt errors, I posted them once before (3.5 beta or 3.6 beta).  Also, why does it keep resetting the values for my filaments (spool weight, cost, link to Amazon for refill in the notes)? 

I totally understand that stuff gets talked over with the community. That's fine. But to be honest, I don't have the time to get engaged with those discussions, mostly because linux is already such a small part of our user base (and i also realise that there is no way in hell that you can get everyone happy).
In the past, Ubuntu suddenly dropped support for python 3.4 in favor of python 3.5. Unfortunately at that point we really really depended on it. Which caused a bunch of extra work that we basically never have to do for the appimages.


As far as the plugins not working, it might have been a bug once, but it's working just fine now.
 

  • Like 1

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura | a new interface

It would appear that the beta is only available for Windows - is there a Linux 4.0 beta available someplace ?

Share this post


Link to post
Share on other sites
Posted · Ultimaker Cura | a new interface

Scroll down to the BETA section, all the way on the bottom of the page @smartavionics linked to.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!