Jump to content
Ultimaker Community of 3D Printing Experts
Feversham

[Bug] Cura 3.6.0 Hangs at launch

Recommended Posts

I've been using Cura for a little while, 

 

I ran into an issue recently where the tool just stopped running. It would attempt to launch, show the splash image then an empty window that would just hang. 

 

Tried restarting, uninstalling, reinstalling, nothing worked. 

 

Luckily I found a way to fix it...

 

I have a laptop dock with 2 attached monitors. The only different thing (to my knowledge) was I used one of the attached monitors for the first time and it kept trying to launch on that secondary screen. Which It was having trouble doing.

 

I unlplugged the dock and used just with the screen on the laptop. And it opened up! 

 

I attached the log of a clean install of cura showing the symptom below if it helps resolve the bug permanently.

 

Hope that helps someone who might've had the same issue I did. It might be display related, unplug all secondary monitors and see if that helps. 

 

Cheers.

_run1_cura.log

Share this post


Link to post
Share on other sites
On 2/10/2019 at 4:48 PM, ahoeben said:

Make sure Cura is on your primary screen when you close it. 

 

This is the work-around I use right now but it's pretty limiting. Especially now that I have some reliable triggers that will cause it to crash on the other screen (on creation of a context menu, selecting between model view and layer view). 

 

Whats the best way to get this in front of one of the developers to take a look at? 

Share this post


Link to post
Share on other sites

It helps if you are a client that's about to buy 100 Ultimaker printers 😉 More seriously though, it has been an issue for a long time, and it never got enough traction to get it fixed unfortunately. I don't know who's the "product owner" of Cura these days. The product owner has a large say in what gets fixed and what will remain open for the foreseeable future because there is too much to do. You could chime in here: https://github.com/Ultimaker/Cura/issues/4427

 

As another, more permanent workaround, it should be possible to write a plugin that forces Cura to always start on the primary screen. Thing is I already have 10 plugins to maintain and update between versions...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • Ultimaker Cura | a new interface
      We're not only trying to always make Ultimaker Cura better with the usual new features and improvements we build, but we're also trying to make it more pleasant to operate. The interface was the focus for the upcoming release, from which we would already like to present you the first glance. 
        • Like
      • 130 replies
    • "Back To The Future" using Generative Design & Investment Casting
      Designing for light-weight parts is becoming more important, and I’m a firm believer in the need to produce lighter weight, less over-engineered parts for the future. This is for sustainability reasons because we need to be using less raw materials and, in things like transportation, it impacts the energy usage of the product during it’s service life.
        • Like
      • 12 replies
×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!