Jump to content
DivideByZero

How to infil a gap between the bed and the 1st layer

Recommended Posts

Posted · How to infil a gap between the bed and the 1st layer

Hi,

 

I have found a STL I would like to print, but there is a small air gap between some of the bottom of the STL and the bed, say roughly 50% of it.

 

What I would like to do (as I have no CAD skills at all yet) is just extend that print so all of the base touches the bottom.

 

Is there an option to do this in Cura? Some kind of support setting I guess, but not sure what is best.

 

Thanks in advance.

Share this post


Link to post
Share on other sites
Posted · How to infil a gap between the bed and the 1st layer

If you can't fix it in any CAD program, you can cheat using the Support: use the same extruder for support than for your print, set the 'Support Z Distance', 'Support X/Y Distance' and 'Minimum Support X/Y Distance' to 0, and activate 'Enable Support Roof'.

 

This will basically turn the layer into a fully filled-in layer, and there will be virtually no difference between that layer of support and the object you want to print, save for some oddly orientated lines if one looks at the bottom of the object closely.

  • Thanks 1

Share this post


Link to post
Share on other sites
Posted · How to infil a gap between the bed and the 1st layer
1 hour ago, DivideByZero said:

What I would like to do (as I have no CAD skills at all yet) is just extend that print so all of the base touches the bottom.

 

What I do in this case, when the bottom of the model is not really flat, I move to model into the build plate by setting the Z direction to a small negative value until you get a flat bottom. 

 

Forget the values here, it just to illustrate what I mean. 

167165606_Bildschirmfoto2019-02-01um14_43_27.png.2328542a670386157109b2aeddbb9c3c.png

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
Posted · How to infil a gap between the bed and the 1st layer

Don't forget to uncheck the option that makes CURA place the model automatically on the bed, else it might not accept your new Z value.

  • Like 2

Share this post


Link to post
Share on other sites
Posted · How to infil a gap between the bed and the 1st layer
3 minutes ago, Brulti said:

Don't forget to uncheck the option that makes CURA place the model automatically on the bed, else it might not accept your new Z value.

Good point, thanks! I never have this option checked so I forgot about it.

Share this post


Link to post
Share on other sites
Posted · How to infil a gap between the bed and the 1st layer

Thanks both.

 

For this model I will probably use the support solution as I don't want to lose any of the bottom layer as if it did that it would really notice on this model. However, that's a handy tip for most models.

 

I am working on the assumption that if the bottom is cut off on the Z axis, it just doesn't print, rather than it all bunches up?

Share this post


Link to post
Share on other sites
Posted · How to infil a gap between the bed and the 1st layer

Aye, the printer won't print anything that is below Z=0.

  • Thanks 1

Share this post


Link to post
Share on other sites
Posted · How to infil a gap between the bed and the 1st layer

Hum, this seems to have done something strange.

 

I use a specific machine startup code, it does a wipe and activates mesh bed levelling etc.

 

With these support options on, the wipe is now happening at layer 3, having done layer 1 and 2 of the print already.

 

It's odd, I can see the travel for the hot end starts in L1 from where it ends in L3 (after the wipe).

 

Any idea what would cause that? This is new since the support options, so I am guessing they are somehow jumping the queue?!

L1.JPG

L2.JPG

L3.JPG

Share this post


Link to post
Share on other sites
Posted · How to infil a gap between the bed and the 1st layer

I have no idea since I don't know the first thing about coding and use the standard CURA code. Maybe you should deactivate your wipe for this specific print?

Share this post


Link to post
Share on other sites
Posted · How to infil a gap between the bed and the 1st layer

I'd sooner not, I get a lot better start of print with it. It does a purge and a wipe so the PLA is good to go when it starts the actual print.

 

Might be that I have to manually edit the gcode once it is created then, which I have not done before, but how hard can it be... LOL.

Share this post


Link to post
Share on other sites
Posted · How to infil a gap between the bed and the 1st layer

OK, well, I don't think this is a CURA issue as looking at the gcode, the first thing that happens is my startup code.

 

I guess this must be Octoprint doing something strange.

 

Thanks again. 🙂

Share this post


Link to post
Share on other sites
Posted · How to infil a gap between the bed and the 1st layer

Yeah, Octopint gcode viewer issue as it printed normally at the start, just waiting for L3 to make sure it doesn't double wipe (though I don't think it will as it's only in the gcode once).

 

Share this post


Link to post
Share on other sites
Posted · How to infil a gap between the bed and the 1st layer
3 hours ago, Brulti said:

Don't forget to uncheck the option that makes CURA place the model automatically on the bed, else it might not accept your new Z value.

Just for the records, I tested it now and it also works when you have enabled the option. I also thought that it will prevent it, but you never stop learning. 🙂 

  • Like 2

Share this post


Link to post
Share on other sites
Posted · How to infil a gap between the bed and the 1st layer
35 minutes ago, Smithy said:

Just for the records, I tested it now and it also works when you have enabled the option. I also thought that it will prevent it, but you never stop learning. 🙂 

 

Interesting. It looks like the option's name is even more descriptive that I thought: 'Automatically drop model to the build plate.'

It does indeed drops the model if it's not touching the buildplate, but doesn't raises it if it's below it.

As you say, @Smithy, you never stop learning! 😏

  • Like 1

Share this post


Link to post
Share on other sites
Posted · How to infil a gap between the bed and the 1st layer

But I not sure if the behavior was different in a previous version of Cura. I also have in mind that you have to disable this option. But I rarely need to lower the model, so I don't know.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!