Jump to content
Ultimaker Community of 3D Printing Experts

Recommended Posts

Posted · Help again with the Mark 2

ok following on from another thread I have my head 1 printing under S3D so I know the bed is level and the heat setting are working but when I try and print with cura with two heads the print is messy not sticking to bed is there a way of adjusting the z offset in cura OR am I missing a crucal part of the callobration…. I have done the z adjust as per the instructions but still not sticking.....

 

I have never used cura so the learning curve is vertical..

 

advise please 

  • Link to post
    Share on other sites
    Posted · Help again with the Mark 2

    What exactly do you try (or what have you done differently in Cura)?

    - The first printhead works flawless with Cura and S3D?

    - The second printhead is problematic with both slicers, or only with Cura?

    - What exactly means "print is messy"?

  • Link to post
    Share on other sites
    Posted · Help again with the Mark 2

    tinkergnome thanks for the reply

     

    I could not get the calibration print to stick no matter what I did with the z (piece of paper under the nozzle) I tried with slight pressure, I tried with quiet a grab on the paper, got no improvement..

     

    so I went to S3D and tried printing with the left head only and it stuck no problem

     

    went to cura and loaded in a cone,  when I eventually worked out how to set a dual head print up,  I ran it this afternoon, the heaters worked, the tool head's swapped and did there own skirt BUT left head was still to far away from the build plate and the second head was worse,,,, I let the code run for 1 layer by then the prime pillar was being scraped off by the second head.....(messy)

     

    I thought there might be a global offset for the Z (as in S3D) but couldn't find anything like that (even on web) 

     

    I presume you think it is a Z issue (being to far away from bed) but as I said I have been tight and lose with the Paper...

    I haven't tried the two heads in S3D YET I wanted to get cura to work first.

     

    your thoughts would be appreciated,,, spent a lot of time on this it would be good to say its finished???😃

     

     

  • Link to post
    Share on other sites
    Posted · Help again with the Mark 2
    27 minutes ago, bob-hepple said:

    I thought there might be a global offset for the Z (as in S3D) but couldn't find anything like that (even on web) 

     

    Do you use a (global) z offset in S3D?

    In this case you could try the ZOffset-Plugin from @ahoeben. It's not exactly the same (it does post-processing), but the result should be similar. The plugin should be available in the "Marketplace".

    If the plugin is active, you'll find the z offset setting in the group "Build Plate Adhesion".

  • Link to post
    Share on other sites
    Posted · Help again with the Mark 2
    9 hours ago, bob-hepple said:

    what do you think is my btm line problem

     

    Hard to guess...

     

    You said, it works fine with S3D and the main printhead.

     

    I would make a second test with the same object in S3D, but printed only with the second printhead

    If this works too, you have verified that the extruder z offset ("Adjust Z" for Extruder 2) is correct.

     

    This would rule out any problems with your hardware setup as well.

    I remember that you made some kind of "mixed" setup with a new and an "old" printhead? I think, the height (of the printheads) is not the same and one needs an adapter or so...? (but my "selective retention" may be wrong...)

    More data would help - pictures? What's you z offset ("Extruder offset" on the printer) a.t.m.?

    The nozzle of the coupled second head should be 2-3mm lower than the main one.

     

    After that ios checked, i would do the same in Cura (with similar settings) and compare the generated gcode files (start script and first layer) to find any differences (esp. of the z-coordinates).

  • Link to post
    Share on other sites
    Posted (edited) · Help again with the Mark 2
    16 hours ago, bob-hepple said:

    I could not get the calibration print to stick no matter what I did with the z (piece of paper under the nozzle) I tried with slight pressure, I tried with quiet a grab on the paper, got no improvement.. 

     

     

    Presume your talking about the 'normal' UM setup here to ensure bed is level etc??

     

    Have you then gone into the 'dual head' area under maintenance and set the Z values in there? (can't confirm the name at the moment as printer running, but it's section for Mark2 upgrade!).

     

    Go to the bottom of the available options there until you see Z adjustment, and adjust head 1 until the nozzle just touches the glass bed (you can sometimes hear a change of tone from the stepper motor when it touches) then save.

     

    Go back up to change extruder head, and select head 2 - back down to Z adjustment and do the same as above - you should then be good to go. Just change extruder head back to 1 before leaving the dual  head options unless you want to do a print using the second head - cura output when using standard single head will work with head 2 fine, as long as head 2 is mounted first before starting the print 👍

    Edited by navigator
  • Link to post
    Share on other sites
    Posted · Help again with the Mark 2

    navigator thanks for the reply I di exactly that spent ages with different tensions on the paper I'm gonna try this again if still cant get it to stick then I will download ZOffset tweak and try that,, thanks for all the advise appreciated.

  • Link to post
    Share on other sites
    Posted · Help again with the Mark 2
    17 minutes ago, bob-hepple said:

    navigator thanks for the reply I di exactly that spent ages with different tensions on the paper I'm gonna try this again if still cant get it to stick then I will download ZOffset tweak and try that,, thanks for all the advise appreciated.

     

    When doing the Z distance in the Mark 2 area in the maintenance menu  for head 1 & 2, you do not need to use paper - just do what it says and get the bed to just touch the printer nozzle!!

    Just ensure your nozzles are clean and do not have remnants of material hanging off them which will affect the distances.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Ultimaker Transformation Summit

        On April 20 - April 23 we will host the Ultimaker Transformation Summit. Come talk to us via Live chat and get inspired by any of our relevant presentations!
        • 6 replies
      • New here? Register your Ultimaker for free 3D printer onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 0 replies
    ×
    ×
    • Create New...