Jump to content
Ultimaker Community of 3D Printing Experts

Activate second backup Extruder as main extruder


Recommended Posts

Posted · Activate second backup Extruder as main extruder

last week i blown up my motordriver from the main extruder(E1) motor on the ultiboard rev v2.1.4

now i try to set my second extruder port (E2) as main but it doesn't work.

first i select the right board (72) from the board list and after that i search for board 72 in the pin tab and change the 3 pinning numbers from E0 To E1 but no power at all do i miss a step?

i also tried to change the X/Y pinning and that work the change direction. the extruder morot also work when i put the connector in the Z motor port.

 

marlin board selection printscreen.jpg

marlin motor pinning printscreen.jpg

  • Link to post
    Share on other sites
    Posted · Activate second backup Extruder as main extruder

    I haven't tried, but it sounds like you are making the correct changes.

    The Ultimaker board has id 72 in the Marlin code.

    Change:

    #define E0_STEP_PIN         42
    #define E0_DIR_PIN          43
    #define E0_ENABLE_PIN       37

    #define E1_STEP_PIN         49
    #define E1_DIR_PIN          47
    #define E1_ENABLE_PIN       48

     

    into:

    #define E0_STEP_PIN         49
    #define E0_DIR_PIN          47
    #define E0_ENABLE_PIN       48

    #define E1_STEP_PIN         -1
    #define E1_DIR_PIN          -1
    #define E1_ENABLE_PIN       -1

     

    Too bad you didn't post your modified code, so we can't verify your changes.

  • Link to post
    Share on other sites
    Posted · Activate second backup Extruder as main extruder

    Thank you for your anwer Carlo i make a printscreen of the uploaded pin changes.

    can you tell me why you fill in -1 values at E1? is it to disable?

     

    today i check the pins again and i saw the follow line:

    #define MOTOR_CURRENT_PWM_E_PIN 46

    i think i need change this pin number also because both extruder connectors have 4 pins, but no idea wich pin number i need to fill in?

    motor current pin.jpg

  • Link to post
    Share on other sites
    Posted · Activate second backup Extruder as main extruder
    2 hours ago, roald said:

    today i check the pins again and i saw the follow line:

    #define MOTOR_CURRENT_PWM_E_PIN 46

    i think i need change this pin number also because both extruder connectors have 4 pins, but no idea wich pin number i need to fill in?

     

    There's only a single motor current setting for both E1 and E2. This pin is connected to both stepper drivers.

     

    Speaking of stepper drivers: are you sure that your mainboard has the 5th stepper driver chip soldered on? On many newer 2.1.4 boards it is not installed at all. But the connector is obviously present, so this should be not the issue?

     

  • Link to post
    Share on other sites
    Posted · Activate second backup Extruder as main extruder

    Yes, I did set the values to -1 to disable the functions. Not really a big thing, but since your other driver chip is broken this feels like the right thing to do.

     

    Like I said before, the changes you made seem fine.

    The code you posted is slightly different from my local copy. Just checking, but what machine type do you have (UM2, UM2+)?

    And, what is the link to the git repository you are using?

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    ×
    ×
    • Create New...