Jump to content
Ultimaker Community of 3D Printing Experts

BLTouch on UM2+ : got it working on Marlin bugfix 1.1.x but hotend fan won't spin up


Recommended Posts

Posted · BLTouch on UM2+ : got it working on Marlin bugfix 1.1.x but hotend fan won't spin up

Recently upgraded my UM2+ to BLTouch for auto bed levelling, with Marlin bugfix 1.1.x firmware.

Auto bed levelling works fine, but the hotend fan won't spin up after the hotend reaches and exceeds the trigger temperature. 

I know the fan itself works and is hooked up correctly because I re-uploaded the stock UM2+ firmware and watched it correctly spin the fan when hotend heated up. 

 

Been all through the firmware and can't find where it references the hotend fan pin on J34 (PJ6).   I've even been through the UM2 original firmware and can't find that pin referenced anywhere either.  

 

Any ideas what could be wrong?

 

 

  • Link to post
    Share on other sites
    Posted · BLTouch on UM2+ : got it working on Marlin bugfix 1.1.x but hotend fan won't spin up

    Howdy Tinkergnome, thanks for the speedy reply.  I figured it had to be hardwired somewhere.  I will give that a shot.

     

    Any chance the tinkergnome firmware could be augmented to support BLTouch?  That firmware is my preference to run on a farm of UM2+ printers.  

  • Link to post
    Share on other sites
    Posted (edited) · BLTouch on UM2+ : got it working on Marlin bugfix 1.1.x but hotend fan won't spin up

    Is there some trick to getting that code to work?  Have added the UM2 specific code into temperature.cpp to set the PORTJ register but no joy.  hotend fan still inoperative.  I am thinking of just hot-wiring the fan to +5V and let it spin continuously.  That's the electrical engineer's solution to a software problem. 😎

     

    Quote
    DDRJ |= _BV(6);
      if (current_temperature[0] > EXTRUDER_AUTO_FAN_TEMPERATURE
      #if EXTRUDERS > 1
      || current_temperature[1] > EXTRUDER_AUTO_FAN_TEMPERATURE
      #endif
      #if EXTRUDERS > 2
      || current_temperature[2] > EXTRUDER_AUTO_FAN_TEMPERATURE
      #endif
      )
      {
      PORTJ |= _BV(6);
      }else{
      PORTJ &=~_BV(6);
      }

     

    Edited by lowracer
  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Ultimaker Transformation Summit

        On April 20 - April 23 we will host the Ultimaker Transformation Summit. Come talk to us via Live chat and get inspired by any of our relevant presentations!
        • 6 replies
      • New here? Register your Ultimaker for free 3D printer onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 0 replies
    ×
    ×
    • Create New...