Jump to content
Luke6805

Cura is not turning on fan during print

Recommended Posts

Posted · Cura is not turning on fan during print

Hey guys recently updated to cura 4.0 and having a problem. i actually started having this problem on cura 3.6 but it is still persisting. Basically my main fan that is pointed at the nozzle is not being turned on during the print. I have all my settings within the program to have it on, yet while it is printing the fan is not being activated. 

 

If i send the gcode directly to the printer the fan turns on so the hardware is definetly working. I even tried adding some gcode to the "Start G-code" text box setting the fan to turn on in the beginning and it works but once it starts printing the fan turns back off. Any idea on how to fix this issue? 

 

Printer is the Monoprice Maker Select V2 so it may be an issue because there is no preset for it but i doubt it because the fan was working previously but seemed to randomly start having this issue a couple weeks ago

Share this post


Link to post
Share on other sites
Posted · Cura is not turning on fan during print

I don't think it's the gcodes. I think it's a wire that opens up when the head moves to the middle of the print.

 

But first check for all gcodes that start with "M1".  There is probably only 10 or 20 in your entire gcode file.  And look them all up here:

http://reprap.org/wiki/G_code

Share this post


Link to post
Share on other sites
Posted (edited) · Cura is not turning on fan during print

I have same situation here, since i upgraded to cura 4, the fan won't start after the 1 layer. 

 

Screen Shot 2019-04-01 at 09.29.53.png

Edited by dicky

Share this post


Link to post
Share on other sites
Posted (edited) · Cura is not turning on fan during print

Yes same here. I can confirm that the issue is with cura 4.0.0 I think, going back to cura 3.4.1 no issues but with cura 4.0.0 I get no can as well.

Edited by vis321

Share this post


Link to post
Share on other sites
Posted · Cura is not turning on fan during print

I think I figured it out.

 

Cura 4.0.0 now has a new feature where you can select different number of cooling fans.

I looked at the gcode exported from cura 3.4.1 and the gcode from cura 4.0.0. I noticed the M106 command was exported as M106 S255 P1. I compared this to the gcode exported from cura 3.4.1 which just had M106 S255. I first tried to modify the gcode to have M106 S255 P0, AND THAT WORKED Later in my investigation I noticed in the "Machine Settings" under "Extruder 1", there is a new setting called "Cooling Fan Number", by default it was set to 1, hence the "P1" reference in the gcode.

Change the option under "Cooling Fan Number" from 1 to 0. 

 

After that I saw cura exported the gcode as before M106 S255. I popped in sd card and it seemed to solve my issue. I am sure maybe in the Marlin configuration you could change the fan number as well but this seemed to fix my issue.

 

Hope this helps! 

fan number.JPG

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Our picks

    • Ultimaker Cura 4.0 | Stable available!
      Ultimaker Cura 4.0 is mainly focused on the improved user interface and cloud integration.
      As always, we want to collect your user feedback for this release. If there are any improvements you can think of, feel free to mention it here and help us to shape the next release.
      • 65 replies
×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!