Jump to content
Digibike

UM3E druckt nach FW-Update nicht mehr von USB?!

Recommended Posts

Posted · UM3E druckt nach FW-Update nicht mehr von USB?!

Kommando zurück mit s3d......

Also man kann die Datei auswählen, er heizt dann das Bed und komischerweise alle beide Extruder....

Wenn er sie warm hat dann fängt er mit dem Linken an das Skirt zu Drucken, ist auch normal da ich momentan mit Links Drucken möchte.... Was aber dann passiert ist mir ein Rätzel....Er fährt nach rechts, zieht die rechte Düse runter und versucht dann mit links weiter zu Drucken, da die rechte Düse noch unten ist Druckt er dann natürlich mit der linken Düse in der Luft....

 

Also: Warum heizt er beide Hottends und zieht die rechte Düse nach dem Skirt Drucken runter 😞 !?

Werde das mal als Antwort an Simplify3d schicken.....

 

Was ich noch mit der Firmware habe ist ein nervender surrender Ton, wenn ich das Rädchen bewege ist es weg, kommt dann aber irgendwann zurück....

 

Aber ansonsten muss ich Ultimaker mal loben, echt toll was sie aus den Ulti3 noch raus geholt haben....selbst das Drucken über der Handy App funktioniert nun mit nen Vorschaubild, die Benachrichtigung funktioniert nun auch....Druck gestartet, abgebrochen und beendet 🙂

Share this post


Link to post
Share on other sites
Posted · UM3E druckt nach FW-Update nicht mehr von USB?!

das mit beiden hotends ist klar - sind ja beide im Header mit 100 Grad gesetzt... Mußt löschen...

Aber das andere ist wie bei mir, nur dass er das gleich macht. Schau mir jetzt dann das Cura-File dazu

von Smith an, vielleicht entdecke ich ja die Ursache... 

 

Gruß, Digibike

Share this post


Link to post
Share on other sites
Posted · UM3E druckt nach FW-Update nicht mehr von USB?!

Vielleicht könnt ihr auch mal ein S3D gcode teilen dann könnte ich auch mal drüber schauen (habe Cura und S3D im Einsatz)

An besten von gleichen Teil, oder von S3D eine Factory Datei

  • Like 1

Share this post


Link to post
Share on other sites
Posted · UM3E druckt nach FW-Update nicht mehr von USB?!

Vielen dank für das Angebot! Smithy hat es für mich in Cura gesliced und ich das selbe Teil - ähnliche

Einstellungen soweit möglich war - eingestellt mit Simplify gesliced.

Was mir auffiehl, ist das da der rechte Extruder bei Simplify "resetet" wird - könnte das da mit rein spielen?

Header müßte eigentlich mittlerweile soweit passen, aber nach der Purge-Raupe passiert etwas, was

Ihn veranlasst, den rechten Extruder in Druckposition zu bringen - inkl. Offset - aber, wie gewünscht,

druckt er mit dem linken Extruder. Das kann aber gar nicht gehen, da der Linke durch den Offset viel

zu hoch steht...

 

Gruß, Digibike

Bassbox_fuss.gcode Cura_Bassbox_fuss.gcode

Share this post


Link to post
Share on other sites
Posted · UM3E druckt nach FW-Update nicht mehr von USB?!
1 hour ago, Digibike said:

nach der Purge-Raupe passiert etwas, was

Ihn veranlasst, den rechten Extruder in Druckposition zu bringen - inkl. Offset - aber, wie gewünscht,

druckt er mit dem linken Extruder.

 

Die M218 -Zeilen sind verdächtig...

Wenn nur mit dem einem Extruder gedruckt wird, wird kein "Tool Change Script" gebraucht. Das würde ich entfernen und aus dem Header können die Zeilen mit ";EXTRUDER_TRAIN.1.*" auch noch weg (es kann aber auch sein, das die nicht weiter stören).

 

Ich hab aus reiner Neugier noch eine andere Frage:

Was ist eigentlich mit den (langen) Kommentaren, die S3D normalerweise in die Datei schreibt? Hast Du die gelöscht, oder kann man das irgendwo abschalten?

Share this post


Link to post
Share on other sites
Posted · UM3E druckt nach FW-Update nicht mehr von USB?!

Hi,

 

hast also auch den M218 im Verdacht... Mir fiehl auf, dass Cura a) diesen nicht verwendet und b) nur einmal T0 setzt. Bei Simplify wird T0 gesetzt - klar, Core 1 (Linker Core) wird angewählt. Dann wird aufgeheizt und stabiliziert, Purge-Raupe gezogen. Soweit ok, aber dann resetet er den rechten Core (?) und setzt erneut T0. Ich vermute mal, dass ist der Moment, wo der Drucker dann diese Wechselaktion startet (rechten runter, rechten hoch und rechten wieder runter - was der Gcode so allerdings eigentlich nicht hergibt - kommt die FW da mit den schnellen Wechsel ohne Befehle eventuell durcheinander und weiß nicht mehr, dass der rechte wieder hoch muß?).

Danach arbeitet der Drucker den Gcode wie gewohnt ab - nur eben, dass er die Offset-Höhe von Core 2 hat und diesen unten gelassen hatte...

Welche "Langen Kommentare" meintest du? Ich habe eigentlich nur die Header-Daten von Extruder 1 entfernt, weil a) nicht gebraucht wird und b) er dann Core 1 ebenfalls aufheizt.

 

Gruß, Digibike

Share this post


Link to post
Share on other sites
Posted · UM3E druckt nach FW-Update nicht mehr von USB?!

Symplify 3d hat sich gemeldet 🙂 

Weiß irgend jemand ob Ultimaker an den Fehler der Firmeware arbeitet !? Ne Rückmeldung geben sie ja gerade nicht....

 

 

----------------------------

 

Alexander,

 

Thanks for your reply. Please give this new profile a shot. I've reproduced the described behavior in our office this morning and updated the profile to account for that issue.

 

Thanks,

 

----------------------------

Ultimaker_3ExtendedFIRM5.2.8_PLA_RightExtruder_2019-03-29.fff.zip

  • Like 1

Share this post


Link to post
Share on other sites
Posted · UM3E druckt nach FW-Update nicht mehr von USB?!

Von welchem sprichst du? Das, was ich beschrieben habe? Bei mir hatte er nur festgestellt, dass in Cura ein

anderer Material-Code wie in Simplify wäre und ich das von Hand korrigieren müßte.

Das hat aber, meines Wissens, rein gar nichts mit dem Fehler an sich zu tun. Cura könnte, wenn "On Air"

gedruckt würde, nur den passenden Core für das geforderte Material wählen, soweit ich das mitbekommen

habe, aber per Stick ist alles fest zugeteilt, welcher Code auf welchen Core zugreif...

Schau ich mir mal an - ich vermute ja eher, dass der UM nicht (mehr) mag, wenn ein nicht benutzter Core

(unnötig) resetet wird... Der Header macht jedenfalls keine Probleme mehr - läuft ja bis zur Purge-Raupe

problemlos, nur danach...

 

Gruß, Digibike

Share this post


Link to post
Share on other sites
Posted · UM3E druckt nach FW-Update nicht mehr von USB?!
21 hours ago, Digibike said:

Welche "Langen Kommentare" meintest du? Ich habe eigentlich nur die Header-Daten von Extruder 1 entfernt, weil a) nicht gebraucht wird und b) er dann Core 1 ebenfalls aufheizt.

 

Naja, wenn ich mit S3D den gcode speichere, werden immer am Anfang ca. 200 Zeilen Kommentare hinzugefügt mit allen Einstellungen. Ich dachte das wäre normal und ließe sich nicht ändern. Aber bei Dir scheint das nicht so zu sein?

Deswegen frage ich mich, ob es irgendwo in S3D eine Option gibt, mit der man das abschalten kann...?

 

Share this post


Link to post
Share on other sites
Posted · UM3E druckt nach FW-Update nicht mehr von USB?!

Soll ich dir meine Factory schicken? Diesbezüglich habe ich eigentlich nichts geändert - zumindest nicht

bewußt. 

Übrigens ändert das entfernen des M218 zum reseten des rechten Core rein gar nichts. Ist also eine

"Sackgasse". Mal weiter schauen. Der Fehler muß doch zu finden sein...

 

Gruß, Digibike

Share this post


Link to post
Share on other sites
Posted · UM3E druckt nach FW-Update nicht mehr von USB?!

Das neue File sieht gut aus! Ich habe zwar das Filament raus und Ihn leer drucken lassen, aber er reagierte, wie er soll!

Core 2 (rechts) hoch und mit Core 1 (Links) Purge Raupe gezogen und dann direkt los und Briem drucken. Endlich! Muß mal schauen, was es letztlich war, was das Problem verursachte...

Habe das File mal angehängt, falls es jemand interessiert/vergleichen will.

Tinkergnome, das Factory ist ganz frisch geladen (kam heute erst - noch nichts geändert und einfach gespeichert um zu testen.

Gruß, Digibike

 

 

Bassbox_fuss.gcode Factory_fuer_FW5_2.zip

Share this post


Link to post
Share on other sites
Posted · UM3E druckt nach FW-Update nicht mehr von USB?!

Nachdem ich das zweite Factory File von S3d bekommen habe läuft S3d nun wieder richtig.....ersteinmal Herzlichen Dank an Simplify fur den schnellen Support, haben immer inerhalb von einem Tag geantwortet.....jetzt muss Ultimaker nur noch das Fiepen in der nächsten Firmeware weg bekommen und ich bin zufrieden 😎

Share this post


Link to post
Share on other sites
Posted · UM3E druckt nach FW-Update nicht mehr von USB?!

Bei eurer neuer config ist das M218 weg und der Düsen Versatz wird von S3D direkt in gcode geschrieben

Siehe G-Code -> Werkzeug-Versatze auf G-Code Koordinaten anwenden

 

Ich finde aber das eigentlich der Düsenversatz Sache der Firmware ist und nicht des Slicer.

Ich habe die Einstellung (Werkzeug-Versatze auf G-Code Koordinaten anwenden) immer gemieden weil dann die Layervorschau so gut wie nutzlos ist

 

Gruß

  • Like 1

Share this post


Link to post
Share on other sites
Posted · UM3E druckt nach FW-Update nicht mehr von USB?!
11 hours ago, zerspaner_gerd said:

Ich finde aber das eigentlich der Düsenversatz Sache der Firmware ist und nicht des Slicer.

 

Beim UM3 (oder S5) und Cura sind beide dafür zuständig. In Cura sind auch die 18.0mm festgelegt (man sieht es, wenn man einen Cura (Dual-) gcode in einem anderen Viewer betrachtet). Und nur das "Finetuning" übernimmt die Firmware.

 

Ich vermute der Vorteil dabei ist, das der Slicer schon im Vorfeld (grob) den Düsenversatz berücksichtigen kann und damit "weiß", ob der Druck wirklich in den Bauraum passt.

Wenn man z.B. eine ganze Druckerfarm mit Cura Connect betreibt, ist letzteres ziemlich wichtig, weil dann automatisch der passende Drucker für jeden Druckauftrag gewählt wird.

 

 

  • Like 1

Share this post


Link to post
Share on other sites
Posted · UM3E druckt nach FW-Update nicht mehr von USB?!
18 hours ago, alexbln01 said:

etzt muss Ultimaker nur noch das Fiepen in der nächsten Firmeware weg bekommen

Das ist wirklich störend, aber ich bin drauf gekommen, dass man die Menü Ebene wechseln muss um das Fiepen abzustellen. Zuerst dachte ich es ist nur im Main Menü, da es immer weg war wenn ich z.B. ins Material Menü gewechselt bin. Doch wenn ich dann drucke und er ist fertig, dann fiepst er wieder obwohl ich im Material Menü bin. Ein Wechsel dann wieder retour ins Hauptmenü und das Fiepen ist weg. 

 

Anscheinend wird duch einen Menüwechsel irgenwas zurückgesetzt, was vorher da Fiepen verursacht.

  • Like 1

Share this post


Link to post
Share on other sites
Posted · UM3E druckt nach FW-Update nicht mehr von USB?!

Hoffen wir mal das dies dann nach den nächsten Update weg ist.....

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!