Jump to content
Ultimaker Community of 3D Printing Experts

Firmware 5.2.8 Update failed


Recommended Posts

Posted · Firmware 5.2.8 Update failed

Seems Ultimaker's "Agile" SW development methods are taking their toll not only with Cura, but also with firmware... thanks for this thread, I'll b extra extra careful with UM firmware updates...

  • Link to post
    Share on other sites
    Posted · Firmware 5.2.8 Update failed
    27 minutes ago, PrintMan666 said:

    I have fixed the Update Problem!

    I open Port 123 (NTP Timeserver) at the Firewall. After this, Update to Firmware 5.2.8 works fine!

    Hope this will help you, too!

    Can you please explain how to do it?

     

  • Link to post
    Share on other sites
    Posted · Firmware 5.2.8 Update failed
    16 hours ago, PrintMan666 said:

    I have fixed the Update Problem!

    I open Port 123 (NTP Timeserver) at the Firewall. After this, Update to Firmware 5.2.8 works fine!

    Hope this will help you, too!

    A network without firewall fixed it.

    TX PrintMan666 👍

    TX UM 🤨

  • Link to post
    Share on other sites
    Posted · Firmware 5.2.8 Update failed
    17 hours ago, Mosher said:

    Can you please explain how to do it?

     

    If you have the Printer inside a company network ask your Admin to open NTP Port 123 for your Printer.

    Or you take Printer to your Home and connect to your Internet-Connection. Normaly there is no firewall for outgoing Traffic.

     

  • Link to post
    Share on other sites
    Posted · Firmware 5.2.8 Update failed

    I've tried opening port 123 and disabling my home firewall, but it's the same old story from my Ultimaker 3:

     

        Downloading new firmware...

     

        Checking new firmware...

     

        Failed to verify firmware update.

     

    I should say that it is printing, and with no obvious problems, but I'm still uneasy about having to run a testing version of the firmware, rather than a stable version.

  • Link to post
    Share on other sites
    Posted · Firmware 5.2.8 Update failed

    did you try open Port 123 UDP ?

    otherwise disable complete outgooing firewall for update

  • Link to post
    Share on other sites
    Posted · Firmware 5.2.8 Update failed

    so my Printer finally got the update.

    I have contacted system- administrator and they passed the traffic from the printer around firewall.

     

  • Link to post
    Share on other sites
    Posted · Firmware 5.2.8 Update failed
    58 minutes ago, PrintMan666 said:

    did you try open Port 123 UDP ?

    otherwise disable complete outgooing firewall for update

     

    It looks like my hub's port forwarding defaulted to TCP protocol when I tried to open port 123.

     

    Manually selecting UDP fixed the problem and my UM3 is now running 5.2.8.20190320.

     

    Thanks to all who contributed helpful advice here and especially to PrintMan666 for this solution.

     

    If anyone associated with Ultimaker reads this, please consider adding something about opening port 123 UDP to the notes at the foot of your Update the Ultimaker 3 Firmware article.  Thanks.

     

     

    PS.  Whilst reading around this topic, I found that some people had experienced a similar problem setting up Apple TV's.  Some had fixed it by the methods in our discussion: opening port 123, disabling their firewall, or doing the setup somewhere without a firewall.  One other trick, which I've not seen mentioned here, was to set up via a mobile hotspot on their phone (YMMV).

  • Link to post
    Share on other sites
    Posted · Firmware 5.2.8 Update failed

    Well, here we go again.  I'm now seeing the same problems trying to update to 5.2.11.

     

    The port forwarding settings (i.e. open Port 123 UDP, which solved the issue with 5.2.8) are still in effect.  However, in the time-honoured IT tradition of "turning it off and on again", I've:

    1. Enabled firewall
    2. Disabled firewall
    3. Deleted the port forwarding rule
    4. Recreated the port forwarding rule

    None of this has made any difference, so it seems new solution is required.

     

    I've also tried updating via USB, but the process still ends with the same message:

     

          Failed to verify firmware update.

     

    At least this update doesn't require installation of an intermediate "testing" version, so the machine is failing back to a stable firmware.

     

    As with the 5.2.8 issues, any help would be greatly appreciated.  Thanks.

  • Link to post
    Share on other sites
    Posted · Firmware 5.2.8 Update failed
    On 4/12/2019 at 7:19 AM, KonprintMPE said:

    A network without firewall fixed it.

    TX PrintMan666 👍

    TX UM 🤨

     

    Does your DHCP server advertise another NTP server to use? If no NTP servers are available either from the local network or the internet, the printer will indeed not have a valid time.

    We've fixed the reliance of a correct time with the current stable, but of course, this will only help you when updating from 5.2.11 to a next version.

  • Link to post
    Share on other sites
    Posted · Firmware 5.2.8 Update failed
    On 5/16/2019 at 10:58 AM, weevil said:

    Well, here we go again.  I'm now seeing the same problems trying to update to 5.2.11.

     

    The port forwarding settings (i.e. open Port 123 UDP, which solved the issue with 5.2.8) are still in effect.  However, in the time-honoured IT tradition of "turning it off and on again", I've:

    1. Enabled firewall
    2. Disabled firewall
    3. Deleted the port forwarding rule
    4. Recreated the port forwarding rule

    None of this has made any difference, so it seems new solution is required.

     

    I've also tried updating via USB, but the process still ends with the same message:

     

          Failed to verify firmware update.

     

    At least this update doesn't require installation of an intermediate "testing" version, so the machine is failing back to a stable firmware.

     

    As with the 5.2.8 issues, any help would be greatly appreciated.  Thanks.

    I'm getting the same error "Failed to verify firmware update.". Tried both via Internet and USB.

    Currently on 5.2.8.20190320 attempting to update to 5.2.11.20190503

     

    Any ideas?

  • Link to post
    Share on other sites
    Posted (edited) · Firmware 5.2.8 Update failed
    1 hour ago, cdrose said:

    I'm getting the same error "Failed to verify firmware update.". Tried both via Internet and USB.

    Currently on 5.2.8.20190320 attempting to update to 5.2.11.20190503

     

    Any ideas?

     

    Please just read the posts above. They answer your question.

    Edited by Dim3nsioneer
  • Link to post
    Share on other sites
    Posted · Firmware 5.2.8 Update failed
    8 minutes ago, Dim3nsioneer said:

     

    Please just read the posts above. They answer your question.

     

    Ah I see so regardless of internet or USB updating it still needs to connect to the internet to verify. I'll give it ago then opening port 123 UDP

  • Link to post
    Share on other sites
    Posted · Firmware 5.2.8 Update failed

    Yes, but only for that update as the firmware team removed that check again in 5.2.11.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    ×
    ×
    • Create New...