Jump to content
Ultimaker Community of 3D Printing Experts

Mark 2 Firmware


Recommended Posts

Posted · Mark 2 Firmware

Does the Mark 2 Firmware handle the temp setting in a different way to when I just used Tinkergnomes Firmware for the STD Um2..

 

reason I'm asking I'm getting a lot of banding in the prints which I have never suffered with on the UM2,, my last print I noticed the temp reading on the display is going from 200 to 220 all the time during a print,, it climbs up then drops, continually.  Im using S3D which I have always used before the Mark 2 mod and in my Temp Setting I have 215 for first layer them 210 ????????????

 

and yes I am using just the left head only (original head) the other is parked and NOT being used at all.. and is cold.

  • Link to post
    Share on other sites

    Posted · Mark 2 Firmware

    Tinkergnome

     

    Thank you for replying the oscillation has only raised its head since I installed the new Mark two, On the original head I am still ysing the original heater but I am using 3dsolex blocks,, I did suspect it was the Pid setup (sub-optimal) don't know this,, but I had done a Auto pid tune, but as I said the Temp is ramping up by 20 then back down although I don't know where 200c comes in when S3d has it set to 210,, (could be creeping)??.

     

    The link gives plenty of warnings but light on how to?? for the novice,,, I have Pronteface installed so might have a look on that,, Ill also print the link off and have a go at manually setting 

     

    at the moment my settings for Head 1 are

    Kp 18.83

    Ki 3.64

    Kd 24.38

     

    this was after a Auto Tune

  • Link to post
    Share on other sites

    Posted (edited) · Mark 2 Firmware

    I have:

    Kp 8.5

    Ki 0.75

    Kd 45

    I remember I spent some 2 hours on figuring out how it works best. 

    The autotune parameters were not as good.

    I have a 50W heater in the hotend and it used to overshoot significantly with the autotune parameters.

    Edited by conny_g
  • Link to post
    Share on other sites

    Posted · Mark 2 Firmware

    well, the "Troubleshooting" says for example:

    > Heater oscillates in temperature, and the average is at or very close to what you set the temperature to: Increase D

     

    That's what i mean.

    Simply change the values at the printers menu.

     

    Regarding autotune: just don't use it. It has never worked well in Marlin (if at all). Autotune usually suggests quite useless values...

    The default values for an UM2 should give you a starting point for manual tuning.

     

    // Ultimaker2 (25W heater)
       P 10.0
        I 2.5
        D 100.0

     

    // Ultimaker2+ (35W heater)
        P 12.0
        I 0.75
        D 55.0

     

  • Link to post
    Share on other sites

    Posted · Mark 2 Firmware

    Thanks for all the advise I tried the link and I thought you could alter the Kp Ki Kd values while you are printing ??

     

    but I also hooked the Um2 to Pronteface and ran

    M303 E0 S210 C10

    and this gave me 

    Kp14.31

    Ki 1.46

    Kd 34.98  then added these values manually into the UM2 and saved this was better but at any temp change say from 215 to 210 it would drop to 202 and then climb to 210

     

    I did the same procedure for the second head but altered the line to

    M303 E1 S210 C10

     

    and in putted the results again manually...

     

    so I'm guessing the pid is not reacting quick enough to stop the drop in temp and recover to change??? 

     

    the link you sent me suggest you can do this while printing ??? is that correct... if so how the menu is not available while printing???

     

    again thanks for the advise...

     

     

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • The Ultimaker Showcase — October 14. What's new?
        Your dear friends at Ultimaker have some exciting news and insights for you!
         
        • 0 replies
      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 8 replies
    ×
    ×
    • Create New...