Jump to content
Stratos

Retraction speed has no effect

Recommended Posts

Posted (edited) · Retraction speed has no effect

Hey guys, hope you are all doing well. "First" time Ultimaker Cura user here. It is way simpler than what I was used (repetier host), but the default settings turned out way better than my heavily edited slic3r from repetier prints.

But I came across 2 problems (I have to test one to make sure). So the one I would like to get rid of now is this. Changing the retraction speed has no effect on the actual retraction. It is still the same speed no matter if it is 40mm/s or 120mm/s, it is always slow compared to slic3r (where I had 60mm/s). So, how do I "repair" it? How can I make it retract faster (because now it kinda waits for it to retract)?

Thanks in advance 😉.

 

P.S.: I guess that I am using the latest Cura as I downloaded it on Saturday.

Edited by Stratos

Share this post


Link to post
Share on other sites
Posted · Retraction speed has no effect

Welcome @Stratos, it's hard to give you an answer without seeing your settings so please save the project (File -> Save) and attach the resulting .3mf file to this thread. Thanks.

Share this post


Link to post
Share on other sites
Posted · Retraction speed has no effect
4 minutes ago, smartavionics said:

Welcome @Stratos, it's hard to give you an answer without seeing your settings so please save the project (File -> Save) and attach the resulting .3mf file to this thread. Thanks.

It's literally default 0.3mm but with 60 mm/s retraction speed.

CFFFP_Pi_Camera_2020_Adapter.3mf

Share this post


Link to post
Share on other sites
Posted · Retraction speed has no effect

Thanks for the file. I sliced it and looked at the gcode and the retractions are happening at 60mm/S and then I changed the retraction/prime speed to 40mm/S and the gcode changed as expected so I really don't know why you are seeing the behaviour that you are.

 

This image shows the retraction speed in the gcode to be 2400mm/min = 40 mm/S which is what it should be.

 

Screenshot_2019-04-23_23-02-33.thumb.png.f3ab4bfcd52d786c22d114b3c3b1d45e.png

Share this post


Link to post
Share on other sites
Posted · Retraction speed has no effect

Well, no matter what, it won't go faster then it's "default" speed (which is the 25 mm/s). I don't know what to do. It is seriously anoying.

Share this post


Link to post
Share on other sites
Posted · Retraction speed has no effect

Perhaps the extruder acceleration and/or jerk has been set very low? I don't think Cura does that.

Share this post


Link to post
Share on other sites
Posted (edited) · Retraction speed has no effect
2 hours ago, smartavionics said:

Perhaps the extruder acceleration and/or jerk has been set very low? I don't think Cura does that.

I am using default marlin. How do I "repair" it then.

Edited by Stratos

Share this post


Link to post
Share on other sites
Posted · Retraction speed has no effect
16 hours ago, Stratos said:

Well, no matter what, it won't go faster then it's "default" speed (which is the 25 mm/s). I don't know what to do. It is seriously anoying.

 

short question:

Where do you see a 'default' retraction speed and how do you know that it is set to 25 mm/s? Is this related to Cura or is it a firmware setting?

 

Share this post


Link to post
Share on other sites
Posted · Retraction speed has no effect
8 minutes ago, tinkergnome said:

 

short question:

Where do you see a 'default' retraction speed and how do you know that it is set to 25 mm/s? Is this related to Cura or is it a firmware setting?

 

Extra fast - 0.3mm > Material >Retraction speed - 25 mm/s
It is in Cura.

Share this post


Link to post
Share on other sites
Posted (edited) · Retraction speed has no effect
Quote

/**
 * Default Max Feed Rate (mm/s)
 * Override with M203
 *                                      X, Y, Z, E0 [, E1[, E2[, E3[, E4]]]]
 */
#define DEFAULT_MAX_FEEDRATE          { 300, 300, 5, 25 }
 

The above is from Marlin configuration.h

 

It seems Marlins default max feedrate limits the extruder tp 25mm/s

Try sending A M203 E50 and see if it allows you to go faster.

 

Edited by obewan

Share this post


Link to post
Share on other sites
Posted · Retraction speed has no effect
On 4/24/2019 at 4:41 PM, obewan said:

The above is from Marlin configuration.h

 

It seems Marlins default max feedrate limits the extruder tp 25mm/s

Try sending A M203 E50 and see if it allows you to go faster.

 

That did the trick. Thank you.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Our picks

    • Ultimaker Cura 4.0 | Stable available!
      Ultimaker Cura 4.0 is mainly focused on the improved user interface and cloud integration.
      As always, we want to collect your user feedback for this release. If there are any improvements you can think of, feel free to mention it here and help us to shape the next release.
      • 98 replies
×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!