Jump to content
Matioupi

UM3 X/Y Calibration pattern repeatability

Recommended Posts

Posted (edited) · UM3 X/Y Calibration pattern repeatability

Hello,

despite the fact that I need to manually push the filament with current 5.2.8 firmware on my UM3, I just tried the following :
doing 2 X/Y calibration patterns in a row. I mean : I did one calibration pattern, up to the end, entering the X/Y offset values, and immediatly did a second one (after cleaning the glass plate).
I ended up with 2 very different set of values :
X:5 / Y -7 the first time

X : -5 / Y : - 17 the second time
What could be wrong here ? Nothing changd between both prints (same material, same printcore, a few minutes between both prints)

Edited by Matioupi

Share this post


Link to post
Share on other sites
Posted · UM3 X/Y Calibration pattern repeatability

I went a little further with testing today :

Initial state was X : 5 Y : 17
I ran a first calibration test :
result : X : 7 Y : 13

I ran a second calibration test :

result X : -5 Y : -18
While going back to the menu to check if the values where properly taken into account, I saw in the "change offset" that signs looks like they were not taken into accoun (or badly).
At this stage, I went for a full printer reset (factory + cura connect)
After reset, I manually entered the last test results : -5 / -18
I ran a third calibration test :

result :
X : 7 Y : 13

I checked though change offset, this time, the correct values are displayed.

I ran a forth calibration test
result : X : -5 Y : -18
I ran a fifth calibration test :
result X : 7 Y : 13

At this stage, it seems clear that there is something wrong as the calibration oscilates between 2 set of values, so I went for the following :

I manually changed the offsets to 0 / 0 and ran a sixth calibration


result is X : 2 Y : -5
 

I can see that 2 = 7 -5 and -5 = 13 - 18

At this stage, I would think that there is some kind of bug in the firmware... something like "relative vs. absolute" offset management.


 

Share this post


Link to post
Share on other sites
Posted · UM3 X/Y Calibration pattern repeatability

There was a bug where the XY calibration pattern would apply the last set offsets to the patterns where it should have reset them to zero during the pattern printing. This was fixed in the v5.2.11 release of today.

  • Like 1

Share this post


Link to post
Share on other sites
Posted · UM3 X/Y Calibration pattern repeatability

thank you for the confirmation... i think this was the biggest bug for me in 5.2.8

Share this post


Link to post
Share on other sites
Posted · UM3 X/Y Calibration pattern repeatability
8 hours ago, CarloK said:

There was a bug where the XY calibration pattern would apply the last set offsets to the patterns where it should have reset them to zero during the pattern printing. This was fixed in the v5.2.11 release of today.

 

Seems the v5.2.11 release notes are incomplete then...

https://ultimaker.com/en/ultimaker-firmware

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Our picks

    • Ultimaker Cura 4.0 | Stable available!
      Ultimaker Cura 4.0 is mainly focused on the improved user interface and cloud integration.
      As always, we want to collect your user feedback for this release. If there are any improvements you can think of, feel free to mention it here and help us to shape the next release.
      • 96 replies
×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!