Jump to content
Ultimaker Community of 3D Printing Experts

5.2.11 Broke my WiFi on S5


Recommended Posts

Posted · 5.2.11 Broke my WiFi on S5

I got a message in Cura today saying there was a firmware update for the S5 and I went ahead and installed on the printer.

After it installed and the printer restarted I can't connect to my WiFi anymore.

The WiFi option is grayed-out on the menu.

I tried resetting Cura Connect - No go

Factory Reset - No Go

 

Please help as using Ethernet is not an option in my workshop and I need to fix this ASAP.

 

Thanks

  • Link to post
    Share on other sites
    Posted · 5.2.11 Broke my WiFi on S5

    In 5.2.11 we fixed a WiFi problem where two modules could be loaded in the wrong sequence and hence failing, a software problem called a 'race condition'. Those problems are difficult to tackle since a lot of external factors make the code fail or pass.

     

    So, when you people report the WiFi still fails I'd like to get more details since all our internal tests succeeded and 'it fails' isn't enough info to get us searching in the right direction.

    Could you please send me your log files to: https://community.ultimaker.com/messenger/compose/?to=347407

     

  • Link to post
    Share on other sites
    Posted · 5.2.11 Broke my WiFi on S5
    8 hours ago, CarloK said:

    In 5.2.11 we fixed a WiFi problem where two modules could be loaded in the wrong sequence and hence failing, a software problem called a 'race condition'. Those problems are difficult to tackle since a lot of external factors make the code fail or pass.

     

    So, when you people report the WiFi still fails I'd like to get more details since all our internal tests succeeded and 'it fails' isn't enough info to get us searching in the right direction.

    Could you please send me your log files to: https://community.ultimaker.com/messenger/compose/?to=347407

     

    I email you the log file, updated to 5.2.11 and WIFI always grayed out.
    I renialize cura connect and as well as the printer ....
    Thank you for your help

  • Link to post
    Share on other sites
    Posted · 5.2.11 Broke my WiFi on S5

    Our S5 has Wifi greyed out since 5.2.8.

    Today I tried to update to 5.2.11 using USB, but this gives me an error "The firmware has failed to verify, Please retry installation."

    Downloaded the firmware again, tried to install 5.2.11, the same message appears.

    Reset the printer to factory, tried to install 5.2.11, the same message appears.

    Reset Cura Connect, tried to install 5.2.11, the same message appears.

    I'm using the USB stick supplied with the printer.

  • Link to post
    Share on other sites
    Posted · 5.2.11 Broke my WiFi on S5
     
     
    1
    1 hour ago, cabriobob said:

    Today I tried to update to 5.2.11 using USB, but this gives me an error "The firmware has failed to verify, Please retry installation."

     

    Just to confirm; you are on the 5.2.8 version? Did you do the factory reset and try to connect to the Wi-Fi again? For most users, doing a factory reset enables them to go through the Wi-Fi setup. You need to do the setup before you can enable the Wi-fi toggle.


    If you are unable to connect the printer to either Wi-Fi or Ethernet, please contact your sales partner for a solution.

  • Link to post
    Share on other sites
    Posted · 5.2.11 Broke my WiFi on S5
    3 hours ago, WesleySAV17 said:

    I email you the log file, updated to 5.2.11 and WIFI always grayed out.
    I renialize cura connect and as well as the printer ....
    Thank you for your help

    Can you outline the exact steps that you took? For most users, doing the factory reset enables them to do the Wi-Fi setup again and have a connection setup. You need to perform this setup before the toggle becomes available. Can you verify that you did the Wi-Fi setup before you toggled between Wi-Fi and ethernet?

  • Link to post
    Share on other sites
    Posted · 5.2.11 Broke my WiFi on S5
    28 minutes ago, WesleyE said:

     

    Just to confirm; you are on the 5.2.8 version? Did you do the factory reset and try to connect to the Wi-Fi again? For most users, doing a factory reset enables them to go through the Wi-Fi setup. You need to do the setup before you can enable the Wi-fi toggle.


    If you are unable to connect the printer to either Wi-Fi or Ethernet, please contact your sales partner for a solution.

     

    Yes I am on 5.2.8. since then no WIFI. We have no ethernet available.

    When doing a factory reset, Wifi setup is also greyed out.

     

    But that's not the problem, USB firmware upgrade does not work, gives the "The firmware has failed to verify, Please retry installation." error.

     

    I noticed, when unpacking the printer log files, those have time stamps of January 01 1970. (file properties > modified date)

    • Like 1
    Link to post
    Share on other sites
    Posted · 5.2.11 Broke my WiFi on S5

    moved the printer to a location with ethernet, managed to install the new firmware.

    after firmware upgrade still no Wifi setup available (also after a factory reset).

  • Link to post
    Share on other sites
    Posted · 5.2.11 Broke my WiFi on S5
    2 hours ago, WesleyE said:

    Can you outline the exact steps that you took? For most users, doing the factory reset enables them to do the Wi-Fi setup again and have a connection setup. You need to perform this setup before the toggle becomes available. Can you verify that you did the Wi-Fi setup before you toggled between Wi-Fi and ethernet?

     

    I reset the wear settings again, restart the configuration of the tray, coils ... then WIFI, at this time the button is grayed out ...

     

     

    IMG_8437.jpg

  • Link to post
    Share on other sites
    Posted · 5.2.11 Broke my WiFi on S5
    6 hours ago, WesleySAV17 said:

    I email you the log file

    Thanks for sending the log file.

    From a quick look it seems like there is a problem in discovering the WiFi hardware module. This WiFi module is connected to the USB bus and here something goes wrong. We will look into this further and let you know in a couple of days.

  • Link to post
    Share on other sites
    Posted · 5.2.11 Broke my WiFi on S5

    I look forward to your return .... thank you

  • Link to post
    Share on other sites
    Posted · 5.2.11 Broke my WiFi on S5

    Same Problem here,

    I have no ethernet or wifi connection sindce 5.2.8.

    I was happy that a new update 5.2.11 arrived. Tried to udate via USB. Then the message "The firmware has failed to verify, Please retry installation" popped up.

     

    What can I do now?

  • Link to post
    Share on other sites
    Posted · 5.2.11 Broke my WiFi on S5

    Watching .... and waiting.until a proven resolution.

  • Link to post
    Share on other sites
    Posted · 5.2.11 Broke my WiFi on S5
    On ‎5‎/‎14‎/‎2019 at 11:16 PM, CarloK said:

    In 5.2.11 we fixed a WiFi problem where two modules could be loaded in the wrong sequence and hence failing, a software problem called a 'race condition'. Those problems are difficult to tackle since a lot of external factors make the code fail or pass.

     

    So, when you people report the WiFi still fails I'd like to get more details since all our internal tests succeeded and 'it fails' isn't enough info to get us searching in the right direction.

    Could you please send me your log files to: https://community.ultimaker.com/messenger/compose/?to=347407

     

    It seems that our S5 has the same problems as WesleySAV17.

    I'll send you our log files.

  • Link to post
    Share on other sites
    Posted · 5.2.11 Broke my WiFi on S5
    19 hours ago, cmeier38 said:

    I have no ethernet or wifi connection sindce 5.2.8.

    I was happy that a new update 5.2.11 arrived. Tried to udate via USB. Then the message "The firmware has failed to verify, Please retry installation" popped up.

    The releases 4.3.96 & 5.1.93 & 5.2.8 do reject firmware packages where the release date is too far off. Sounds like a great safety feature, but since your printer has no network connection it starts with the default Linux/Unix year set to 1970 and will reject all new firmware from 2019. This safety check has been removed again in the releases 4.3.97 & 5.1.94 & 5.2.11

     

    There are the following solutions for you now being stuck on this firmware version:

    1) Install a temporary ethernet connection and in a few minutes the time will be synchronized. This works even in most organizations with a firewall. Then install the firmware either over this network connection or from USB.

    Create the ethernet connection by either:

    a) For the time of the update, move your printer to a location where there is an ethernet cable.

    b) Or have an ethernet cable across the room to an ethernet wall outlet. Looks ugly, but is only for 10 minutes. Ethernet cables do work up to a length of 100m.

    c) Or connect a WiFi access point as a bridge to your WiFi and the ethernet of the printer.

    2) Connect Cura to your printer.

    Get a pc with Cura and connect this with an ethernet cable to your printer. You can use any ethernet cable (straight or crossed both work). Once Cura recognizes your printer it will synchronize the time and the USB update can be started.

    3) For the UM3 you can install a recovery image from SD card. For the S5 this is not supported by Ultimaker since there is a lethal high voltage inside the machine. For the S5 you can ask your reseller to do this.

    • Like 1
    Link to post
    Share on other sites
    Posted · 5.2.11 Broke my WiFi on S5
    5 hours ago, cabriobob said:

    It seems that our S5 has the same problems as WesleySAV17.

    I'll send you our log files.

    Thanks for sharing the log files. Yes, it's the same problem as WesleySAV17. We are going to look into this and report back next week.

  • Link to post
    Share on other sites
    Posted · 5.2.11 Broke my WiFi on S5

    An intermediate update:

    There are multiple problems with the WiFi that all result in people reporting the WiFi as failing, but have different underlying causes.

     

    For the moment we are focusing on the most pressing issue where the WiFi can not be enabled at all, in the system log this manifests itself by a message "Cannot power cycle wifi". This was present in both logs sent to me.

    We verified over a 100 printers (S5 and UM3) in the Ultimaker office but none showed the error which makes it difficult to fix this problem.

    One clue we have is from a tester who reported that the bug is difficult to reproduce, but once he had it on a printer and then it remained for at least 5 reboots. We want to remove a software component that tries to restore the WiFi power state after a reboot, we don't use this feature but it might interfere with our operations (and less software is better). It just turns out that this software component is integrated in Linux and difficult to disable.

    • Thanks 1
    Link to post
    Share on other sites
    Posted · 5.2.11 Broke my WiFi on S5

    Carlo, thanks for the update.

    Concerning our S5, WiFi never worked from when we installed firmware 5.2.8. This continued with update 5.2.11.

    Prior to 5.2.8 we also had issues with WiFi, but was always resolved after a printer reboot.

  • Link to post
    Share on other sites
    Posted · 5.2.11 Broke my WiFi on S5

    @cabriobob and @WesleySAV17 see your private inbox for a new firmware to test.

    Other people who are willing to help us fix this problem can send me a private message and I will mail a link to a new firmware version that possibly fixes the problem and also logs more information so we are better able to find the culprit if this latest change didn't fix the problem.

  • Link to post
    Share on other sites
    Posted · 5.2.11 Broke my WiFi on S5
    14 minutes ago, CarloK said:

    @cabriobob and @WesleySAV17 see your private inbox for a new firmware to test.

    Other people who are willing to help us fix this problem can send me a private message and I will mail a link to a new firmware version that possibly fixes the problem and also logs more information so we are better able to find the culprit if this latest change didn't fix the problem.

    No it still does not work, I reset the CURA Connect settings as well as the printer.
    Still no WIFI. I sent you the LOG file. Hoping for a solution ...

  • Link to post
    Share on other sites
    Posted · 5.2.11 Broke my WiFi on S5

    I feel sad to hear that the attempted fix didn't work. The change did sound like a promising hypothesis.

     

    Thanks for sharing the log files. The good news is we can exclude several causes now. The bad news is that we'll have to dig deeper and probably will come with another firmware with new logging messages to discover where it goes wrong.

    It seems to go wrong at system startup where the WiFi hardware does not make itself known on the USB bus.

     

    Fixing this WiFi connection problem has our priority and we are working hard on it.

  • Link to post
    Share on other sites
    Posted · 5.2.11 Broke my WiFi on S5
    5 hours ago, CarloK said:

    I feel sad to hear that the attempted fix didn't work. The change did sound like a promising hypothesis.

     

    Thanks for sharing the log files. The good news is we can exclude several causes now. The bad news is that we'll have to dig deeper and probably will come with another firmware with new logging messages to discover where it goes wrong.

    It seems to go wrong at system startup where the WiFi hardware does not make itself known on the USB bus.

     

    Fixing this WiFi connection problem has our priority and we are working hard on it.

    I sent you log files by mail ... waiting for a new firmware ...

  • Link to post
    Share on other sites
    Posted · 5.2.11 Broke my WiFi on S5

    There is a new testing release which is identical to the v5.2.11 release but has extra logging enabled for the WiFi related problems.

    I discovered the WiFi module sometimes short circuits and the new log messages in this version can identify that problem.

    @WesleySAV17 and @cabriobob could you try this on your printer and email me the log files again?

    The image can be downloaded from here and is applicable to both the UM3 and S5.

    This release is to be considered a testing version, i.e. only use it for non-critical applications as this release didn't undergo the normal quality check procedures.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Talking additive | The 3D printing podcast
        Why should we be the only ones asking questions? Join us and ask Jabil all your questions on September 22nd 5pm CET
          • Like
        • 3 replies
      • Ultimaker masterclass: Optimizing your Ultimaker Cura workflow
        Save your seat for either broadcast on September 23.
        What will you learn?
        · Best practices for iterative print preparation and every lesson you should learn from each print
        · The right way to use per-object settings and when they are most useful
        · Easy-to-use resources for anyone who wants to develop their own printer definitions, plugins, or print profiles
        · How to optimize print profile settings and whether to “keep” or “discard” changes
        · When is the right time to export your drawing from CAD? (Based on Ultimaker Cura’s surprising power as 3D control software)
        · And a whole lot more tips and tricks!
         
        How can I join?
        This free masterclass will take place twice:
        1. 11am CEST (5pm SGT, 5am EDT)
        2. 5pm CEST (11am EDT, 8am PDT, 11pm SGT)
          • Like
        • 0 replies
      • Do you use 3D printing at work? Let us know
        It doesn't matter if you are using 1 Ultimaker or 10, there is inspiration in everything. We're looking for ...
        • 1 reply
    ×
    ×
    • Create New...