Jump to content
Ultimaker Community of 3D Printing Experts

CATIA plugin (official thread)


Recommended Posts

Posted (edited) · CATIA plugin (official thread)

A new plugin is joining the plugin family!

The CATIA plugin comes basically with the features you know from the others (if you had a chance to use them before).[1]

 

The plugin can be easily downloaded and installed on my website.

You can find a very basic checklist of what needs to be done here:

https://thopiekar.eu/cura/cad/catia/

 

Enjoy and happy designing!

 

--------------------------------------------

[1] https://thopiekar.eu:5443/cura-cad-integration/CuraCatiaPlugin/commit/9413a9961f0782a152b9bd878adcb23ade342cbb

 

--------------------------------------------

 

image.thumb.png.c0f516b189513f1330b244e35effd75d.png

Edited by thopiekar
  • Thanks 1
Link to post
Share on other sites
  • 9 months later...
Posted · CATIA plugin (official thread)

sorry but i think that catia plugin for cura 4.5 is not compatible

 

or there is some problem with old version, i use the catia plugin for cura 4.2.1

 

now when i run cura 3.5, in open menu, no catpart file is avaible in format files list

 

best regards

  • Link to post
    Share on other sites
    Posted · CATIA plugin (official thread)

    ok i have found the solution

     

    i think that the plugin in compatible with cura 4.4 max

     

    the last version is done for sdk 7.00

    https://git.thopiekar.eu/Cura/CAD/CuraCatiaPlugin/-/tags

     

    and the sdk for cura 4.5 is = sdk7.1.0

    https://github.com/Ultimaker/Cura/wiki/CuraAPI-and-SDK-Versions

     

    but when i start the version for cura 4.4 i have some trouble = no com between catia and CUI module

     

    i have tried nodelock  management from catia to have a local licence but no effect

     

    i am suprised because during installation of this plugin, there is no compatibility version of catia

     

    and for using catia since a long time, i know that version are very different, and scripts or macros in one version of catia are not fully comptaible with the new one.

     

    i try the com between cura v4.4 and catia v5-6 Buid number 25 SP3

     

    best regards 

  • Link to post
    Share on other sites
    • 3 months later...
    Posted · CATIA plugin (official thread)

    Hello @thopiekar,

    As a 3D Experience user, I am quite interested in your plugin as it might capture some features of CATPARTS that are not transferred through STL.

    I tried installing it via the marketplace: after adding and installing it, Cura asks for a restart (perfectly normal). On startup, it then crashes during the plugin loading. I tried that several times on a fresh Cura 4.6.1 install with no success.

    Is this due to some changes with Cura 4.6?

    Have a good evening/day!

    Mischa

  • Link to post
    Share on other sites
    Posted · CATIA plugin (official thread)

    Hello Mischa,

     

    sorry for the late reply. I have missed your message in my busy inbox.

    Is this problem reproducible? So, does it happen every time? 🙂

     

    - Thomas

  • Link to post
    Share on other sites
    Posted · CATIA plugin (official thread)

    Hi Thomas,

     

    No worries, I mean your doing this for the community I could hardly blame you for not responding fast enough ^_^

     

    Si basically yes, if you install the plugin, then start Cura while having the 3d expérience open, it will not open the 3d link window that allows you to attach your 3d expérience session to Cura, and it will crash in the Cura Plugin loading.

    I did not test to attach the 3d expérience session then close Cura, open 3dexp and reopen Cura, that might work, not sure... At the moment I have the plugin removed as I do not import anything from 3d exp for now, but I'll have a look if I have time.

     

    Have a good weekend!

     

    Mischa

  • Link to post
    Share on other sites
    Posted · CATIA plugin (official thread)

    Hello @thopiekar,

    I ran in to the problem when your plugin not working correctly. 

    On the other PC, same configuration... no problem. This is brand new PC, so perfectly clean install, only Cura, your plugin and Catia.

    Do you have any idea?

     

     

    Best regards
    Tomy

    error.PNG

  • Link to post
    Share on other sites
    Posted · CATIA plugin (official thread)

    Hello,

    I have installed your plugin on cura 4.8 in 2 différents computers. In one, it works very well, on the over it can't open the file, you can see here the pb. Have you an idea ? Thanks a lot

     

     

     

    image.thumb.png.4e03da6889e4b36a0ef81019fcf3bc82.png

  • Link to post
    Share on other sites
    Posted · CATIA plugin (official thread)

    @quevreux what version of Catia are you running?

     

  • Link to post
    Share on other sites
    Posted (edited) · CATIA plugin (official thread)

    @tomazslapsak Same question to you! Any other details you can add? 🙂

    Edited by thopiekar
  • Link to post
    Share on other sites
    Posted · CATIA plugin (official thread)

    Hi. I am running V5R19. Tried with SP2 and still no luck.

     

  • Link to post
    Share on other sites
    Posted · CATIA plugin (official thread)

    Hmm, and what does the service checker say? I'm still busy moving to new hardware for my website, therefore my instructions are how.

    It should give us a better impression where the spot of the issue is.

  • Link to post
    Share on other sites
    Posted · CATIA plugin (official thread)

    Here you go:
    image.png.fa41d3e688669c283d5d03b51d535ab8.png


    If there is something that I can help, just let me know. 

  • Link to post
    Share on other sites
    Posted · CATIA plugin (official thread)

    Hmm, the tool claims that the service is registered, but the executable is wrong..

    Is CATIA installed to non-default location? Anything special on your computer, like an enterprise setup by your IT helpdesk?

  • Link to post
    Share on other sites
    Posted · CATIA plugin (official thread)

    Program path: C:\Program Files (x86)\Dassault Systemes\B19

    Nothing special or should I say, I have two PC one enterprise and one personal, both facing same problem. 

  • Link to post
    Share on other sites
    Posted · CATIA plugin (official thread)

    Any progress on this error?

  • Link to post
    Share on other sites
    Posted · CATIA plugin (official thread)

    As discussed with @tomazslapsak in an email conversation, it happens on R19 only.

    I remember that the plugin has been used with R19 before.

     

    Can someone confirm problems here? 🙂

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Ultimaker turns 10: A look back
        Ultimaker is turning 10 years old and that means it is story telling time! We'll explore 2010-2014, traveling through the evolution of the business from the Protobox and Ultimaker Original, to the major leaps forward with the Ultimaker 2 and Ultimaker 3.
          • Like
        • 0 replies
      • Ultimaker Transformation Summit
        Visit our virtual showroom and learn more about the Ultimaker ecosystem!
        • 14 replies
      • New here? Register your Ultimaker for free 3D printer onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 0 replies
    ×
    ×
    • Create New...