Jump to content
poesel

First layer line gap

Recommended Posts

Posted · First layer line gap

Hi,

 

I have the strange problem that Cura 4.1 creates a 'gappy' first layer (see picture). I've aborted the print half way through to show the first two layers.

 

In 3.6 I didn't have that problem. Unfortunately I uninstalled 3.6 with the profile and when I reinstalled it I had the same problem as in 4.1???

 

4.1 is configured as it came out of the box. I only entered the printer I use (Ender 3). The rest is standard.

 

Before someone asks: check bedlevel, nozzle,... It is NOT the printer! I have old nc files of similar objects and they print perfectly. There the first layer is flat as a sheet of paper without any gaps.

 

I've also put a benchy through Cura to make sure it is not the model.

 

Strangely enough if I get past the first layers the printing looks ok. But at this point the print looses adhesion to the bed because of the irregular first layer.

 

So the only point of failure must be in Cura and I guess it is some setting that I have overlooked. Can someone please tell me what to check?

 

 

Thanks!

 

IMG_1886.jpg

test303001.stl 41test303001.gcode

Share this post


Link to post
Share on other sites
Posted · First layer line gap

This is a common problem when the head is too far from the print surface.  You need to find a way to make the print head closer to the print bed.

 

Is there a leveling procedure for the ender3?  Are you sure you are doing it right?  Try creating a program that just does G0 Z0  (nozzle to touching glass) and see if it touches the glass or if instead there is a small gap.

Share this post


Link to post
Share on other sites
Posted · First layer line gap

As I wrote above: it is NOT the printer. I have an old checkerboard file that prints thin layers all over the plate and this prints just fine.

 

However I will check the generated gcode of new and old files. Maybe I can find a difference there.

Share this post


Link to post
Share on other sites
Posted · First layer line gap

I compared the gcode of 'old' and 'new' and couldn't find any significant difference. Z-values the, accelerations, jerk, etc.. all good.

 

I another test: made an object in Inventor, imported it in Cura and sliced it: yellow picture.

Saved that file and imported the gcode back into Cura: blue picture.

 

Yellow has an opaque surface, blue has gaps - but only in layer 1. Layer 2 is good again.

 

Where do these gaps come from? It is impossible that this is a common fault with Cura. Must be something in my settings - but what?

 

Thanks.

gcode_layer1.png

sliced_layer1.png

Share this post


Link to post
Share on other sites
Posted · First layer line gap

90% of the time if your bottom layer has gaps but the rest of the part doesn't then your "leveling" is off.  I don't care if you have autolevel or if you are a leveling expert - your height is probably off.  It should be that when z=0 the nozzle just touches the glass or actually when Z=0.1 it should touch the glass and Z=0 it should try to go through the glass a bit (but something springy instead just moves a tiny bit).

 

To answer your question about saving and reloading the gcode, I'm not sure.  It is trying to guess the width of the lines based on the gcodes and this is hard to do.

 

It is possible you have something out of whack in your settings.  next to the profile where it shows layer height, click on the * there and it pops up a dialog, click the "extruder 1" tab and it should show all the settings that you modified with both default and modified values.  See if you changed anything.  For example, "initial layer flow", "initial layer width".

 

It's also possible that you are just printing too fast on the bottom layer.  For example if you are printing 0.1mm for most layers but 0.3 for the bottom layer and you are printing 40mm/sec on the bottom layer and 60mm/sec on the higher levels, you are still printing 2X the total extrusion rate on the bottom layer and your printer might not be able to print that fast.  Total extrusion rate is line width X layer height X print speed.  Most printers can do 5mm^3/sec.  Some can do up to about 20mm^3/sec with a 0.4 nozzle.  You can print twice as much volume with a 0.6 nozzle and 4X as much volume with a 0.8 compared to a 0.4mm nozzle.

 

Share this post


Link to post
Share on other sites
Posted · First layer line gap

gr5 - I really appreciate your time and your help. You were right that levelling was the cause of the problem. But in a different way.

 

When I switched over to 4.1 I forgot to add 'M420 S1; retrieve mesh' back into the preamble. I have mesh bed levelling activated and without that line Marlin doesn't compensate. Just ran a short test and everything is perfect again.

 

Truly a d'oh moment. 😋

 

Thanks again for your help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!