Jump to content

Fresh install of 4.1 - all great at first launch, OpenGL issues thereafter

Recommended Posts

Posted · Fresh install of 4.1 - all great at first launch, OpenGL issues thereafter

I have installed the latest version and if I launch as part of the installation, everything functions perfectly. Once I close it and re-open, thereafter it no longer has the 3D portion of the display - so no models are showing. Looking at the logs shows many lines like these:


2019-06-17 10:50:24,688 - DEBUG - [MainThread] cura.Machines.QualityManager.initialize [136]: Lookup tables updated.
2019-06-17 10:50:24,707 - DEBUG - [MainThread] UM.Qt.QtRenderer._initialize [181]: Support for Vertex Array Objects: True
2019-06-17 10:50:24,709 - CRITICAL - [MainThread] cura.CrashHandler.__init__ [61]: An uncaught error has occurred!
2019-06-17 10:50:24,712 - CRITICAL - [MainThread] cura.CrashHandler.__init__ [64]: Traceback (most recent call last):
2019-06-17 10:50:24,714 - CRITICAL - [MainThread] cura.CrashHandler.__init__ [64]:   File "X:\4.1\build\inst\lib\python3.5\site-packages\UM\Qt\Bindings\MainWindow.py", line 218, in _render
2019-06-17 10:50:24,716 - CRITICAL - [MainThread] cura.CrashHandler.__init__ [64]:   File "X:\4.1\build\inst\lib\python3.5\site-packages\UM\Qt\QtRenderer.py", line 118, in beginRendering
2019-06-17 10:50:24,718 - CRITICAL - [MainThread] cura.CrashHandler.__init__ [64]:   File "X:\4.1\build\inst\lib\python3.5\site-packages\UM\Qt\QtRenderer.py", line 183, in _initialize
2019-06-17 10:50:24,720 - CRITICAL - [MainThread] cura.CrashHandler.__init__ [64]:   File "X:\4.1\build\inst\lib\python3.5\site-packages\UM\View\GL\OpenGL.py", line 45, in __init__
2019-06-17 10:50:24,722 - CRITICAL - [MainThread] cura.CrashHandler.__init__ [64]: RuntimeError: Try to create singleton 'OpenGL' more than once


This is on a Windows 10 Pro with a NVIDIA 750. All works great if launched as part of the install but fails after subsequent launches. I've tried compatibility settings based on similar (but not identical) situations from the forums with no luck.


Share this post

Link to post
Share on other sites
Posted · Fresh install of 4.1 - all great at first launch, OpenGL issues thereafter

having the same problem, was working fine 2 days ago but now I get the same behavior  nevermind.. I should have just remember the Dogbert troubleshooting method.. shut up and reboot. 


This was cause because (and I'll try to avoid my rant about how much I hate python and the junk code that is written in it) python is using OpenGL which is fine, been around since, at least, the mid 90's but I use remote desktop to get into this machine from work and I made the horrendous mistake of thinking that I could access Cura through my RDP session (to a box that has a gforce 1080)  which I of course can't, I'd really like a valid explanation of why not that averts my rant about the wonders of python since I can acces fusion/vetrix/and a majority of my (non-python) CNC applications. 


At any rate.. if you try to access Cura from an RDP session and then try to access it again from the physical box you're going to see that error.  After I got it back running I tried to RDP from another box to this one and get the exact same behavior.  


Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Our picks

    • Ultimaker Cura 4.0 | Stable available!
      Ultimaker Cura 4.0 is mainly focused on the improved user interface and cloud integration.
      As always, we want to collect your user feedback for this release. If there are any improvements you can think of, feel free to mention it here and help us to shape the next release.
      • 98 replies
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!