Jump to content
ksor

Collision causes offset !!!!

Recommended Posts

Posted · Collision causes offset !!!!

I have a pattern for moulding af wheel - 290mm diameter and various thickness from 5 to 30mm. - drawn in Fusion360.

 

Cura estimates printing time to around 48 hours at 60mm/s ... and I'm sick and tired of waiting so long so I print at 60 (first layer and them 200-220mm/s

 

First time I printed I noticed an OFFSET of 10mm after 20-30 layers and I THOUGHT it was a cable cought by some brackets at the printer - so I had to start all over !

 

Second time I used same method (slowly at the first layer and then full speed 200-220mm/s !

after some time I notived a very loud BANG because the extruder collided with some of the printed material from one printing position to the next - meaning it finishes printing at one spot and the it will move to the next spot and start printing - I beleave it "traveled" 200 mm at a very very hig speed and then BANG and a new OFFSET came up !

(I beleave the offset comes up because the stepper motor looses some steps in the collision)

 

What are this "travel speed" called i Cura - it's NOT "Travel speed" because it's set to 120 mm/s in my profile - way LOWER than my printing speed !

(Note the dimension mm/s ... maybe it should be % instead ?)

Share this post


Link to post
Share on other sites
Posted · Collision causes offset !!!!

You are printing at extremely high speeds (as you know). If your printer is not designed for this, then that may be a contributing factor to your problem.

 

You could try experimenting with the "z hop" option in Cura, and see if that fixes it.

 

If that doesn't help, you'll have to be more patient. Better wait a bit longer for that print and have it finish reliably instead of having to print it three times and throw away half-printed parts all the time.

Share this post


Link to post
Share on other sites
Posted · Collision causes offset !!!!

Yeah, you're right ... patience would help a lot here 😉

 

But I have to use the printer for these patterns for moulding - and they are often big ones - so I'm very keen to get around these very high printing times 20-30 hours - it's un bareable :-((

 

My printer (CR10s PRO) CAN do printing speeds 200-220 - I have done that on many smaller prints, AND ...

 

the problem I noticed IN BOTH CASES - I beleave - is this very, very high speed - NOT my printing speed - but the speed i moves from where it FINISHES an extrusion to where it starts again - I THOUGHT it was "Travel speed" in the settings - but it CAN'T because it was set to 120mm/s and very, very much higher than my printing speed 210mm/s ... so

 

What is this "Jumping speed" called in the settings ?

Share this post


Link to post
Share on other sites
Posted · Collision causes offset !!!!

Hi, I do not know about any "jump speed", maybe you could post your G-Code, but then someone with more in-depth knowledge than me would need to analyze it. Did you check the z hop settings? Also, you should check if the "maximum z speed" is set, and to which value. If it is set to 0, then set it to some value similar to your printing speed, and see how that works out.

Share this post


Link to post
Share on other sites
Posted (edited) · Collision causes offset !!!!

See also this topic: 

Could very well be the case that your CR10S doesn't have proper firmware limits for the Z speed and now it tries to move faster than it should... So just set the maximum Z speed to some sensible value in Cura.

Edited by P3D

Share this post


Link to post
Share on other sites
Posted · Collision causes offset !!!!

I've been into this 3D printing for 2-3 weeks and I'm not PRO in Gcode - I have to stick to the parameters/settings in the Cura profiles in the first place

Share this post


Link to post
Share on other sites
Posted · Collision causes offset !!!!

So, do like @P3D suggested:

 

3 hours ago, P3D said:

maybe you could post your G-Code, but then someone with more in-depth knowledge than me would need to analyze it

 

Share this post


Link to post
Share on other sites
Posted · Collision causes offset !!!!
29 minutes ago, ksor said:

I've been into this 3D printing for 2-3 weeks and I'm not PRO in Gcode - I have to stick to the parameters/settings in the Cura profiles in the first place

The settings I suggested are to be found in the Cura profile settings. But still, you could post your G-Code so someone can have a look at it and maybe tell you in detail what the problem is.

Share this post


Link to post
Share on other sites
Posted · Collision causes offset !!!!

If you are printing near your printers maximum, then the slightest bump can cause skipping steps. Overhangs often tend to curl up, so that can be enough to trigger it. At slow speeds the force required to accelerate and move is far less, so the printer has more margin before it skips steps.

 

Maybe try a small test print with overhangs and other difficult stuff, and on the fly change settings up to the point where it starts skipping (or underextruding or whatever else problem comes first)?

 

Share this post


Link to post
Share on other sites
Posted · Collision causes offset !!!!

>> geert_2

Thx, yeah, I have to experiment much more with the settings for now ... I wont go into the gcode at this point ... for me it's just some confusing munbers 🙂

 

 

Share this post


Link to post
Share on other sites
Posted · Collision causes offset !!!!
On 7/3/2019 at 8:54 PM, ksor said:

>> geert_2

Thx, yeah, I have to experiment much more with the settings for now ... I wont go into the gcode at this point ... for me it's just some confusing munbers 🙂

 

 

 

If your printer has a front panel, then maybe you could change the speed while it is printing, without having to go into the gcode? Like we can do on our Ultimakers? But I don't know your printer, so I don't know if it has this functionality?

 

Share this post


Link to post
Share on other sites
Posted · Collision causes offset !!!!

>> geert_2

 

My printer has that functionality but I can't know WHEN it stopped pring at one spot and wants to "jump" to another stop to start printing there - BTW it's a CR10s PRO printer.

Share this post


Link to post
Share on other sites
Posted · Collision causes offset !!!!

What I was thinking about, is to design and print a small item like this (the square baseplate is 50mm x 50mm). The 45° overhanging edges are likely to curl up (at least with PLA, at 100% infill, and on my printers), and cause the nozzle to bump into them violently, creating a hard test.

 

Then dial up printing speed until it starts causing trouble and skipping steps. And then dial down until these go away. That will give you an idea of how fast you can maximally go. And then reduce further for a safety margin.

 

Maybe that could work as a test?

 

image.thumb.png.ba6c2e937efca1ceb69ff3a9bca583a2.png

 

Share this post


Link to post
Share on other sites
Posted · Collision causes offset !!!!

Thx, I'll try construct a figure like that and est it

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!