Jump to content
Ultimaker Community of 3D Printing Experts

UM3 NOZZLE 2 always leveled too close to bed after active leveling


Recommended Posts

Posted · UM3 NOZZLE 2 always leveled too close to bed after active leveling

I just contacted @V3DPrinting privately and asked him to do a simple test.  If his core fails my test then this is a problem 3dsolex discovered and fixed about a year ago.  The problem was only on some cores.  Hopefully we will know more soon.

  • Link to post
    Share on other sites
    Posted · UM3 NOZZLE 2 always leveled too close to bed after active leveling

    After a long time of practice and waiting in vain for a FW update I downgraded to 4.3.3 today: Everything is fine again, my auto-leveling works again! Too bad I waited so long and lost so much wasted time.

     

    I had the auto-leveling problems with the original Ultimaker print cores (both AA-0.4). Replacing the print cores and factory reset did not help. The XY calibration didn't work either, because the PLA of the Core-2 was not visible. Level-Switch Test worked without errors. I would say that also the inductive height sensor worked perfectly during calibration (by watch the spring screws), only the Z-value is not stored.

     

    Note about the Ultimaker 3 firmware recovery work instructions:

    • Olimex board cover: This is the board with the Ethernet connector.
    • I couldn't find the status LED-Q LED-R and LED-T. But it doesn't matter, as the progress and completion of the recovery process is shown on the display.
    • In general: it was a easy and quick process.

    During the welcome setup with the 4.3.3 I found something else: My NFC sensor is not connected because I use two separate spool holders. But I think this cause is rather unlikely.

    • Like 1
    Link to post
    Share on other sites
    Posted · UM3 NOZZLE 2 always leveled too close to bed after active leveling
    22 hours ago, gr5 said:

    I just contacted @V3DPrinting privately and asked him to do a simple test.  If his core fails my test then this is a problem 3dsolex discovered and fixed about a year ago.  The problem was only on some cores.  Hopefully we will know more soon.

     

    Test done. It seems to run fine.

    Awaiting @gr5 feedback

  • Link to post
    Share on other sites
    • 2 weeks later...
    Posted · UM3 NOZZLE 2 always leveled too close to bed after active leveling

    Sorry for the late reply after tests done with @gr5.

     

    The outcome was that the 3d Solex Hardcores were within the specs and pretty much like the UM print cores regarding the springs.

     

    As the issue appears also with manual leveling, we have agreed that the right nozzle should be offset during the calibration process  in order to compensate for the difference when printing the first layer.

    Also we agreed to revert back to FW 4.33 and check if the difference between the two nozzle's heights is still there.

     

    Unfortunately, I was off last week and now my printer are over loaded for a week ....

  • Link to post
    Share on other sites
    • 2 months later...
    Posted · UM3 NOZZLE 2 always leveled too close to bed after active leveling

    Has this problem been resolved? I've been struggling with this exact same problem for the last three hours, trying everything short of taking the whole printer apart, then found this thread. 

  • Link to post
    Share on other sites
    Posted · UM3 NOZZLE 2 always leveled too close to bed after active leveling
    On 5/5/2020 at 5:14 AM, Duckminster said:

    Has this problem been resolved? I've been struggling with this exact same problem for the last three hours, trying everything short of taking the whole printer apart, then found this thread. 

     

    I hadn't the opportunity to downgrade before the lockdown in France.

    Since, I'm busy printing COVID parts in single extrusion where there is not leveling issues.

     

    I'm expecting a new printer next week and hope to have some slots end of the month to do the downgrade

  • Link to post
    Share on other sites
    Posted · UM3 NOZZLE 2 always leveled too close to bed after active leveling

    Thanks a lot for this thread. 

    We can confirm that our UM3 has exactly the described problems. Printing with the 2nd extruder was really a pain, ending in time consuming calibration orgies, but with little success. 

     

    Back on firmware 4.3.3 everything is working fine again! Thumbs up for all the helping members in this community.

    Thumbs down for Ultimaker releasing such a annoying firmware. Furthermore it isn't so easy to find the recovery image and knowing this will lead to version 4.3.3 again. 

    So, download the recovery.img here: Link (-> 4.3.3)

    Follow the instructions here: Link

     

    The downgrade process itself is simple.

     

    Is it possible to deactivate the update firmware hints?

  • Link to post
    Share on other sites
    Posted (edited) · UM3 NOZZLE 2 always leveled too close to bed after active leveling
    On 5/6/2020 at 7:04 PM, V3DPrinting said:

    I'm expecting a new printer next week and hope to have some slots end of the month to do the downgrade

     

    My BCN3D Epsilon has arrived and will be production ready today.

     

    Having some free capacity on one of my UM3E, I have downgraded to 4.3.3.

     

    So far, for the first dual extrusion print, my 2 printcores (both 3d Solex Hardcores) are leveled at the same height.

    So the problem was FW 5.2.11 on UM3E

    I will downgrade my other 4.3.3 too over the weekend. And not going to upgrade anymore.

     

    Again poor non regression tests from the Ultimaker FW team. Thumbs down !

    Edited by V3DPrinting
  • Link to post
    Share on other sites
    Posted · UM3 NOZZLE 2 always leveled too close to bed after active leveling
    On 5/15/2020 at 3:30 AM, ET-PC18 said:

    Thanks a lot for this thread. 

    We can confirm that our UM3 has exactly the described problems. Printing with the 2nd extruder was really a pain, ending in time consuming calibration orgies, but with little success. 

     

    Back on firmware 4.3.3 everything is working fine again! Thumbs up for all the helping members in this community.

    Thumbs down for Ultimaker releasing such a annoying firmware. Furthermore it isn't so easy to find the recovery image and knowing this will lead to version 4.3.3 again. 

    So, download the recovery.img here: Link (-> 4.3.3)

    Follow the instructions here: Link

     

    The downgrade process itself is simple.

     

    Is it possible to deactivate the update firmware hints?

    Thanks for the link info ET-PC18.

    I was hoping by now we'd have a real fix from Ultimaker...?

    So far my experience and this thread has been akin to my car dealer calling me to say "We recommend you bring in your car, as we have a newer better engine computer for it we're going to swap in that's going to fix a bunch of issues". Then when I drive it back home I discover it no longer goes in reverse. And when I call the dealer to complain they say "Sorry, but you shouldn't really use reverse anyways. However if you want to use it and restore the full value of features you originally paid for, you're going to have to put the original engine computer back in yourself."

  • Link to post
    Share on other sites
    Posted · UM3 NOZZLE 2 always leveled too close to bed after active leveling

    Hi I have the same problem that you. I didnt try to downgrade the firmware.

    I have using 2 UM3 printcores 0,4 

    All the time my prints with the pintcore 2 are missing 8mm (10 mm) . During several layers the material doesnt extrude. The material is pla .

    There is no problem with pla.

    I thing is a problem with some algorithm or with the firmware

    The only way to get the print well is automatic leveling after the init and always the first print have to be with the printcore 2.

    If the  automatic leveling is active after the init but the first time is with the printcore 1. Later, when I try to print with printcore2 the problems come back again

     

    is there any update from Ultimaker about these problems?

    Thanks

     

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    ×
    ×
    • Create New...