Jump to content
Ultimaker Community of 3D Printing Experts

UM3 NOZZLE 2 always leveled too close to bed after active leveling


Recommended Posts

Posted · UM3 NOZZLE 2 always leveled too close to bed after active leveling

I just contacted @V3DPrinting privately and asked him to do a simple test.  If his core fails my test then this is a problem 3dsolex discovered and fixed about a year ago.  The problem was only on some cores.  Hopefully we will know more soon.

  • Link to post
    Share on other sites

    Posted · UM3 NOZZLE 2 always leveled too close to bed after active leveling

    After a long time of practice and waiting in vain for a FW update I downgraded to 4.3.3 today: Everything is fine again, my auto-leveling works again! Too bad I waited so long and lost so much wasted time.

     

    I had the auto-leveling problems with the original Ultimaker print cores (both AA-0.4). Replacing the print cores and factory reset did not help. The XY calibration didn't work either, because the PLA of the Core-2 was not visible. Level-Switch Test worked without errors. I would say that also the inductive height sensor worked perfectly during calibration (by watch the spring screws), only the Z-value is not stored.

     

    Note about the Ultimaker 3 firmware recovery work instructions:

    • Olimex board cover: This is the board with the Ethernet connector.
    • I couldn't find the status LED-Q LED-R and LED-T. But it doesn't matter, as the progress and completion of the recovery process is shown on the display.
    • In general: it was a easy and quick process.

    During the welcome setup with the 4.3.3 I found something else: My NFC sensor is not connected because I use two separate spool holders. But I think this cause is rather unlikely.

    • Like 1
    Link to post
    Share on other sites

    Posted · UM3 NOZZLE 2 always leveled too close to bed after active leveling
    22 hours ago, gr5 said:

    I just contacted @V3DPrinting privately and asked him to do a simple test.  If his core fails my test then this is a problem 3dsolex discovered and fixed about a year ago.  The problem was only on some cores.  Hopefully we will know more soon.

     

    Test done. It seems to run fine.

    Awaiting @gr5 feedback

  • Link to post
    Share on other sites

    • 2 weeks later...
    Posted · UM3 NOZZLE 2 always leveled too close to bed after active leveling

    Sorry for the late reply after tests done with @gr5.

     

    The outcome was that the 3d Solex Hardcores were within the specs and pretty much like the UM print cores regarding the springs.

     

    As the issue appears also with manual leveling, we have agreed that the right nozzle should be offset during the calibration process  in order to compensate for the difference when printing the first layer.

    Also we agreed to revert back to FW 4.33 and check if the difference between the two nozzle's heights is still there.

     

    Unfortunately, I was off last week and now my printer are over loaded for a week ....

  • Link to post
    Share on other sites

    • 2 months later...
    Posted · UM3 NOZZLE 2 always leveled too close to bed after active leveling

    Has this problem been resolved? I've been struggling with this exact same problem for the last three hours, trying everything short of taking the whole printer apart, then found this thread. 

  • Link to post
    Share on other sites

    Posted · UM3 NOZZLE 2 always leveled too close to bed after active leveling
    On 5/5/2020 at 5:14 AM, Duckminster said:

    Has this problem been resolved? I've been struggling with this exact same problem for the last three hours, trying everything short of taking the whole printer apart, then found this thread. 

     

    I hadn't the opportunity to downgrade before the lockdown in France.

    Since, I'm busy printing COVID parts in single extrusion where there is not leveling issues.

     

    I'm expecting a new printer next week and hope to have some slots end of the month to do the downgrade

  • Link to post
    Share on other sites

    Posted · UM3 NOZZLE 2 always leveled too close to bed after active leveling

    Thanks a lot for this thread. 

    We can confirm that our UM3 has exactly the described problems. Printing with the 2nd extruder was really a pain, ending in time consuming calibration orgies, but with little success. 

     

    Back on firmware 4.3.3 everything is working fine again! Thumbs up for all the helping members in this community.

    Thumbs down for Ultimaker releasing such a annoying firmware. Furthermore it isn't so easy to find the recovery image and knowing this will lead to version 4.3.3 again. 

    So, download the recovery.img here: Link (-> 4.3.3)

    Follow the instructions here: Link

     

    The downgrade process itself is simple.

     

    Is it possible to deactivate the update firmware hints?

  • Link to post
    Share on other sites

    Posted (edited) · UM3 NOZZLE 2 always leveled too close to bed after active leveling
    On 5/6/2020 at 7:04 PM, V3DPrinting said:

    I'm expecting a new printer next week and hope to have some slots end of the month to do the downgrade

     

    My BCN3D Epsilon has arrived and will be production ready today.

     

    Having some free capacity on one of my UM3E, I have downgraded to 4.3.3.

     

    So far, for the first dual extrusion print, my 2 printcores (both 3d Solex Hardcores) are leveled at the same height.

    So the problem was FW 5.2.11 on UM3E

    I will downgrade my other 4.3.3 too over the weekend. And not going to upgrade anymore.

     

    Again poor non regression tests from the Ultimaker FW team. Thumbs down !

    Edited by V3DPrinting
  • Link to post
    Share on other sites

    Posted · UM3 NOZZLE 2 always leveled too close to bed after active leveling
    On 5/15/2020 at 3:30 AM, ET-PC18 said:

    Thanks a lot for this thread. 

    We can confirm that our UM3 has exactly the described problems. Printing with the 2nd extruder was really a pain, ending in time consuming calibration orgies, but with little success. 

     

    Back on firmware 4.3.3 everything is working fine again! Thumbs up for all the helping members in this community.

    Thumbs down for Ultimaker releasing such a annoying firmware. Furthermore it isn't so easy to find the recovery image and knowing this will lead to version 4.3.3 again. 

    So, download the recovery.img here: Link (-> 4.3.3)

    Follow the instructions here: Link

     

    The downgrade process itself is simple.

     

    Is it possible to deactivate the update firmware hints?

    Thanks for the link info ET-PC18.

    I was hoping by now we'd have a real fix from Ultimaker...?

    So far my experience and this thread has been akin to my car dealer calling me to say "We recommend you bring in your car, as we have a newer better engine computer for it we're going to swap in that's going to fix a bunch of issues". Then when I drive it back home I discover it no longer goes in reverse. And when I call the dealer to complain they say "Sorry, but you shouldn't really use reverse anyways. However if you want to use it and restore the full value of features you originally paid for, you're going to have to put the original engine computer back in yourself."

  • Link to post
    Share on other sites

    Posted · UM3 NOZZLE 2 always leveled too close to bed after active leveling

    Hi I have the same problem that you. I didnt try to downgrade the firmware.

    I have using 2 UM3 printcores 0,4 

    All the time my prints with the pintcore 2 are missing 8mm (10 mm) . During several layers the material doesnt extrude. The material is pla .

    There is no problem with pla.

    I thing is a problem with some algorithm or with the firmware

    The only way to get the print well is automatic leveling after the init and always the first print have to be with the printcore 2.

    If the  automatic leveling is active after the init but the first time is with the printcore 1. Later, when I try to print with printcore2 the problems come back again

     

    is there any update from Ultimaker about these problems?

    Thanks

     

  • Link to post
    Share on other sites

    Posted · UM3 NOZZLE 2 always leveled too close to bed after active leveling

    I'd apprecate an update on this - it seems to affect my UM3X and not my UM3 for some reason.  Wondering if the latest firmware for the UM3X will fix this?

     

    Thanks

    John

  • Link to post
    Share on other sites

    Posted · UM3 NOZZLE 2 always leveled too close to bed after active leveling
    7 minutes ago, JohnInOttawa said:

    I'd apprecate an update on this - it seems to affect my UM3X and not my UM3 for some reason.  Wondering if the latest firmware for the UM3X will fix this?

     

    Thanks

    John

    Hi John

    I do confirm that FW 4.3.3 fixes the issue on UM3X. Works like a charm since May 2020.

     

    I haven't tested the latest FW, as Ultimaker does not put any penny in the UM3. Everything is focused on S line, and their non regression tests are nearly non existent.

  • Link to post
    Share on other sites

    Posted · UM3 NOZZLE 2 always leveled too close to bed after active leveling

    I have an open support case with this problem and I asked the same but answer was theres nothing in the documentation saying 5.2.16 solves this issue.

    • Thanks 1
    Link to post
    Share on other sites

    Posted · UM3 NOZZLE 2 always leveled too close to bed after active leveling

    I made a restore image of 4.3.3 and then went ahead with 5.2.16.  No improvement and I am seeing a new flow issue that I have not fully diagnosed yet.  I am going to restore back to 4.3.3 today and run the same print with the same cores (both Ultimaker OEM).  I'll report back.

     

    Meanwhile, my UM3 (not extended) remains at 4.3.3.  I think I am going to leave it there.  I can't afford to have both machines in trouble.

     

    I understand UM3 is end of manufacturing life.  UMO firmware is available from folks like Tinkergnome.  How difficult is it do go this route with the UM3/3X family?  I get the feeling that as the S line diverges from the legacy printers, the UM3 and 3X offerings are just going to become more problematic.  Maybe we just need to form an aftermarket community that can focus on the UM3 line and not have its resources drawn in multiple directions.

     

    Sorry to have to say this.  I bet it is just as frustrating for the UM team that made these great machines to see this happening and be unable to address it as they would like.  My guess is the situation is not their choice. 

     

    John

  • Link to post
    Share on other sites

    Posted · UM3 NOZZLE 2 always leveled too close to bed after active leveling

    Just an update.  Back to 4.3.3.  Normal operation restored.  Will stay there for both printers.

    Looks to me like a completely different levelling process between 4.3.3.3 and 5.2.xx  No heating cycle in 4.3.3  I'm thinking perhaps the capacitive sensor is perhaps a bigger factor in levelling with the newer firmware?

     

    John

    • Like 1
    Link to post
    Share on other sites

    Posted · UM3 NOZZLE 2 always leveled too close to bed after active leveling
    10 hours ago, JohnInOttawa said:

    I'm thinking perhaps the capacitive sensor is perhaps a bigger factor in levelling with the newer firmware?

    Hi John

     

    The issue is determining the right nozzle height for the 2nd (right) nozzle.

    Both left and right are using the capacitive sensor to do it and left nozzle is always fine.

     

    To me the issue is more a computation bug in the FW.

     

    Nevertheless the sensing cycle on 5.2.x seems to be more accurate due to the fact it is heating the build plate, taking into account its thermal expansion. Unfortunately, it's not operational on UM3.

  • Link to post
    Share on other sites

    Posted (edited) · UM3 NOZZLE 2 always leveled too close to bed after active leveling

    It looks like if I set levelling frequency to Always it resolve the issue on my machine. I'll do some more tests but if anyone else still have issues and test this, please report back

     

    Levelling manually or setting frerquency to Auto fails on every print on core 2

    Edited by AndersK
  • Link to post
    Share on other sites

    Posted · UM3 NOZZLE 2 always leveled too close to bed after active leveling
    24 minutes ago, AndersK said:

    It looks like if I set levelling frequency to Always it resolve the issue on my machine. I'll do some more tests but if anyone else still have issues and test this, please report back

     

    I had the issue with FW 5.X on my two UM3X with auto leveling frequency set to Always.

    Changing the leveling frequency did nothing to the issue, except turning it off and doing a manual leveling (but it is tricky as it is temperature dependent)

     

    The only workaround for me was to downgrade to FW 4.3.3. Since no more issues with dual extrusion prints.

     

  • Link to post
    Share on other sites

    Posted (edited) · UM3 NOZZLE 2 always leveled too close to bed after active leveling

    With Ultimaker releasing PETG filament, which I've found to be a fabulous material for many reasons, and many of us stuck on FW 4.3.3, I'm curious where Ultimaker is at with this issue. How do we get this issue fixed in FW 5.X and/or PETG material supported in FW 4.3.3?

    Edited by Duckminster
  • Link to post
    Share on other sites

    Posted · UM3 NOZZLE 2 always leveled too close to bed after active leveling
    4 hours ago, Duckminster said:

    How do we get this issue fixed in FW 5.X and/or PETG material supported in FW 4.3.3?

    Cura 4.10 has material profiles for the UM3 included. Select your printer from Cura and it will transfer all updated material profiles in the background to your printer. This should even work for the older 4.3.3. release.

  • Link to post
    Share on other sites

    Posted · UM3 NOZZLE 2 always leveled too close to bed after active leveling
    15 hours ago, CarloK said:

    Cura 4.10 has material profiles for the UM3 included. Select your printer from Cura and it will transfer all updated material profiles in the background to your printer. This should even work for the older 4.3.3. release.

    This does not appear to be the case Carlo. I've been using Cura 4.10 with PETG for a couple of prints now and the printer does not recognize the NFC tag for PETG. Nor is there a PETG material option on the printer.

    What I have to do to print is select a different material on the printer such as CPE, and then each time I print I get the dreaded "configuration change detected" in CURA monitor, which I have to override to force it to print.

  • Link to post
    Share on other sites

    Posted · UM3 NOZZLE 2 always leveled too close to bed after active leveling

    @Duckminster I checked and you are right, v4.3.3 doesn't update the materials. I'm always using v5.2.x and there it is updating the materials when connected to Cura.

  • Link to post
    Share on other sites

    Posted · UM3 NOZZLE 2 always leveled too close to bed after active leveling
    45 minutes ago, CarloK said:

    @Duckminster I checked and you are right, v4.3.3 doesn't update the materials. I'm always using v5.2.x and there it is updating the materials when connected to Cura.

    What are our options @CarloK? I bought a UM3 on the premise of two advertised features: auto-levelling, and NFC support for NFC-tagged Ultimaker materials. However this is currently not the case. These two features do not exist simultaneously. As it stands I have to pick which feature I wish to use and then upgrade the machine to the appropriate firmware.

  • Link to post
    Share on other sites

    Posted · UM3 NOZZLE 2 always leveled too close to bed after active leveling

    Personally I'm not happy with the current situation either. The formal way for complaints nowadays is to contact your reseller and they will forward it to the Ultimaker Customer Care department.

     

    Then, as a work around, I can show you one of the hidden tricks the UM3 has in its internals. When you are willing to edit a text file on the printer, then you can enable another leveling mechanism that's also used in the S-line of printers.
    The UM3 uses a 3-point leveling where the S-line uses a multi-point bed leveling (MPBL). The MPBL is more accurate as it probes more locations and can hence handle curved or twisted build plates, not an issue for the smaller UM3, but there are fewer bugs in this algorithm.

    There is always a catch: You can't select the leveling frequency anymore, the MPBL probing will always run before a print, but we did some optimizations here so it's not that bad time wise.

     

    • Upgrade your printer to the most recent version (5.2.16 at the time of writing)
    • Set the printer in developer mode (in menu Maintenance/Diagnostics)
    • Now we are going to edit a file on the printer. You can do this directly of use scp to copy the file to your pc, modify it and then copy it back to the printer. Here the online guide:
      • Use a terminal program to create an SSH connection to the printer. Username = root / password = ultimaker
      • cd /usr/share/griffin/griffin/machines
      • vi um3.json  (check online guides for how to navigate in the 'vi' editor)
      • On line 45 of the file change "frequency" to "mode"
      • On line 54 change "spacing" from 80 to 160 (reduces the number of probe locations from 9 to 4 which is way faster)
      • Save the file (ESC ':wq')
      • Type 'reboot' to reboot the printer
    • Like 1
    Link to post
    Share on other sites

    Posted · UM3 NOZZLE 2 always leveled too close to bed after active leveling

    I use a UM3 with a ultistik build plate directly onto the heated bed (without the glass plate) and whilst I've managed to get the bed fairly level, the fact that there are only 3 adjustment points has made it difficult to get truly flat/level surface.

     

    With the above tip from @CarloK, it has seemed to make prints behave slightly better, especially with prints on the edges of the bed. I've tweaked the spacing to '50' and reduced the margin values by 10 each (So 30, 5, 5 and 30) and so far so good.

     

    Many thanks Carlo for the tip!

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share


    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 11 replies
    ×
    ×
    • Create New...