Jump to content
Ultimaker Community of 3D Printing Experts

Cura won't recognize a vertical pocket


Recommended Posts

Posted · Cura won't recognize a vertical pocket

Cura seems to be ignoring a pocket when my part is in the vertical orientation.  I've modeled it in Solidworks.  I've imported it into Cura 3.3.1 and 4.1.0 and it ignores the feature in both versions.  It WILL recognize the feature if I lay the part down in a horizontal position, but I don't want to print this way.  .STL attached.

Jason Trident Pommel.STL

  • Link to post
    Share on other sites
    Posted · Cura won't recognize a vertical pocket

    I am thinking that this has to do with which axis the program of origin has set as its 'up axis'.

     

    Cura uses 'Z Up'. Many programs use 'Y Up.'

     

    Check to see if Solidworks uses 'Y Up.'

     

    It is also possible to just rotate the object to proper orientation in Cura to compensate for this.

     

    Also, Solidworks may allow an export to 'Z Up.'

  • Link to post
    Share on other sites
    Posted · Cura won't recognize a vertical pocket

    I have changed the orientation within solidworks and resaved the model.  Resent the STL to cura, same result.  I also have rotated the part in cura.  If the hole is up, cura sees it.  If it's horizontal, cura sees it.  In any other orientation, cura skips the hole.

  • Link to post
    Share on other sites
    Posted · Cura won't recognize a vertical pocket
    15 hours ago, harley573 said:

    Cura seems to be ignoring a pocket when my part is in the vertical orientation.

     

    There's an option "Mesh Fixes -> Remove All Holes" which does exactly what you describe. Perhaps it is accidentally checked? 🤷‍♂️

    Have you made a try with one of the default printing profiles?

    • Like 2
    Link to post
    Share on other sites
    Posted · Cura won't recognize a vertical pocket

    I did check that "remove all holes" setting and have tried it with that setting selected and deselected with no change in result.  I didn't think to try reverting to default settings though.  I'll give that a shot.  Thanks for the suggestion.

  • Link to post
    Share on other sites
    Posted · Cura won't recognize a vertical pocket

    So, very odd.  I reverted to recommended settings in version 3.3.1 and there was no change.  Reverted back to recommended settings in version 4.1.0 and the problem was corrected.  Obviously, I've tweaked a setting somewhere, but I have no idea where or what it was.  Thanks to everyone for help and suggestions.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • Our picks

      • Ultimaker Transformation Summit
        Visit our virtual showroom and learn more about the Ultimaker ecosystem!
        • 14 replies
      • New here? Register your Ultimaker for free 3D printer onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 0 replies
    ×
    ×
    • Create New...