Jump to content
Ultimaker Community of 3D Printing Experts
donidu

Extruder doesn't move away after printing

Recommended Posts

Hi,

I have received my new Ultimaker 2 printer yesterday and I have made my first test last night :-P .

After some printouts directly from the SD memory-card I printed an self-constructed object via USB using Cura 13.10 which worked fine as well, unless the object was finished. The extruder didn’t move away from the point it finished printing so that the hot nozzle melted the part of the model where it stopped. I didn’t do any further tests with Cura, as I did not want to damage anything. The Objects have been constructed with ViaCAD and exported in STL-Format. Do I have to embed somewhere a kind of "move-away-command" in the code or did I do anything wrong?

Thanks for any help

Tom

 

Share this post


Link to post
Share on other sites

im guessing David will get on this question pritty fast this morning..

the only thing i can think of is. did your usb cable come loose and maybe interupt the data at the end of print... confusing the printer ?... or maybe the usb cable is too long and the data... screwed up ?

you can show us your 3d model. put it on youmagine and we can have a look for you... maybe there is something weird there..

cant imagine there is no home command after a completed print with an ultimaker2.

Ian :-)

 

Share this post


Link to post
Share on other sites

USB printing with the UM2 is not officially supported, it's not something we developed into the details and it's something that we had lots of issues with so we decided to do SD printing only.

(If you do want to print with USB, you'll have to switch to "RepRap" gcode-flavor in the machine settings instead of UltiGCode. But you might experience connection problems)

 

Share this post


Link to post
Share on other sites

There are some gcodes in cura on the start/end gcode tab.

The "end" codes should include a Z+0.5 to move the head up away from your part, and an X,Y -20 and then a X,y to position 0 (home position). All of that should move the head up and away. I don't understand why those would make it onto the SD card but not into the file that the cura "print window" uses. It should be the same file and the same gcodes. Probably the "move away" has been removed from the gcode and is now run in Marlin after the gcode file is done. So you could put it back in by selecting "reprap" or whatever Daid just said (Daid wrote cura).

Anyway I would stay away from usb printing. It's very flaky. Many people have seen it crash 8 hours into a 20 hour print. Plus there are screen savers, power savers on your computer, (windows update nailed me once!). Better to use the SD card.

Also the serial path is slower and sometimes if you have thousands of tiny line segments, the USB can't keep up. For example when printing the "yoda" model or anything scanned.

 

Share this post


Link to post
Share on other sites

I have the same with my Ultimaker2, though I'm not using USB printing.
The nozzle stays on top of the print, on the last print position, and does not move away from the object.
It then first extrudes some extra filament, leaving a clogged of plastic on the object. Just after that the nozzle moves away.

How can I change this?

Share this post


Link to post
Share on other sites

Thanks tinkergnome, for responding!

It is an old thread, but I wanted to prevent to start new threads about the same issue.
In fact the issue I was having is no different than described here. Exactly the same happened. I noticed it happened after having updated Cura to the latest version 3.2.1. Nevertheless, I now also noticed that it happened with a specific 3D design. Printing a different objet after it, did not have the issue of the nozzle hanging at the end position at the end of the printing.
So I am still not sure whether it is Cura/firmware or the 3D design of the object.  

Share this post


Link to post
Share on other sites

Hello I had the same issue, I answer in a different thread in french. I think I fix it.

this comes from a bug in CURA 3.2 and 3.2.1 on mac. I did different test and I was able to clear the issue by using Cura 3.2 on windows or by downgrade to CURA 3.1 on mac. note that to fix the issue when I re install CURA 3.1, I had to remove and recreate the printer. for a reason I do not understand CURA keeps my printer settings after the downgrade.

hope it helps.

 

link to the post in french: 

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!