Jump to content

Can't install new firmware T2 T3 LED FAN

Recommended Posts

Posted (edited) · Can't install new firmware T2 T3 LED FAN

My Ultimaker 2 has worked perfect ly for  years with exception to the led which had blown the T1 or T2 transistor.

so i replaced them both and also T3 as it was the same the light now work perfectly. however every time i tried to print or move the bed of print head

i  would get a ER06  or ER05 or ER07 i have tested the stop switch and my connection sereral time and all it fine.
after reading a few posts it suggested reinstalling the firmware , unfortunately it now thinks its the first time i've used the machine

and want to calibrate the bed but keep coming up with the errors messages i have tried to connect it the cura via a usb cable but it dose not detect the printer while it stuck in the 

calibration mode Help i understand you cannot install the firm ware via SD card.



Edited by superflyguy1973

Share this post

Link to post
Share on other sites
Posted · Can't install new firmware T2 T3 LED FAN

Did you perhaps install firmware for another printer? You say you have the UM2 and installing firmware for a UM2+ could show this behavior.

Which Cura version are you using? We are now at Cura 4.3, but I remember about a year ago there was a bug in Cura where firmware versions for the UM2 and UM2+ were mixed up.


Instructions for re-installing the firmware on a failing UM2 printer

The newer versions of Cura are being 'nice' to your printer and that's why they fail in programming.


In order to start the programming process, Cura has to reboot the printer. That's what older versions of Cura did when you connected the USB cable. Disadvantage was that when you were printing and you started Cura, then your multi-day print would reboot as well.... Oops.

So, now Cura is nice to the ongoing print process but as a consequence fails to program a printer that's stuck.


Your workaround is to use another program for programming the printer.
One option is this old version of Cura: https://software.ultimaker.com/cura/Ultimaker_Cura-15.04.06.exe

There are other programs as well, but I haven't done this since long so are not aware of the current situation. Look for programs that can program an Arduino AtMega 2560 board


The UM2 firmware is a *.hex file and is included in the Cura program directory.

For the UM2+ a release candidate for the next official version can be downloaded here: https://github.com/Ultimaker/UM2.1-Firmware/blob/UM2.1_JarJar/releases/beta/MarlinUltimaker2plus_20181007.hex  (right click on link, and then 'save link as').

Share this post

Link to post
Share on other sites
Posted · Can't install new firmware T2 T3 LED FAN

Ok after look into this when replacing the T1 and T2 transistors T3 looked identical so silly old me replaced that one too. It turns out that one is different 

Replacement order hopefully it fixes the problem 

Share this post

Link to post
Share on other sites
Posted · Can't install new firmware T2 T3 LED FAN

T1 and T2 are BC817 NPN transistors.

T3 is a BC807 PNP transistor


So glad Ultimaker provided the schematics so people will study them ....   🙄

https://github.com/Ultimaker/Ultimaker2/blob/master/1091_Main_board_v2.1.1_(x1)/Main Board V2.1.1.pdf


T3 indirectly switches on the 24V for the motors and the bed. So with a wrong type of transistor here it explains the wrong behavior in your printer.

Share this post

Link to post
Share on other sites
Posted · Can't install new firmware T2 T3 LED FAN

Check the connection, sometimes this could be caused by a physical  connection failure or a problem with your device.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • Survey: Understanding your workflow
      Interact with future concepts and aim to collect your feedback and opinion. In particular, if this would/could be a welcome addition to your 3D printing workflow. Interested?
      • 0 replies
    • Coronavirus: Let's do our part
      Through this post I would like to further explain what we are doing, and what you could be doing. 
      Our efforts consist of 2 layers. First; connect medical institutions and hospitals to (local) 3D Printing hubs to help them print parts of which a 3D model already exists. And second, contribute to design the necessary part and then have it printed via a (local) 3D printing hub. Experts are available from within Ultimaker and from within our network of 3D printing experts.
        • Like
      • 45 replies
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!