Jump to content
bowie130459

Cura 4.3 not starting on MACOSX 10.15 Catalina

Recommended Posts

Posted · Cura 4.3 not starting on MACOSX 10.15 Catalina

Hi all,

 

this weekend i updated to OSX Catalina 10.15 on my MAC.

 

But know Cura 4.3 stays in a white blank screen and a rotaiting rainbow circle.

 

How could I get CUra run again. I often use it because it is much better then simplify 3d.

 

Help is realy wanted.

 

Kind regards

Willi

Share this post


Link to post
Share on other sites
Posted · Cura 4.3 not starting on MACOSX 10.15 Catalina

Cura 4.3 runs fine for me on Catalina, so it must be something with your installation.

 

You can try to delete your Cura configuration folder, that you can start over with a fresh installation. But be aware that you will loose all your settings.

Share this post


Link to post
Share on other sites
Posted · Cura 4.3 not starting on MACOSX 10.15 Catalina

You find it here: ~/Library/Application Support/cura/4.3

When you delete the whole 4.3 directory or everything lower than this number, you will start with a fresh copy. You can also try to just rename the latest (4.3) folder to something else and delete the previous versions.

Share this post


Link to post
Share on other sites
Posted · Cura 4.3 not starting on MACOSX 10.15 Catalina

Sorry but this didn't help.

 

I removed the 4.3 Config directory but no changes at all. A white screen appears nothing more.

I attached the log for Cura just after installation, perhaps some one can help.

 

 Kind regards

Willi

cura.log

Share this post


Link to post
Share on other sites
Posted · Cura 4.3 not starting on MACOSX 10.15 Catalina

It’s working fine for me also in Catalina, maybe remove Cura fully and reinstall it.

Share this post


Link to post
Share on other sites
Posted · Cura 4.3 not starting on MACOSX 10.15 Catalina

So I solved the Problem just a couple of minutes ago.

Problem was an USB-Unit where cura tries to access to as a Printer, but it Isn't a printer. I removed all USB Units attached and which I didn't need for working with cura and reallised that the Docking station for my Sportswatch was the reason to prevent Cura from a correct starting.

Now I have to check why, for hell, cura tries to read  USB-ports.

 

But thanks to you all.

Share this post


Link to post
Share on other sites
Posted · Cura 4.3 not starting on MACOSX 10.15 Catalina

You can stop Cura from accessing the USB ports by going into Marketplace -> Installed and disable the USB printing plugin.

 

Screenshot_2019-10-15_07-39-17.thumb.png.e48f1bc326c537745ebda4407f238fa8.png

Share this post


Link to post
Share on other sites
Posted · Cura 4.3 not starting on MACOSX 10.15 Catalina

It was enabled, now I disabled it and attached the USB device causing my Problem.

What should I say, everything is fine now.

Thanks for this hint.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!