Jump to content
Ultimaker Community of 3D Printing Experts

4.3.0 will not start on an Intel NUC with Windows 10


Recommended Posts

Posted · 4.3.0 will not start on an Intel NUC with Windows 10

I was wanting to move Cura to my Intel NUC running Windows 10 and it will load ok but when I tried to start it, the icon spins for a few seconds and it does nothing else.  I've update Windows 10 with all the latest patches and update the NUC with all the Intel updates and still nothing.  

I tried uninstalling Cura and reinstalling and still no luck.



  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

    • Our picks

      • New here? Get ahead with a free onboarding course
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 11 replies
    • Create New...