Jump to content
maht

Ultimaker S3 Firmware 5.3.4 Released

Recommended Posts

Posted · Ultimaker S3 Firmware 5.3.4 Released

Ultimaker-S3-product-hero.jpg?w=528

 

Hey Ultimaker S3 users,

 

We just dropped a new firmware for the UMS3. Firmware 5.3.4 primarily addresses the cloud connection workflow, and some other thingsFind out more here.

If you have feedback, please let us know in this thread so we can keep track of everything.

Share this post


Link to post
Share on other sites
Posted (edited) · Ultimaker S3 Firmware 5.3.4 Released

Hello,

 

I just updated two Ultimaker S3 printers to firmware 5.3.4, however, both show the following issue:

 

After the update, the printer keeps saying a new firmware version is available: 5.3 (see attached pictures).

Checking the logs, I noticed the following:

 

Quote

Oct 23 21:02:01 ultimakersystem-0030d6210cf6 python3[313]: 2019-10-23 21:02:01,959 WARNING systemUpdate HTTP error 404 during updating of the update version strings for release type 'testing' from url 'http://software.ultimaker.com/releases/firmware/213482/testing/um-update.swu.version?current_version=5.3.4.20191008': Not Found

 

Don't know if it's related. Thanks in advance for looking at this.

 

WhatsApp Image 2019-10-23 at 15.47.08.jpeg

WhatsApp Image 2019-10-23 at 14.57.22.jpeg

Edited by Digitina

Share this post


Link to post
Share on other sites
Posted (edited) · Ultimaker S3 Firmware 5.3.4 Released

That log entry just means the printer found no testing version on the server. Which is correct as UM does not use testing versions anymore.

Edit: Testing versions were actually preview versions used in the past (in most cases for the Ultimaker 3) to test new features.

Edited by Dim3nsioneer

Share this post


Link to post
Share on other sites
Posted · Ultimaker S3 Firmware 5.3.4 Released

OK, I understand. That was just a guess from what I could see.

 

Regarding the actual issue where the printer keeps asking to update to 5.3 while it's already on 5.3.4.

Is there any other place I could check for more details? SSH into the machine and read the logs there maybe?

I just need to know the file path in that case.

 

I don't think I can be the only one having this issue as I have it on two separate machines.

Share this post


Link to post
Share on other sites
Posted · Ultimaker S3 Firmware 5.3.4 Released

Thanks for reporting the 5.3.4 update being marked as 'new' even after installation. This was a problem on our web server and has been fixed now.

 

About the log message for a testing version not being found: Ultimaker uses test releases for people to test new versions that fix problems or add new features. These test releases have not gone through an extensive test procedure and hence are not considered good enough to be released as 'stable'. Since the S3 is a new printer model we never before released a test version and so this message pops up in the log file. To avoid confusion about these log messages I just uploaded the identical v5.4.3 to testing as well. The testing and stable versions are identical so it makes no difference which one you install.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!