Jump to content
Ultimaker Community of 3D Printing Experts

In dual extrusion, second material sliced every other layer


Recommended Posts

Posted (edited) · In dual extrusion, second material sliced every other layer

I am attempting a dual extrusion job. In the design, I have some solid cylinders (material 2) oriented horizontally and spanning several layers within a larger cylinder (material 1) which is vertical.

When I slice this, the horizontal cylinders are sliced only every other layer so the printer extrudes "material 2" every other layer while "material 1" is extruded every layer.

Any idea of the reason this is happening and how to resolve this issue?

 

Thank you!

Edited by murandi
  • Link to post
    Share on other sites
    Posted · In dual extrusion, second material sliced every other layer

    That sounds strange.  It sounds like a problem with your model.  Maybe the seam where the two cylinders connect has gaps or other errors in the model.  Please:

    1) Show some photos to explain both in normal view, xray view, and slice view

    (for xray view there is a drop down in top left area when in preview mode)

    2) Tell us what CAD you are using or is this a model from someone else?

    • Like 1
    Link to post
    Share on other sites
    Posted (edited) · In dual extrusion, second material sliced every other layer

    The thing is that the problem occurs "within" the horizontal cylinders. When I enlarge the cylinders using the CAD software and I slice it I see more alternating layers, i.e. one layer with both materials and one with only "material 1".

    1) Attached are some screenshots

    2) The CAD is Autodesk's Fusion 360 

     

    Screen Shot 2019-10-23 at 6.57.17 PM.png

    Screen Shot 2019-10-23 at 6.57.11 PM.png

    Screen Shot 2019-10-23 at 6.56.32 PM.png

    Screen Shot 2019-10-23 at 6.56.25 PM.png

    Screen Shot 2019-10-23 at 6.56.16 PM.png

    Screen Shot 2019-10-23 at 6.56.02 PM.png

    Edited by murandi
    clarity
  • Link to post
    Share on other sites
    Posted · In dual extrusion, second material sliced every other layer

    okay.  Strange.  Let's clarify:

    1) Do you export 2 STL files from autocad? 

    2) Are the two files exclusive?  I mean in the image just above the blue cylinders pass through "holes" in the yellow part, right?  At no point are both materials occupying the same space?  if not then you need to do a boolean operation where you subtract the blue part from the yellow.

     

    3) I suggest you play with all the "mesh fixes".  Please make all mesh fixes options visible and then look at each one and toggle the value if it even remotely might have something to do with this.  Looking them over, any one of them could be related but the most standout one: "alternate mesh removal" is very likely involved - you probably want to uncheck that.  Read what that does - it sounds a LOT like what is going on here but it should not be a problem if there were no bugs.

  • Link to post
    Share on other sites
    Posted (edited) · In dual extrusion, second material sliced every other layer

    I had almost the exact same issue and found this thread while searching for a solution.

     

    In the end, for me it turned out to be a problem with my 3D model. The main body (the one you show in yellow) was intersected by the smaller bodies but there were no actual holes cut from it. My two bodies were just occupying the same space. I am using Fusion 360 and solved the problem using the Combine tool, selecting Cut and Keep Tools to punch holes through my main piece using the smaller bodies as the tool.

     

    After that, re-exported the .stl files, opened them in Cura, merged them and my smaller bodies no longer only print every second layer. It makes sense if you think about it, the program sees two bodies occupying the same space and is printing 50% of one and 50% of the other.

     

    Hope that helps!

    Edited by surfacefeatures
    clarification
  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    ×
    ×
    • Create New...