Jump to content
cdettman

SOLVED: UM2 Underextrusion... forgot to set e-steps per BondTech

Recommended Posts

Posted (edited) · SOLVED: UM2 Underextrusion... forgot to set e-steps per BondTech

Hi all, 

 

I recently began having some severe underextrusion issues.   To make a long story short,  after flashing new firmware I forgot to set the e-steps to 492.45 per the Bondtech instructions.  It had been so long since I had originally installed the Bondtech that I forgot about the e-steps and even after reviewing the instructions many times, I somehow overlooked it.

 

Big thanks to Smithy for quickly finding my problem!

 

(Edited to make a unnecessarily long story short)

 

Edited by cdettman

Share this post


Link to post
Share on other sites
Posted · SOLVED: UM2 Underextrusion... forgot to set e-steps per BondTech

Have you set the steps for the QR feeder to the correct value?

Share this post


Link to post
Share on other sites
Posted · SOLVED: UM2 Underextrusion... forgot to set e-steps per BondTech

By steps do you mean the current?  Set to 1000mA per the BondTech specs.  Also tried bumping to 1200mA (max rating for that motor) with no change.

Share this post


Link to post
Share on other sites
Posted · SOLVED: UM2 Underextrusion... forgot to set e-steps per BondTech

No not the current, I mean the e-steps which should be at 492.?? Or something like that. You find the correct value in the Bondtech manual or here in the forum. 
 

The UM2 uses a quite lower value 28? And this could explain why you need to dramatically increase the flow.

 

You cannot set this value with the stock Firmware but you can set it via gcode. The Tinkerfw has a menu option for that in the motion menu.

 

Check the Bondtech site, there are detailed instructions how to configure the e-steps.

 

I am quite sure this is your problem.

I guess you have set it in the past but lost the value with a firmware upgrade or factory reset.

 

 

Share this post


Link to post
Share on other sites
Posted · SOLVED: UM2 Underextrusion... forgot to set e-steps per BondTech

The correct value for the e-steps and the Bondtech QR feeder is 492.45

 

If you don't want to use the Tinkergnome FW, you can set the value with the following GCODEs:

M92 E492.45
M500

With M500 you save the value to the eeprom, so you don't have to put the first line in every gcode.

  • Like 1

Share this post


Link to post
Share on other sites
Posted · SOLVED: UM2 Underextrusion... forgot to set e-steps per BondTech

You nailed it!   I had a feeling I was overthinking it and overlooking something obvious.

 

Must have looked back at that manual 10 times and somehow didn't see the note about e-Steps. 

 

Thanks for your help!

Share this post


Link to post
Share on other sites
Posted · SOLVED: UM2 Underextrusion... forgot to set e-steps per BondTech

I'm glad it was the reason and it's working again.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!