Jump to content
Ultimaker Community of 3D Printing Experts

CURA 4.4.0 freezes on startup at Loading plugins...FIX


Recommended Posts

Posted · CURA 4.4.0 freezes on startup at Loading plugins...FIX

Tried twice to install 4.4.0 on my Windows 10 home 64 bit laptop.  On startup is freezes at "Loading plugins".  The only way to kill it at this point is through task manager and looking at background processes.  The install never makes it to showing up on the task bar as a running application.  I have installed 4.4 on two other Windows computers (10 Enterprise and 10 Pro) with no issues.

Opened a "cmd" window and started it there on command line.  It came up after noting that Windows Firewall had blocked some of it.  I gave permission for it to run and it started.

 

Now it starts from the icon.

 

FYI,

DLC

  • Like 1
Link to post
Share on other sites
Posted · CURA 4.4.0 freezes on startup at Loading plugins...FIX

Tks, @RoboDLC

What I made, based on your suggestion:

norton -> pare feu -> controle programme -> ajouter ( add a new programme autorisation) -> selected CURA 4.4.0 and gave full autorisation.

Now, the problem is solved.

  • Link to post
    Share on other sites
    Posted · CURA 4.4.0 freezes on startup at Loading plugins...FIX

    Hey @RoboDLC  thank you for reporting this. I'm not sure if the firewall rules should matter - some times during testing, we choose cancel on that Windows Firewall prompt... and it still works without the getting blocked on the splash page. 

     

    and @OUPS65, interesting to know this for us. I'll keep a note of it so we can include in our test it next time. 

     

  • Link to post
    Share on other sites
    • 4 weeks later...
    Posted · CURA 4.4.0 freezes on startup at Loading plugins...FIX

    I just ran into same issue.  I got a new windows 10 PC and installed to use.  It got stuck on loading plugins. Found this post and manually added Cura to the firewall exception list and all was well.

  • Link to post
    Share on other sites
    Posted · CURA 4.4.0 freezes on startup at Loading plugins...FIX

    So, is CURA doing something new or is Windows firewall becoming more effective in blocking snoopware?

     

    DLC

  • Link to post
    Share on other sites
    Posted · CURA 4.4.0 freezes on startup at Loading plugins...FIX

    I also had Cura stop working today.  It did work for 5 days, however today stopped on Windows 10 system-it too hung up on loading plugins.  I tried with and without firewall on.  Perhaps I will look into adding the exceptions.  Any other ideas welcome.

     

     

  • Link to post
    Share on other sites
    Posted · CURA 4.4.0 freezes on startup at Loading plugins...FIX

    Strangely enough, it didn't work when I turned the firewall off, only when I allowed both .exes through. It may work with only curaengine.exe in the exceptions, as that's the one that's trying to open the port.

  • Link to post
    Share on other sites
    Posted · CURA 4.4.0 freezes on startup at Loading plugins...FIX

    I allowed both and I get as far as "loading preferences".  What bums me out is it worked for days and then stopped.   I have uninstalled and reinstalled a few times with fingers crossed but, no good...

  • Link to post
    Share on other sites
    Posted · CURA 4.4.0 freezes on startup at Loading plugins...FIX

    Had the same problem. After some investigation (like event log) I figured out that I had to add Cura.exe and CuraEngine.exe to the Windows Defender exceptions... after doing so cura 4.4.1 started up ok.

  • Link to post
    Share on other sites
    Posted · CURA 4.4.0 freezes on startup at Loading plugins...FIX

    Thank you for the feedback, I had to run the compatibility troubleshooter and it has recommended Windows 8 compatibility.

     

    I ran compatibility troubleshooter on it and it fixed it.  Hopefully there are no drawback to running in Windows 8 compatibility...

     

    I am not sure why it stopped, but it may have been a result of a Windows update...  

  • Link to post
    Share on other sites
    Posted (edited) · CURA 4.4.0 freezes on startup at Loading plugins...FIX

    Same issue here. I use Cura 4.4.1. on two w10 laptops. An old one and it works fine, but on a new freshly installed Lenovo Yoga it also freezes on startup schreen. Adding cura.exe and curaengine.exe to the firewall settings diddn't solve the issue. Running cura.exe in W8 compatibility mode solved the issue

    Edited by damenzijlstra
  • Link to post
    Share on other sites
    Posted · CURA 4.4.0 freezes on startup at Loading plugins...FIX

    Later i discovered that you have to also allow Cura and Curaengine to public networks in the firewall settings and then it also solves the issue

    • Thanks 1
    Link to post
    Share on other sites
    Posted (edited) · CURA 4.4.0 freezes on startup at Loading plugins...FIX

    Alllowing public networks works for me (after restart of the computer)  Thanks!!!

    Edited by toml
  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    ×
    ×
    • Create New...