Jump to content
sono

S3 5.3.6 - unable to connect ssh

Recommended Posts

Posted · S3 5.3.6 - unable to connect ssh

Hey,

 

I was wondering if there are any known issues or any other users are experiencing this issue.

 

First observed with putty on LAN (no filters) and then verified with a direct crossover connection from a linux laptop running dnsmasq.

Port 22 is closed (connection refused.)

Dev mode is activated, verified on S3 Display, numerous restarts. Tried re-enabling etc. etc.

 

Now I don't want to say that I might not still be overlooking something silly but it seems exceedingly unlikely.

 

Anyone got something?

 

Thanks,

sono

Share this post


Link to post
Share on other sites
Posted · S3 5.3.6 - unable to connect ssh

Hello,
we have exactly the same problem. Without the possibility to set a static ip address we can't use ouer printer.

Very sad that not even this is possible. I would also expect this to be a setting available through the menu.

 

Thanks.

 

Share this post


Link to post
Share on other sites
Posted (edited) · S3 5.3.6 - unable to connect ssh

No mysterious change, problem persists.

 

As far as i know the UM uses a Raspberry Pi oder similiar quite open SBC. I will find the time to get a console in January and keep this thread updated with my findings.

 

Meanwhile i would encourage you to do the same, if you don't want to wait. It should be easy enough.

Edited by sono

Share this post


Link to post
Share on other sites
Posted · S3 5.3.6 - unable to connect ssh

Try a "cura connect reset" on the S3 panel.  This fixes a huge amount of problems, some of which have nothing to do with the network.

 

I'm wondering if this is a new feature.  Maybe they moved the ssh port to a "hidden" port?  ssh works find on my UM3 and S5 but I don't have an S3.  I assumed it would be the same.  A port scanner should be able to detect which port.  But I kind of doubt the port was moved.

 

When in developer mode does your S3 show the IP address at the top of the display?  Mine does.

Share this post


Link to post
Share on other sites
Posted · S3 5.3.6 - unable to connect ssh

Yea, it does show the address.

According to nmap -A -p 1-65535 only ports 80 and 8080 are open.

I will try the connect reset after the current print job is done.

Share this post


Link to post
Share on other sites
Posted · S3 5.3.6 - unable to connect ssh

Oh and the boards inside the S5 and UM3 are Olimex boards.  With I think an "A20" processor if that means anything (not sure if that's a processor).  More hints here:

 

 

An alternative to ssh is to get an olimex cable.  it has 3 connectors to olimex on one end and a USB on the other end such that you can do a serial rs232 connection as a console.  Username/password is root/ultimaker.

 

Share this post


Link to post
Share on other sites
Posted · S3 5.3.6 - unable to connect ssh

Allwinner A20 is a common ARM SoC. The board mentioned in that post has USB and HDMI, so I don't know why they are using a TTL / RS232 adapter but either way getting a console on such devices is trivial unless the device has been intentionally locked down, as is not the case here. Once on the console, it should be quick to find the cause why ssh is not running or filtered. Should be a one time thing.

Share this post


Link to post
Share on other sites
Posted · S3 5.3.6 - unable to connect ssh

Yes, once fixed you can go back to ssh.

 

It's not clear if your printer is working or not but if you have one typo in (for example) a json file on the printer then it halts the boot process before ssh daemon is started which sort-of bricks your printer.  The olimex is a cheap (around 10 euros) and easy solution to find the error message and fix the typo on a UM3 or S3.  Or to modify network settings (use connman utility).

 

Someone with recent firmware and an S5 also complained about ssh not working anymore.

 

 

Share this post


Link to post
Share on other sites
Posted · S3 5.3.6 - unable to connect ssh

We just purchased a large number of S3's (40 of them) and can confirm this issue.  100% of them on firmware versions 5.2.15 (what they shipped with) and 5.3.6 (what we just updated to) do not have SSH functionality after activating developer mode.  Unfortunately there are certain configs that necessary for our environment.  

 

[removed per request from chip]

Share this post


Link to post
Share on other sites
Posted · S3 5.3.6 - unable to connect ssh

Chip - know that with an olimex cable you should be able to connect to your S3 printers and access linux that way.  This is a serial (on the printer end) to USB cable which can connect to linux/mac/pc that has "serial terminal" software that lets you use a console that talks to your S3.  I don't have an S3 (just S5 and UM3) so I don't know 100% that this will work but I'm 90% sure it will.  I sell these olimex cables in my store by the way for people in USA at thegr5store.com.  If you are in Europe then it's easier to get them directly from the manufacturer.

 

It sounds like UM disabled ssh in the newer versions of their firmware.  This is unfortunate.

 

Share this post


Link to post
Share on other sites
Posted · S3 5.3.6 - unable to connect ssh
11 hours ago, Chip_Bobbert said:

I know the dev's monitor this forum.  We need this issue fixed by the end of tomorrow or we'll have to RMA the S3's. 

Not as much as you might think, but in this case at least one (me) saw it. I've notified the firmware team and they are having a look at it. 

  • Thanks 1

Share this post


Link to post
Share on other sites
Posted · S3 5.3.6 - unable to connect ssh
14 hours ago, gr5 said:

Chip - know that with an olimex cable you should be able to connect to your S3 printers and access linux that way.  This is a serial (on the printer end) to USB cable which can connect to linux/mac/pc that has "serial terminal" software that lets you use a console that talks to your S3.  I don't have an S3 (just S5 and UM3) so I don't know 100% that this will work but I'm 90% sure it will.  I sell these olimex cables in my store by the way for people in USA at thegr5store.com.  If you are in Europe then it's easier to get them directly from the manufacturer.

 

It sounds like UM disabled ssh in the newer versions of their firmware.  This is unfortunate.

 

 

No, this is incorrect, SSH was not removed. We are investigating why these users are not able to connect but engineers at HQ are.

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
Posted · S3 5.3.6 - unable to connect ssh
On 12/20/2019 at 3:48 AM, sono said:

Allwinner A20 is a common ARM SoC. The board mentioned in that post has USB and HDMI, so I don't know why they are using a TTL / RS232 adapter but either way getting a console on such devices is trivial unless the device has been intentionally locked down, as is not the case here. Once on the console, it should be quick to find the cause why ssh is not running or filtered. Should be a one time thing.

 

It has not been locked down. In fact SSH was never removed from the firmware. Could you share your logs with me so I can get them in front of the Devs at HQ? They do not have any problem enabling Dev mode and using SSH. We are trying to figure out why some users are having this problem.

Share this post


Link to post
Share on other sites
Posted · S3 5.3.6 - unable to connect ssh
On 12/5/2019 at 6:24 AM, sono said:

Hey,

 

I was wondering if there are any known issues or any other users are experiencing this issue.

 

First observed with putty on LAN (no filters) and then verified with a direct crossover connection from a linux laptop running dnsmasq.

Port 22 is closed (connection refused.)

Dev mode is activated, verified on S3 Display, numerous restarts. Tried re-enabling etc. etc.

 

Now I don't want to say that I might not still be overlooking something silly but it seems exceedingly unlikely.

 

Anyone got something?

 

Thanks,

sono


How were you connecting to the machine? Wifi, ethernet?And you enabled DEV mode? I can get this addressed if I have this info, thanks again!

Share this post


Link to post
Share on other sites
Posted · S3 5.3.6 - unable to connect ssh

This issue has been resolved. Please contact support (or me) to get the patch. It will be included in the nest firmware for the S3. Thanks for reporting everyone!

  • Like 2

Share this post


Link to post
Share on other sites
Posted · S3 5.3.6 - unable to connect ssh

I just had time for a quick check, in my case the issue is that dropbear can not start because no host keys are present.

 

I'll try your hotfix tomorrow.

 

Share this post


Link to post
Share on other sites
Posted · S3 5.3.6 - unable to connect ssh

Applying the hotfix has solved the issue. Thanks everyone.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • Survey: Understanding your workflow
      Interact with future concepts and aim to collect your feedback and opinion. In particular, if this would/could be a welcome addition to your 3D printing workflow. Interested?
      • 0 replies
    • Coronavirus: Let's do our part
      Through this post I would like to further explain what we are doing, and what you could be doing. 
      Our efforts consist of 2 layers. First; connect medical institutions and hospitals to (local) 3D Printing hubs to help them print parts of which a 3D model already exists. And second, contribute to design the necessary part and then have it printed via a (local) 3D printing hub. Experts are available from within Ultimaker and from within our network of 3D printing experts.
        • Like
      • 52 replies
×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!