Jump to content
macaron

Multi extruder issue

Recommended Posts

Posted · Multi extruder issue

Hi,

 

Last week I received my new printer; a geeetech A30M; 2 extruders, 1 hot end.

 

I'm working on mac, Cura 4.4.1.

I download profiles for the A30M; I have 2 extruders setup on Cura.

 

The issue is when I use the second extruder, the hotend start to heat at the beginning of the print and stop at the end of the first layer or (the brim?)

 

For sample, I want to print a part only with extruder 1.

I test to print in USB, I saw on the computer screen, that the cura start to heat at 200° the extruder 0, extruder 1 is at 0°.

after the brim or layer #0, extruder 0 temp goes to 0° as extruder 1 !

 

other sample

If i try to preheat extruder 0; it works

If I try to preheat extruder 1 ... Nothing Append.

 

How could I do to make cura control extruder 1 like extruder 0 ?

 

thanks

 

Share this post


Link to post
Share on other sites
Posted · Multi extruder issue

Find something !

 

Use Post Processing Script twice:

Once to replace M104 T1 with just M104

and M109 T1 with M109

 

 

Is it possible for the development team to manage with an option 2 extruders with one hotend by implement these features directly in CURA ?

Share this post


Link to post
Share on other sites
Posted · Multi extruder issue

Ohter search and replace script found :

 

replace M104 T. S0 with ;removed M104 T. S0  (USE REGULAR EXPRESSION = ON)

 

Share this post


Link to post
Share on other sites
Posted · Multi extruder issue

Hello @macaron, I have contributed to Cura a setting that informs Cura that the extruders share a heater. I don't think this feature has made it yet into a UM Cura release but if you install one of my releases you can try it out. You can find my releases at https://www.dropbox.com/sh/s43vqzmi4d2bqe2/AAADdYdSu9iwcKa0Knqgurm4a?dl=0. Please read the README.md file there for more information.

 

The shared heater setting is in the machine settings dialog...

 

Screenshot_2020-01-19_09-07-27.png.d64b0dfb1102499a1c0fb3e92c2c3fbb.png

 

Share this post


Link to post
Share on other sites
Posted · Multi extruder issue

thanks.

I saw in Cura forum that the issue is dismissed ! Developers focus on the ultimaker printer issues !

 

I'm on mac (Os X). Is your releases compatible ?

 

 

Share this post


Link to post
Share on other sites
Posted · Multi extruder issue
18 minutes ago, macaron said:

I saw in Cura forum that the issue is dismissed ! Developers focus on the ultimaker printer issues !

 

That is entirely reasonable. That's why they get paid.

 

19 minutes ago, macaron said:

I'm on mac (Os X). Is your releases compatible ?

 

Yes, I build releases for Linux (x86_64 and armv7l), Windows and MacOS. The MacOS releases are for High Sierra or later.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!