Jump to content
Ultimaker Community of 3D Printing Experts
  • Sign Up

I created "definition files" for Flashforge Dreamer3d

Recommended Posts

Posted · I created "definition files" for Flashforge Dreamer3d

hi there!

i am currently working on flashforge dreamer3d definitions.


right now it works perfectly fine with      one extruder!


for dual extrusion i ran into two problems and could use some help here.  thx in advance !!



cura adds a line with "T0" to the gcode file right infront of my own startcode if you activate the second extruder!

this renders the file unusable.. dreamer3d cancels the print immediately!



if i manually remove the "T0" line from the gcode file the dreamer3d accepts it and starts printing, but it uses the same extruder for bot parts instead of switching extruders





ich hosted the def.json files on github and hopefully someone is able to help getting dualextrusion to work.. i'm kinda stuck right now 😞




i attached a file where two simple 10x10x4 mm cubes were sliced in cura (the left one with extruder0 the right one with extruder1)


Share this post

Link to post
Share on other sites
Posted · I created "definition files" for Flashforge Dreamer3d

well..  i tried to get help from the cura dev team.. but the issue is marked as "won't fix" now since this ought to be a flashforge firmware problem rather than something they could fix in cura.. 





i'm not sure about that though.. 

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...