Jump to content
Ultimaker Community of 3D Printing Experts

Ultimaker S5 Camera Not Working


Recommended Posts

Posted · Ultimaker S5 Camera Not Working

Hello,

 

I have an S5 and I'm just starting to do longer prints which are lasting for about a day, so i was hoping to use the camera fitted in the S5. However, when i click on the little camera in the monitor section of cura the screen goes a bit faint. I then clicked on the manage printer in browser link which led me to cura connect and there was my printer with a video camera button next to it, so i clicked it but still nothing happened. A black screen appears with a small page icon in the corner or a cross. 

I have reset cura connect on the printer as some people have suggested but it still doesn't work. 

It would be nice to use this feature to check on my printer remotely.

 

Thanks in advance,

Ewan

  • Link to post
    Share on other sites
    • 2 weeks later...
    Posted · Ultimaker S5 Camera Not Working

    If a cura connect reset is not working then I would contact your reseller. The issue that the camera is not working after some time, is a software issue, but after a cura connect reset it should work again for the next period. If not there is maybe a hardware issue which sould be solved.

     

    On 1/29/2020 at 10:57 AM, ewanoss9 said:

    It would be nice to use this feature to check on my printer remotely.

    Be aware that is will only work on your local network. So you can use a VPN solution to connect from remote to your network, but not via the cloud. It is also not a good idea to open and forward the port on your router/firewall to the printers streaming port, it would be open for the whole world.

  • Link to post
    Share on other sites
    • 2 weeks later...
    Posted · Ultimaker S5 Camera Not Working

    I spent the first few months trying to get my new S5 WiFi to work without dropping all the time. Finally gave up and cut a hole in the wall and hard wired it to the router, really wanted that WiFi, though! But seeing the boards were full of people with same issue, it seemed UM was not going to get it fixed.

     

    Now camera is not working.... and I see the boards are full of the same kind of talk like the WiFi...suppose I'll wind up getting an off the shelf camera and mounting it in the printer with an app to my phone to have reliable camera. 

     

    I am super happy with how it prints but these problems with basic technology that $300 toys do better with is dissatisfying.  Seems like the camera and wifi  were afterthoughts to the designers.

     

    Wonder how smooth the new material station add on is working 😉

  • Link to post
    Share on other sites
    Posted · Ultimaker S5 Camera Not Working

    I've had two S5 for a year now and there's never been a firmware where the camera has worked consistently good. Rarely works for more than a few hours after a reboot or a reset. It is really annoying as most of my prints are really long and it's nice to be able to check in on them.

     

    Just searching again to see if anyone had a solution and decided I would finally add my complaint! Come on Ultimaker, get it fixed! Webcam is not a new tech! 

  • Link to post
    Share on other sites
    Posted · Ultimaker S5 Camera Not Working

    Hey together, 

    I've the same problem with the S5 Pro. At the beginning everything works and the S5 ist available, after a time the connection is lost! In Cura, the App or wherever it says the printer is not available and the camera shows a black screen. This for system for over 10k Euros. And Ultimaker is aware of the problem. 

    I really hope it will be fixed. 

     

    Best regards!

  • Link to post
    Share on other sites
    Posted · Ultimaker S5 Camera Not Working
    On 2/15/2020 at 8:59 PM, RodBot said:

    I spent the first few months trying to get my new S5 WiFi to work without dropping all the time. Finally gave up and cut a hole in the wall and hard wired it to the router, really wanted that WiFi, though! But seeing the boards were full of people with same issue, it seemed UM was not going to get it fixed.

     

    Now camera is not working.... and I see the boards are full of the same kind of talk like the WiFi...suppose I'll wind up getting an off the shelf camera and mounting it in the printer with an app to my phone to have reliable camera. 

     

    I am super happy with how it prints but these problems with basic technology that $300 toys do better with is dissatisfying.  Seems like the camera and wifi  were afterthoughts to the designers.

     

    Wonder how smooth the new material station add on is working 😉

     

    Same issues here with the camera.

     

    Went all-in and purchased the air handler and material station.  Both are working wonderfully.  The is a noticeable amount of material purge at the beginning of any print start.  I didn't have this when I was using a community S5 printer with no material station.  Seems like unnecessary waste, and I have found no way to turn it off.

    • Like 1
    Link to post
    Share on other sites
    Posted · Ultimaker S5 Camera Not Working

    Our UMS5 keeps loosing camera feed as well. The only way to get it going again is to re-boot the printer. We use the camera quiet a bit as I am based away from the printer so need to keep an eye on it. Maybe add a feature onto the next firmware update that allows just the camera to be re-booted, so if you are printing it wont affect it.

  • Link to post
    Share on other sites
    Posted · Ultimaker S5 Camera Not Working

    Hi guys, thank you for reporting. 

    It is a known issue where the printer sometimes can run out of memory and due to prioritisation it drops the camera feed to ensure the other crucial print features remain operational. A poor wifi network could also be a reason, albeit a different one. We've significantly reduced the chances of this happening now if you run 1 Ultimaker. If you run multiple in a group, the chances of this occurring are still a little bit higher. 

    Can you let me know if you run 1 or multiple Ultimaker S5's? 

    If it is multiple, can you share your log files with me? Thank you for your time and our apologies for the inconvenience. 

  • Link to post
    Share on other sites
    Posted · Ultimaker S5 Camera Not Working

    We are running 1 Ultimaker S5 with a wired connection.

  • Link to post
    Share on other sites
    Posted · Ultimaker S5 Camera Not Working

    1 Ultimaker with a wired connection to our network

  • Link to post
    Share on other sites
    Posted · Ultimaker S5 Camera Not Working

    Hey @SandervG,

     

    hope you're doing well! I'm using an UM3E and the S5 Pro Bundle, both connected via LAN! The UM3 is working quote well regarding the camera feed, only after hours of printing it can be that the feed is stopping, but the S5 Pro Bundle chancel its connection sometimes after only one hour. Your collegues mentioned that the problem is known and would be solved with the next update, so why are you asking these questions now?

    Best regards and stay healthy!

  • Link to post
    Share on other sites
    Posted · Ultimaker S5 Camera Not Working

    Thank you for your reply @SandervG.  I am running two Ultimaker s5 with material stations.  They are grouped (usually)  and are hardwired to the network.  I am wondering if the number of completed print jobs that are still in the printer's memory is what you are looking for.  I bet there's a lot!  I am running up to the school to take care of some other items today or tomorrow, but if you share some data dumping instructions maybe I can clear up some memory on them.  (Running a CADD lab at a high school virtually is now a totally different monster!)  🙂

  • Link to post
    Share on other sites
    Posted · Ultimaker S5 Camera Not Working

    I am running two S5's independently and have tried wired and wireless with no real difference.  

  • Link to post
    Share on other sites
    Posted · Ultimaker S5 Camera Not Working

    Hi Thank you everybody for getting back with me. 

    Are your printers still available for new commands, except it's 'just' the camera that is not working? Or is the entire connection lost? 

     

    I checked with our product experts, and they've informed me that in the upcoming firmware release there should be a fix where the camera should be able to regain connection after it has lost connection at some point, which should result in a much more stable experience. The exact release date is not known yet, but you might find it comforting to know that a solution is coming! 

  • Link to post
    Share on other sites
    Posted · Ultimaker S5 Camera Not Working

    Strictly camera feed for our S5 Pro.

  • Link to post
    Share on other sites
    Posted · Ultimaker S5 Camera Not Working
    On 4/1/2020 at 8:39 AM, SandervG said:

    Hi guys, thank you for reporting. 

    It is a known issue where the printer sometimes can run out of memory and due to prioritisation it drops the camera feed to ensure the other crucial print features remain operational. A poor wifi network could also be a reason, albeit a different one. We've significantly reduced the chances of this happening now if you run 1 Ultimaker. If you run multiple in a group, the chances of this occurring are still a little bit higher. 

    Can you let me know if you run 1 or multiple Ultimaker S5's? 

    If it is multiple, can you share your log files with me? Thank you for your time and our apologies for the inconvenience. 

    3 Ultimakers S5. One is the group host and the other two members. All Ethernet, latest Firmware. Connection gets lost at Cura and online locally as well as remotely via VPN. Can provide the logs later this week.

  • Link to post
    Share on other sites
    Posted · Ultimaker S5 Camera Not Working

    I Ultimaker S5 on a wired network connection.

  • Link to post
    Share on other sites
    Posted · Ultimaker S5 Camera Not Working

    I would love to hear when a new firmware to address this becomes available.  We have 6 of the S5's at my office, and they are NOT grouped.  All hardwired.  And the camera feed is only available for a few hours after rebooting and running prints.

     

    We are actively printing on them (face-shield parts) and the inability to access the webcam is a PITA when you are remote!

     

    Thanks!

  • Link to post
    Share on other sites
    Posted · Ultimaker S5 Camera Not Working
    On 4/1/2020 at 8:39 AM, SandervG said:

    Hi guys, thank you for reporting. 

    It is a known issue where the printer sometimes can run out of memory and due to prioritisation it drops the camera feed to ensure the other crucial print features remain operational. A poor wifi network could also be a reason, albeit a different one. We've significantly reduced the chances of this happening now if you run 1 Ultimaker. If you run multiple in a group, the chances of this occurring are still a little bit higher. 

    Can you let me know if you run 1 or multiple Ultimaker S5's? 

    If it is multiple, can you share your log files with me? Thank you for your time and our apologies for the inconvenience. 

    Hello SandervG -

     

    Can you clarify what is meant in your statement about it being less likely when running one ultimaker?  Was this something that was in a recent firmware update?  I don't know if our machines are all updated to the latest, but if not, I would be willing to try updating them to see if something changes.

     

    These are the versions we have right now:

    5.5.12.20200226

    5.5.12.20200226

    5.5.12.20200226

    5.4.27.20191212

    5.2.11.20190503

    5.5.12.20200226

     

    So clearly two of them are out of date, but the remaining printers look like they are on the same version dated 02/26/2020.

     

    Is there a newer version than the above?

  • Link to post
    Share on other sites
    Posted · Ultimaker S5 Camera Not Working

    I have a long running ticket with UM support about this. I've send multiple logs and offered to help in any way possible.  Still no solution.  I run mine via Wifi.

     

    What I've learned:

    If you're network is still up, but camera is down and you have dev mode enabled, you can SSH to the printer and type

    systemctl restart mjpg-streamer@0

    to get the camera working. I just leave an SSH session open to the printer, as it requires a restart multiple times per job.

     

    WiFi will usually stays up indefinitely if the printer isn't doing anything, but as soon as you start printing, ping times go up and packets start dropping.  Seems to me like there is too low of a priority on the WiFi processes running in the operating system. 

     

    If it's a memory problem, why in the world isn't there more memory in a $5K machine?  it's cheap!  Are they expandable?  Can something please be done to fix this?

     

    If I can provide any logs or assistance to get this working, PLEASE let me know.

     

    40832 is the ticket number I have open with UM Support, if anyone needs to reference it

     

  • Link to post
    Share on other sites
    Posted (edited) · Ultimaker S5 Camera Not Working
    On 4/23/2020 at 10:16 PM, krknopp said:

    I have a long running ticket with UM support about this. I've send multiple logs and offered to help in any way possible.  Still no solution.  I run mine via Wifi.

     

    What I've learned:

    If you're network is still up, but camera is down and you have dev mode enabled, you can SSH to the printer and type

    
    systemctl restart mjpg-streamer@0

    to get the camera working. I just leave an SSH session open to the printer, as it requires a restart multiple times per job.

     

    WiFi will usually stays up indefinitely if the printer isn't doing anything, but as soon as you start printing, ping times go up and packets start dropping.  Seems to me like there is too low of a priority on the WiFi processes running in the operating system. 

     

    If it's a memory problem, why in the world isn't there more memory in a $5K machine?  it's cheap!  Are they expandable?  Can something please be done to fix this?

     

    If I can provide any logs or assistance to get this working, PLEASE let me know.

     

    40832 is the ticket number I have open with UM Support, if anyone needs to reference it

     

     

    Thanks for that info.  We initially tried turning on dev mode on all of the printers, but I kept running into issues with the machines getting stuck in a weird state.  I was trying to reboot them remotely (sudo reboot), and I think this was causing the problem.

     

    I might try turning it back on for one (or more) of them and trying your suggestion above.

     

    Thanks!

    Edited by jeffroe
    • Like 1
    Link to post
    Share on other sites
    Posted · Ultimaker S5 Camera Not Working

    We are having the problem with the cam going black, during long printjobs. When can we expect is to be fixed?

  • Link to post
    Share on other sites
    Posted · Ultimaker S5 Camera Not Working

    Hello, we expect that the next firmware version help a lot in this regard. The exact release date I don't know yet unfortunately, but we're working on it! 

  • Link to post
    Share on other sites
    Posted (edited) · Ultimaker S5 Camera Not Working
    On 4/23/2020 at 10:20 PM, jeffroe said:

     

    Thanks for that info.  We initially tried turning on dev mode on all of the printers, but I kept running into issues with the machines getting stuck in a weird state.  I was trying to reboot them remotely (sudo reboot), and I think this was causing the problem.

     

    I might try turning it back on for one (or more) of them and trying your suggestion above.

     

    Thanks!

    Well, that command actually did work for me yesterday to re-enable the printer's camera!  At least we have SOMETHING to get the camera operational again during a print...

    Edited by jeffroe
    • Like 1
    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    ×
    ×
    • Create New...