Jump to content
Ultimaker Community of 3D Printing Experts

Settings Guide plugin not showing


Recommended Posts

Posted · Settings Guide plugin not showing

Hello! First post here, excuse obvious newb question(s). 

 

I've been looking at several videos about setting up cura for first time use. It was recommended that I install the Settings Guide plugin in the marketplace, which I've done, but for whatever reason it's not showing up in the extensions like (I think) it's supposed to. Despite the marketplace saying that it's installed. Is there a trick to this I'm missing?

 

This is on a relatively new Macbook Pro running macOS 10.15.3 Catalina, in Cura 4.4.1. I've tried resetting the app by deleting the cura folder in ~/library/application support and resetting everything up, no change. 

  • Link to post
    Share on other sites
    Posted · Settings Guide plugin not showing

    This is a problem in connection with the MacOS. MacOS does not allow any menu item starting with "Setting", so the plugin does not display the menu item.

     

    You can fix it yourself, go to the CUra configuration folder, then plugins -> SettingsGuide2 and open the file CuraSettingsGuide.py

    Search for this line of code:

    self.addMenuItem("Settings Guide", self.startWelcomeGuide)

    And use something else for the menu item name:

    self.addMenuItem("My Settings Guide", self.startWelcomeGuide)

     

    Restart Cura and it should be shown in the menu bar.

    • Like 1
    Link to post
    Share on other sites
    Posted · Settings Guide plugin not showing

    Workaround for now is to open the guide by right-clicking on a setting you'd like to learn about. I'll try to find a solution before the next release of the plug-in. Maybe it helps to replace it with the Cyrillic character "Ѕ", which looks almost the same.

  • Link to post
    Share on other sites
    Posted · Settings Guide plugin not showing

    @ghostkeeper I am sorry to say, but the menu item is not shown. It is generally strange, because I tried to use a complete different name too "Cura Guide" in ine 53, but it is still not working. The context menu in line 67 is working, but this was always the case.

     

    The "Settings Visibility" plugin from Aldo was working as soon as we choosed another name. So I guess you do something different to show the menu item. I haven't checked if you use a different function.

     

     

  • Link to post
    Share on other sites
    Posted · Settings Guide plugin not showing

    I see now that I've edited the wrong one. Could you re-test with this plug-in? SettingsGuide7.0.0.zip

     

    As you can imagine, without a MacOS computer I'm sort of programming in the blind, so thanks for your help! You get a free preview of version 2.2 with the troubleshooting pages ;)

  • Link to post
    Share on other sites
    Posted · Settings Guide plugin not showing

    No problem, I am here and happy to help 🙂

     

    But sorry....

     

    image.png.48f6d350f1feec7a02982ae64922b397.png

     

    Context menu is working

     

    image.thumb.png.94a5aa841821af430025966e8f612e4e.png

     

     

     

  • Link to post
    Share on other sites
    Posted · Settings Guide plugin not showing

    @Smithy can I ask you to give it one more try on your computer? I've taken a look at how fieldOfView solved this in his plug-in and found something that was probably the solution for him.

     

    You can download it here: SettingsGuide7.0.0.zip You might have to uninstall an old version first. This one has version number 2.1.99, newer than the Marketplace version but not yet 2.2 (so you can still upgrade later).

     

    This version also completes the guide-in-setting-tooltips feature for 2.2, but that's just bonus 😉

  • Link to post
    Share on other sites
    Posted · Settings Guide plugin not showing
    55 minutes ago, ghostkeeper said:

    I've taken a look at how fieldOfView solved this in his plug-in and found something that was probably the solution for him.

     

    Now I'm curious. What did I do?

  • Link to post
    Share on other sites
    Posted · Settings Guide plugin not showing

    Yeah! It is working! Great, many thanks!

     

    image.thumb.png.c843fc128b6b06cfe3c67f77f1601cd6.png

  • Link to post
    Share on other sites
    Posted · Settings Guide plugin not showing
    4 hours ago, ahoeben said:

     

    Now I'm curious. What did I do?

    You did this! https://github.com/fieldOfView/Cura-SettingVisibilityProfileCreator/commit/0d41f8af7ba97d7a9c1d518a0a6f05226618a187

     

    I did something similar: https://github.com/Ghostkeeper/SettingsGuide/commit/6d0b97cfa16d92438ed35a57b97c84fc92d7ee74

     

    Thanks for helping with the testing, Smithy! I'm working on finishing up the release this weekend. This is crucial since the plug-in got broken in Cura 4.5...

    • Like 2
    Link to post
    Share on other sites
    Posted · Settings Guide plugin not showing

    I'm not sure if I love or hate that trick with the Cyrillic S. Probably both 😉

  • Link to post
    Share on other sites
    Posted · Settings Guide plugin not showing

    Hi,

    really good help but my computer is running under windows 10 and I have the same problem. I don't find the folder I need to edit.

     

    Thanx for answers

  • Link to post
    Share on other sites
    Posted · Settings Guide plugin not showing

    The issue identified and solved in this thread sofar is specific to OS X. If you are experiencing something similar on Windows, we need logs to see what is going on. See Help -> Show configuration folder. Locate the "cura.log" file and upload it somewhere. Then post a link to it here.

  • Link to post
    Share on other sites
    Posted · Settings Guide plugin not showing

    Here is the link :https://we.tl/t-KFsj3usvxv

     

    I had this problem with cura 4.4.1 so i tried 4.5 beta and i've the same problem, this file is from cura 4.5 beta

  • Link to post
    Share on other sites
    Posted · Settings Guide plugin not showing

    Thanks for the log. In that log, there is no trace of the Settings Guide plugin being installed or its files being on your system. Did you install it from the Marketplace?

  • Link to post
    Share on other sites
    Posted · Settings Guide plugin not showing

    Yes, except the 4.5 in Github

  • Link to post
    Share on other sites
    Posted · Settings Guide plugin not showing
    16 minutes ago, Galaxie12 said:

    Here is the link :https://we.tl/t-KFsj3usvxv

     

    I had this problem with cura 4.4.1 so i tried 4.5 beta and i've the same problem, this file is from cura 4.5 beta

    Dear galaxie, explain step by step where to install or enable this cura.log

  • Link to post
    Share on other sites
    Posted · Settings Guide plugin not showing

    The file cura.log was in C:\Users\******\AppData\Roaming\cura\4.5

  • Link to post
    Share on other sites
    Posted · Settings Guide plugin not showing
    13 minutes ago, Galaxie12 said:

    Yes, except the 4.5 in Github

     

    I don't know what you mean by this. Did you install it through the Marketplace on 4.5 or not?

     

    If you installed it manually from github then you did not put it in the correct location because the plugin is not seen by Cura at all. Best course of action is to undo what you did in Cura 4.5 and just install the plugin from the Marketplace. This should work as expected on Windows. If it doesn't, post a new version of your cura.log after installing from the Marketplace and restarting Cura.

  • Link to post
    Share on other sites
    Posted · Settings Guide plugin not showing
    Link to post
    Share on other sites
    Posted · Settings Guide plugin not showing

    Cura doesn't ship with the settings guide. It will not show up unless you manually download the guide.

     

    Please follow these steps:

    1. Download the settings guide from here: https://github.com/Ghostkeeper/SettingsGuide/releases/download/v2.2.0/SettingsGuide7.0.0.curapackage
    2. Open Cura.
    3. From the downloads folder, drag that .curapackage file onto the main window of Cura.
    4. Restart Cura.

    Afterwards, you should be able to right-click on any setting to access the guide.

     

    I've submitted the new version of the settings guide to the Marketplace as well which should make it easier to install. The version on there currently is not compatible with Cura 4.5.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    • 27 Visiting our virtual showroom

      1. 1. Have you visited our virtual showroom before?


        • Yes
        • No
      2. 2. If yes - what content did you find most interesting?


        • Information about Ultimaker ecosystem
        • Applications & application stories
        • Customer success stories
        • Webinar sessions
        • Material wall & ecosystem partners
        • New product introduction; software subscription plans
      3. 3. What of the below would make you consider visiting (again)?


        • New Live Ultimaker Webinar streams
        • ‘Ask Me Anything’ with industry experts or Ultimaker staff via main stage and public chat
        • New customer success stories
        • New applications
        • Presentations/news from ecosystem partners
        • Opportunity to meet representatives for an interactive tour
        • Helpful videos like Software tutorials
        • Other; leave input in a comment below!

    • Our picks

      • Ultimaker turns 10: A look back
        Ultimaker is turning 10 years old and that means it is story telling time! We'll explore 2010-2014, traveling through the evolution of the business from the Protobox and Ultimaker Original, to the major leaps forward with the Ultimaker 2 and Ultimaker 3.
          • Like
        • 0 replies
      • Ultimaker Transformation Summit
        Visit our virtual showroom and learn more about the Ultimaker ecosystem!
        • 14 replies
      • New here? Register your Ultimaker for free 3D printer onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 0 replies
    ×
    ×
    • Create New...