Jump to content
lucabur

Message: this setting has been hidden ...

Recommended Posts

Posted · Message: this setting has been hidden ...

Hi, I am a novice in using Cura, and I've installed Cura 4.4. and jusr now 4.5 on Windows 10 64bit machine. My 3D printer is a Creality Ender 5 plus model, having a quite large hot bed, 350x350 mm. I encontered from the beginning serious adhesion problems to the hot bed unitil I got a PEI sheet 300x300 mm (the bigger I found). This drastically improved the quality of the printing jobs, solving the adhesion issue.

But there is a new problem now: the Prime Blob that is printed at the begin of each job is printed outside of the PEI sheet area, and the nozzle height in this position is of course to big, because I tuned it taking into account the PEI sheet thickness.

I tried both these:

  • Clearing the "Enabled Prime Blob" option
  • Changing the Prime Blob position with the "Extrude Prime X position" and "Extrude Prime Y position" options

 

But I can't modify any of these options and a "this setting has been hidden ... message is trying to explain me the reason without actually explaining anything.

Can anyone please explain me why these options are hidden  with a preset fixed value and how to make them available ?

 

Thanks a lot.

 

Luca

 

Share this post


Link to post
Share on other sites
Posted (edited) · Message: this setting has been hidden ...

I'm using Cura 4.3, so I do'nt see the creality ender5plus but I have the def.json file for the ender5.

Ender5 inherits from creality_base which inherits from fdmprinter for the settings

 

The fdmprinter.def.json file tells that enabled prime bob has the enabled var to false, which makes it invisible.

This parameter is not overridden by creality_base and ender5

 

For the ender5plus please check if this param is overridden with enabled=true, if not this params is not visible in cura. Maybe you may override it, i do'nt know this printer, by adding the line in the def.json file

Edited by JCD

Share this post


Link to post
Share on other sites
Posted · Message: this setting has been hidden ...
3 hours ago, lucabur said:

Can anyone please explain me why these options are hidden  with a preset fixed value and how to make them available ?

 

AFAIK "Prime Blob" is only usable for newer Ultimaker printers (with gcode flavor "Griffin") - it uses a custom gcode command that is ignored by other printers.

 

For all other printers such things are done in the start script. So the solution is: change the coordinates in the start script to take the reduced build area into account.

If needed you can lookup all gcodes and parameters in the Marlin documentation.

Share this post


Link to post
Share on other sites
Posted · Message: this setting has been hidden ...
Quote

The fdmprinter.def.json file tells that enabled prime bob has the enabled var to false, which makes it invisible.

This parameter is not overridden by creality_base and ender5

Thank you for the suggestion. I modified the "overrides" element of creality_ender5plus.def.json adding :

        "prime_blob_enable": { "enabled": true, "default_value": true },
        "extruder_prime_pos_x": { "enabled": true, "default_value": 30 },
        "extruder_prime_pos_y": { "enabled": true, "default_value": 30 }


but with only a partial success: now "prime_blob_enable" is visible in settings and can be enabled or disabled, but both the position elements X and Y have no effect: they can be checked in the Visibility setting panel, but are never shown in the actual setting. Moreover, the default values are ignored.

Share this post


Link to post
Share on other sites
Posted · Message: this setting has been hidden ...
Quote

it uses a custom gcode command that is ignored by other printers.

Thanks for the suggestion. I think you are right: I tried to modify the .def.json file, enabling the prime_blob parameters without success. I will now explore the generated Gcode to discover where and how the prime blob is created.

Share this post


Link to post
Share on other sites
Posted · Message: this setting has been hidden ...

The prime blob that your printer performs might simply be part of the start gcode. Google how to edit that and look at the reprap wiki for gcode to understand what the codes in the start gcode do exactly.

 

If it's not in the start gcode than the firmware of your printer might decide when and how to do the prime blob. In that case I can't help you.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Our picks

    • Survey: Understanding your workflow
      Interact with future concepts and aim to collect your feedback and opinion. In particular, if this would/could be a welcome addition to your 3D printing workflow. Interested?
      • 0 replies
    • Coronavirus: Let's do our part
      Through this post I would like to further explain what we are doing, and what you could be doing. 
      Our efforts consist of 2 layers. First; connect medical institutions and hospitals to (local) 3D Printing hubs to help them print parts of which a 3D model already exists. And second, contribute to design the necessary part and then have it printed via a (local) 3D printing hub. Experts are available from within Ultimaker and from within our network of 3D printing experts.
        • Like
      • 49 replies
×
×
  • Create New...

Important Information

Welcome to the Ultimaker Community of 3D printing experts. Visit the following links to read more about our Terms of Use or our Privacy Policy. Thank you!