Jump to content
Ultimaker Community of 3D Printing Experts

Union overlapping volumes problem in cura


Recommended Posts

Posted · Union overlapping volumes problem in cura

Hello !
I can't undersand why cura dos't union crossed parts with "Union overlapping volumes" option.
I come across from time to time something similar in different models.
I know that  option "Remove All Holes" can make it rigth for some case, but it not solution because original model must contain holles too.
I tried with cura 4.4 and 4.5.
Thanks.

sample_sketch.png

sample_stl.PNG

sample_cura.png

sample2_stl.PNG

sample2_cura.png

sample2_sketch.png

sample.3mf sample.stl sample2.3mf sample2.stl

  • Link to post
    Share on other sites
    Posted · Union overlapping volumes problem in cura

    I'm confused. If you know that your STL is broken (which it is), why not fix the model rather than trying to use Cura to work around it?

     

    But for what it's worth, both MS 3D Builder and the Cura plugin "Mesh Tools" could fix at least "sample.stl" which I tested.

  • Link to post
    Share on other sites
    Posted (edited) · Union overlapping volumes problem in cura

    Ok, I'll try to check and try with the "Mesh Tools".
    The statement "STL is broken" is news to me. I still do not quite understand what this means and how to see it (Windows 3D viewer shows the correct picture).
    If you mean dirties in details (overlapping elements instead of accurate adjacencies) then I really expect that the cura will accept this in order to reduce the time for prototyping.
    I made a model, I export to STL and expect to get what I painted.
    Here another problem arises for me ... What should I do or not do in the editor so that I get the correct STL (when I understand what it is) since iterative editing and small modifications of the model and subsequent editing of the STL can be tediously.

    At the moment, I have found a workaround. I uploaded STL to Slyc3r, just export to new STL and got what I needed in the Cura.
    Thanks !

    Edited by icool123
  • Link to post
    Share on other sites
    Posted · Union overlapping volumes problem in cura
    On 3/14/2020 at 10:31 PM, IRobertI said:

    I'm confused. If you know that your STL is broken (which it is), why not fix the model rather than trying to use Cura to work around it?

     

    But for what it's worth, both MS 3D Builder and the Cura plugin "Mesh Tools" could fix at least "sample.stl" which I tested.

     

    When you say 'broken', do you mean because it has two volumes that are overlapping?

     

    If so, isn't "Union Overlapping Volumes" supposed to address this exact problem? I'm also having this problem where "Union Overlapping Volumes" actually cuts the intersection out entirely, instead of unioning them.

  • Link to post
    Share on other sites
    Posted · Union overlapping volumes problem in cura

    Yes but I think you have "normals" errors.

     

    It looks to me in the first screenshot that you are using sketchup.  In sketchup if you see any gray surfaces you need to right click on these surfaces and choose "reverse faces".  This should fix your part in the eyes of Cura.  You may also have to do "union overlapping volumes" in cura but if you get the normals right then maybe not.

     

    However I think you changed your materials in sketchup so I guess you can't use that trick.  More information about normals and sketchup here:

    https://i.materialise.com/blog/3d-printing-with-sketchup/

     

  • Link to post
    Share on other sites
    Posted · Union overlapping volumes problem in cura

    Sorry, I'm not the original poster. I've been using Fusion 360, but get the same problem.

     

    I.e. If I have two intersecting bodies in Fusion 360, and then export that component as an STL, Cura cuts the intersecting section out.

     

    If this is not broken functionality, then I think I must be misunderstanding something. However I feel like the support article on this makes it pretty clear: https://support.ultimaker.com/hc/en-us/articles/360012614159-Mesh-fixes-settings

     

    Quote

    If a model contains two volumes that interfere (as if they were placed through each other), this setting allows you to fix that. Union overlapping volumes will recognize these interferences and try to slice it as one volume.

     

    This is then followed by a diagram. To be clear, when I have "Union overlapping volumes" enabled, what I see is the image in the diagram captioned "Union overlapping volumes disabled".

     

    If I am in fact misunderstanding how this setting is supposed to work, please let me know.

  • Link to post
    Share on other sites
    Posted · Union overlapping volumes problem in cura

    Some pictures to illustrate.

    cura.jpg

    f3d.jpg

    intersecting cube test v1.stl

  • Link to post
    Share on other sites
    Posted · Union overlapping volumes problem in cura

    If you have fusion 360 then you should be able to do a "binary or" or "union" in fusion.  It's much more sophisticated (1000X more sophisticated) than Cura and can do this kind of thing easily.  There may be a bug in the Cura feature but I can't say for sure as I would have to check the normals as well.  I've never had to use the "overlapping volumes" on my own models as, well, my CAD software just won't allow that so I don't know how to export such a thing as an STL.

     

    But I've used the feature on downloaded models and it helped me in the past.

     

     

  • Link to post
    Share on other sites
    Posted · Union overlapping volumes problem in cura
    12 hours ago, Setiawan said:

    To be clear, when I have "Union overlapping volumes" enabled

     

    "Slicing Tolerance" is set to "Exclusive", this prevents the union in this case.

    The default for this setting is "Middle". I dunno how many other options it interferes with - I guess it's in the "Experimental" section for a reason...

     

    grafik.thumb.png.dc08eaae59833848f7dc75769df417be.png

    • Like 1
    Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    ×
    ×
    • Create New...