Jump to content
Ultimaker Community of 3D Printing Experts
  • Sign Up
conicio

Cura will not sync with ultimaker account

Recommended Posts

Posted · Cura will not sync with ultimaker account

Hi folks.

Updated to Cura 4.5.0 but all my materials were gone (even the self made profiles)

I've added a material from marketplace to Cura 4.5.0

Now, everytime I start Cura it says "There are changes on your ultimaker account, do you wish to sync them?", I press OK then shows a list of the material added. "You need to restart Cura for the changes take effect", I quit Cura, restart Cura and repeat all the process again, and again, and again... 

What can I do?

 Thanks in advance and sorry for my poor english.

 

CoNiCiO

 

Share this post


Link to post
Share on other sites
Posted · Cura will not sync with ultimaker account

Could you share the log files?

Share this post


Link to post
Share on other sites
Posted · Cura will not sync with ultimaker account

Of course. Here it is.

By the way I'm on Mac OS Catalina

 

Thanx

cura.log

Share this post


Link to post
Share on other sites
Posted · Cura will not sync with ultimaker account

Do you have some firewall setup? The logs show that it can't reach the packages / plugins server.

Share this post


Link to post
Share on other sites
Posted · Cura will not sync with ultimaker account
2 hours ago, nallath said:

Do you have some firewall setup? The logs show that it can't reach the packages / plugins server.

It's allowed in the firewall options. I'll try disabling the firewall

But it only happens with a material profile. The rest of the plugins can be installed.

 

Thanks

 

Share this post


Link to post
Share on other sites
Posted · Cura will not sync with ultimaker account

Having the same issue with 4.5, even after restart it will not sync the materials.

  • Like 1

Share this post


Link to post
Share on other sites
Posted · Cura will not sync with ultimaker account

I am also having this issue. Has it been resolved? I just installed the Generic PETG profile and it keeps trying over and over.

Share this post


Link to post
Share on other sites
Posted · Cura will not sync with ultimaker account

Same here. Happens in both Ultimaker Cura 4.5.0 and 4.6.0 on macOS 10.15.4.

- tried complete uninstall, restarted computer, reinstall

- added "Full Disk Access" in security preferences

- explicitly added "allow incoming connections" in firewall rules to both 4.5.0 and 4.6.0

- happens on 2 different wifi networks and also via Verizon mobile tether

Share this post


Link to post
Share on other sites
Posted · Cura will not sync with ultimaker account

I'll move this thread to the 'online services'. Perhaps @ctbeke has any idea?

Share this post


Link to post
Share on other sites
Posted · Cura will not sync with ultimaker account

Without logs is hard to say what is going on. The logs provided in the 3rd post indicate some kind of network restrictions are in place that prevent Cura from calling the Ultimaker cloud services. The following helpdesk article explains which connections are made and which domains should be whitelisted for all services to work properly: https://support.ultimaker.com/hc/en-us/articles/360012113719-I-am-having-networking-trouble-with-my-printer. If after configuring all of this it still doesn't work, something else is going on in Cura, but with the current logging I cannot find out what that would be.

Share this post


Link to post
Share on other sites
Posted · Cura will not sync with ultimaker account

Here is my Cura log...

 

Still giving the sync note for all start ups with Cura today.

cura.log

Share this post


Link to post
Share on other sites
Posted · Cura will not sync with ultimaker account

Hi,

 

We have read through the logs, and it seems to be 'stuck' on the generic material profiles (it keeps thinking those have to be synced again). We'll investigate why those are not filtered out (because Cura ships with the same or a higher version of them). In the mean time, you can go to marketplace.ultimaker.com and unsubsribe from those, that will make the sync message for them go a way.

 

Chris

Share this post


Link to post
Share on other sites
Posted · Cura will not sync with ultimaker account

This issue has been picked up by the Cura team. Internal ref CURA-7425

  • Like 1

Share this post


Link to post
Share on other sites
Posted · Cura will not sync with ultimaker account
20 hours ago, ctbeke said:

it seems to be 'stuck' on the generic material profiles (it keeps thinking those have to be synced again). We'll investigate why those are not filtered out (because Cura ships with the same or a higher version of them).

 

The set of Generic profiles in my installation of Cura 4.6.1 (and 4.6.0, 4.5.0) is missing profiles like PETG that do appear in the marketplace Generic profiles.

This is why I chose to install them from the marketplace.

However, once installed, they still do not appear in Cura, as if they are not properly being overwritten (good ol' permissions issues?). 

 

Hope this helps!

Share this post


Link to post
Share on other sites
Posted · Cura will not sync with ultimaker account
3 hours ago, Semiconducted said:

 

The set of Generic profiles in my installation of Cura 4.6.1 (and 4.6.0, 4.5.0) is missing profiles like PETG that do appear in the marketplace Generic profiles.

This is why I chose to install them from the marketplace.

However, once installed, they still do not appear in Cura, as if they are not properly being overwritten (good ol' permissions issues?). 

 

Hope this helps!

 

Which printer are you using? Not all printer types support PETG and thus the material is hidden if such a printer is selected. The material is still installed, just not visible.

Share this post


Link to post
Share on other sites
Posted · Cura will not sync with ultimaker account
8 hours ago, ctbeke said:

The material is still installed, just not visible.

 

I was using an Ultimaker S5, though I usually use an Ultimaker 2+ Extended.

PETG is not shown for either printer before or immediately after the marketplace install nor after restarting Cura (as the 'success (?)' message requests).

 

Re: material not visible

My professional UX design advice is to handle this use case differently. Hiding incompatible materials creates a mismatch between the perceived system state and the actual system state. It also sets the user up to experience repeated "silent errors" wherein they install the material, get a "success" confirmation, but then see no system change, leaving them baffled as to what went wrong, even though nothing did.

 

I suggest indicating that the material is installed but just not available for this machine. It could be as simple as showing the unavailable materials as greyed out / not selectable. Or these materials could all be put in a separate 'incompatible with this printer' group. Or... (I could go on and on)

 

Share this post


Link to post
Share on other sites
Posted · Cura will not sync with ultimaker account

a small update - now every time I load a model it gives me a warning that the model has been updated and asks if I want to reload it. 

 

Logs included... 

cura.log

Share this post


Link to post
Share on other sites
Posted · Cura will not sync with ultimaker account
23 hours ago, Turnbolt said:

every time I load a model it gives me a warning that the model has been updated and asks if I want to reload it. 

 

+1

I had also been experiencing this behavior in 4.6.0 and 4.6.1 (don't recall if also in 4.5.0).

 

Share this post


Link to post
Share on other sites
Posted · Cura will not sync with ultimaker account
On 5/7/2020 at 9:33 PM, Turnbolt said:

a small update - now every time I load a model it gives me a warning that the model has been updated and asks if I want to reload it. 

 

Logs included... 

cura.log 3.37 MB · 0 downloads

That is a different issue.

Could you please report it on github? The forum is very badly suited for keeping track of these things.

Share this post


Link to post
Share on other sites
Posted · Cura will not sync with ultimaker account
4 hours ago, nallath said:

That is a different issue.

Could you please report it on github? The forum is very badly suited for keeping track of these things.

I would but I have no idea how to do that...

 

Is there an ultimaker github? Where do I post this? As I am not a programmer and have limited experience with github so I will need some instruction.

Share this post


Link to post
Share on other sites
Posted · Cura will not sync with ultimaker account

I'm also running into this, but with Ultimaker ABS. I do not own an Ultimaker machine, but Cura still has a little red notification by the marketplace button to get me to update Ultimaker ABS. Trying to update it gets me stuck in the infinite loop, and I don't know how else to make the notification go away.

  • Like 2

Share this post


Link to post
Share on other sites
Posted · Cura will not sync with ultimaker account

The same issue here as StormFalcon32. Infinite loop and notification doesn't go way.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...