Jump to content
Ultimaker Community of 3D Printing Experts

How do I turn off this initial triangle?


Recommended Posts

Posted · How do I turn off this initial triangle?

I am new to 3d printing so I apologize in advance if this is a basic question. But every time I start a print during the initial purging of the nozzle, my CR 10s Pro draws this triangle on the bed, I would prefer it to just draw a line down the side so that it doesn't interfere with the Initial layer of the actual print. Does anyone know how to adjust this? I'm using Cura 4.5 as my slicer. 

traingle.jpg

  • Link to post
    Share on other sites
    • Replies 74
    • Created
    • Last Reply

    Top Posters In This Topic

    Top Posters In This Topic

    Popular Posts

    I have the same issue with a CR10S Pro V2.  Like others note, the issue seems to be with the call to "M420 S1 Z2".  According to here (https://marlinfw.org/docs/gcode/M420.html), this command enables

    Yep, before the skirt.   I've got about 4 hours left on a print right now, but I'll try to remember to take a video when I start the next one and throw it up on Youtube sometime tomorrow if

    If you make your preset printer Creality CR-10S instead of CR-10S pro it works without changing any other settings.

    Posted Images

    Posted · How do I turn off this initial triangle?

    I opened the G-code back up with cura and I see the initial line on the left of the print bed, but I don't see the rest of the triangle..any idea of how I would change the script?

    g code.jpg

  • Link to post
    Share on other sites
    Posted · How do I turn off this initial triangle?

    ;FLAVOR:Marlin
    ;TIME:35273
    ;Filament used: 23.2464m
    ;Layer height: 0.2
    ;MINX:19.2
    ;MINY:89.362
    ;MINZ:0.2
    ;MAXX:280.8
    ;MAXY:210.638
    ;MAXZ:9.6
    ;Generated with Cura_SteamEngine 4.5.0
    M140 S110
    M105
    M190 S110
    M104 S250
    M105
    M109 S250
    M82 ;absolute extrusion mode
    M201 X500.00 Y500.00 Z100.00 E5000.00 ;Setup machine max acceleration
    M203 X500.00 Y500.00 Z10.00 E50.00 ;Setup machine max feedrate
    M204 P500.00 R1000.00 T500.00 ;Setup Print/Retract/Travel acceleration
    M205 X8.00 Y8.00 Z0.40 E5.00 ;Setup Jerk
    M220 S100 ;Reset Feedrate
    M221 S100 ;Reset Flowrate

    G28 ;Home
    M420 S1 Z2 ;Enable ABL using saved Mesh and Fade Height

    G92 E0 ;Reset Extruder
    G1 Z2.0 F3000 ;Move Z Axis up
    G1 X10.1 Y20 Z0.28 F5000.0 ;Move to start position
    G1 X10.1 Y200.0 Z0.28 F1500.0 E15 ;Draw the first line
    G1 X10.4 Y200.0 Z0.28 F5000.0 ;Move to side a little
    G1 X10.4 Y20 Z0.28 F1500.0 E30 ;Draw the second line
    G92 E0 ;Reset Extruder
    G1 Z2.0 F3000 ;Move Z Axis up

    G92 E0
    G92 E0
    G1 F2700 E-5
    ;LAYER_COUNT:48
    ;LAYER:0
    M107
    G0 F6000 X24.969 Y89.664 Z0.2
    ;TYPE:SKIRT
    G1 F2700 E0
    G1 F1200 X25.738 Y89.485 E0.02626
    G1 X26.522 Y89.385 E0.05255
    G1 X27.117 Y89.362 E0.07235
    G1 X34.2 Y89.362 E0.30793

  • Link to post
    Share on other sites
    Posted · How do I turn off this initial triangle?

    Yeah there's no triangle in the gcode.  Strange.  Does it do it before or after the line on the left edge?

     

    The line on the left edge is drawn with these commands:

    G1 X10.1 Y20 Z0.28 F5000.0 ;Move to start position
    G1 X10.1 Y200.0 Z0.28 F1500.0 E15 ;Draw the first line
    G1 X10.4 Y200.0 Z0.28 F5000.0 ;Move to side a little
    G1 X10.4 Y20 Z0.28 F1500.0 E30 ;Draw the second line

    Looking over the gcode it all looks fine.  

  • Link to post
    Share on other sites
    Posted (edited) · How do I turn off this initial triangle?

    It does it after. It draws the line on the left, draws to the center of the bed, and then back to the starting point. Then lifts up and starts the actual print. 

    Edited by furkasocal
  • Link to post
    Share on other sites
    Posted · How do I turn off this initial triangle?

    Were you able to figure out what is causing this?

     

    I've had an Ender 5 plus and it started doing the same thing but the gcode looks fine

  • Link to post
    Share on other sites
    Posted · How do I turn off this initial triangle?

    I looked this over again.  I think the gcode file got corrupted after you copied it to the SD card (are you printing through an SD card?)

     

    I think somehow one of the X10.1 or X10.4 got changed to X101 or X104 - the period got lost.  Actually it would be the first 10.4.  Can you open the file on the SD card and check that?

     

    I'd try writing the gcode file to a new location on the SD card and try printing the copy (instead of the original) - just the first few seconds to see if it makes the big triangle.

  • Link to post
    Share on other sites
    Posted · How do I turn off this initial triangle?

    Thanks! I'll take a look at that. It does it every time I slice something though. It's not just this file. 

  • Link to post
    Share on other sites
    Posted · How do I turn off this initial triangle?

    I am getting the triangle every time as well and it interferes with first layer. Did you find out how to prevent the triangle from happening? It does this on every print.

  • Link to post
    Share on other sites
    Posted · How do I turn off this initial triangle?

    I haven't found the solution yet but I am now sure it's a setting in Cura, a friend sent me a file sliced with a different program and the triangle didn't occur. 

  • Link to post
    Share on other sites
    Posted · How do I turn off this initial triangle?

    Can confirm it's not the printer, just set up a new CR10s Pro V2 yesterday and it's doing the same thing.  I've uninstalled/reinstalled Cura from my computer and that didn't fix it either.  It's not really ruining any of the prints, and before this happened I wasn't really sure what gcode even was, so on the bright side it's forcing me to learn stuff 🙂

     

    I might try rolling back to a previous version, but for now I'm just removing the triangle as soon as it's printed if I'm quick enough.

    2020-04-05.jpg

    • Like 1
    Link to post
    Share on other sites
    Posted · How do I turn off this initial triangle?

    Let me know if that solves the issue. Good to know that I am not the only one or that it is my printer.

  • Link to post
    Share on other sites
    Posted · How do I turn off this initial triangle?

    Okay this is so bizarre.  It does this *before* it does the skirt?  Can you post a 5 second video that shows what happens 1 second before and after it happens?  I see nothing of interest in the gcode but I'd like to narrow it down to one or two lines of code and seeing the video would help.

     

  • Link to post
    Share on other sites
    Posted · How do I turn off this initial triangle?

    Yep, before the skirt.

     

    I've got about 4 hours left on a print right now, but I'll try to remember to take a video when I start the next one and throw it up on Youtube sometime tomorrow if I have time.  It's nice to not be alone 😅

    • Like 2
    Link to post
    Share on other sites
    Posted · How do I turn off this initial triangle?

    Attached is the starting sequence before the skirt is added. It lays down the side line and then completes the triangle before placing the skirt. If I turn off skirt it does the same triangle and then goes right to the print.

    triangle.MOV.zip

    • Like 1
    Link to post
    Share on other sites
    Posted · How do I turn off this initial triangle?

    yup mine does the same thing.

  • Link to post
    Share on other sites
    Posted · How do I turn off this initial triangle?

    Here's one on each of my printers.

     

    CR10s Pro V2

     

    Ender 5 Plus

  • Link to post
    Share on other sites
    Posted · How do I turn off this initial triangle?

    Oh and here's the first little bit of Gcode for the Ender 5 Plus video above.

     

    ;FLAVOR:Marlin
    ;TIME:3627
    ;Filament used: 2.22282m
    ;Layer height: 0.2
    ;MINX:147.271
    ;MINY:66.732
    ;MINZ:0.2
    ;MAXX:202.8
    ;MAXY:283.146
    ;MAXZ:6.8
    ;Generated with Cura_SteamEngine 4.5.0
    M140 S60
    M105
    M190 S60
    M104 S215
    M105
    M109 S215
    M82 ;absolute extrusion mode
    M201 X500.00 Y500.00 Z100.00 E5000.00 ;Setup machine max acceleration
    M203 X500.00 Y500.00 Z10.00 E50.00 ;Setup machine max feedrate
    M204 P500.00 R1000.00 T500.00 ;Setup Print/Retract/Travel acceleration
    M205 X8.00 Y8.00 Z0.40 E5.00 ;Setup Jerk
    M220 S100 ;Reset Feedrate
    M221 S100 ;Reset Flowrate

    G28 ;Home
    M420 S1 Z2 ;Enable ABL using saved Mesh and Fade Height

    G92 E0 ;Reset Extruder
    G1 Z2.0 F3000 ;Move Z Axis up
    G1 X10.1 Y20 Z0.28 F5000.0 ;Move to start position
    G1 X10.1 Y200.0 Z0.28 F1500.0 E15 ;Draw the first line
    G1 X10.4 Y200.0 Z0.28 F5000.0 ;Move to side a little
    G1 X10.4 Y20 Z0.28 F1500.0 E30 ;Draw the second line
    G92 E0 ;Reset Extruder
    G1 Z2.0 F3000 ;Move Z Axis up

    G92 E0
    G92 E0
    G1 F1500 E-6.5
    ;LAYER_COUNT:34
    ;LAYER:0
    M107
    M204 S500
    M205 X8 Y8
    G0 F6000 X148.449 Y73.352 Z0.2
    ;TYPE:SKIRT

  • Link to post
    Share on other sites
    Posted · How do I turn off this initial triangle?

    VERY HELPFUL, THANKS!

    G1 Z2.0 F3000 ;Move Z Axis up
    G1 X10.1 Y20 Z0.28 F5000.0 ;Move to start position
    G1 X10.1 Y200.0 Z0.28 F1500.0 E15 ;Draw the first line
    G1 X10.4 Y200.0 Z0.28 F5000.0 ;Move to side a little
    G1 X10.4 Y20 Z0.28 F1500.0 E30 ;Draw the second line
    G92 E0 ;Reset Extruder
    G1 Z2.0 F3000 ;Move Z Axis up

    Well it's definitely the first "10.4" line.  This is so messed up!  It should not do this.  So when the video starts it is in the middle of the 3rd line of code above.   F is feedrate in mm/minute.  Divide by 60 to get mm/sec.  So that F1500 is 25mm/sec.  E is the E axis position - it's extruding 15mm of filament while it draws that line up the left side.  Again - this is the 3rd line of code above.

     

    4th line: Then it does the crazy move and it's moving faster as expected - at F5000 or 83mm/sec.  And you can clearly see that it is indeed about 3X faster.  BUT IT'S ONLY SUPPOSED TO MOVE LESS THAN A MILLIMETER TO THE RIGHT.

     

    5th line: then it moves back to the left front corner as it is supposed to while extruding (now goes from 15 to 30mm or extrudes another 15mm of filament - that's the E30).  And it's back to 25mm/sec.  The video confirms.  All is fine on the 5th line.

     

    6th line doesn't cause movement - it just tells the printer to think of this as position 0 for the extruder stepper.  

     

    7th line raises the nozzle 2mm - and it's in the video all good.

     

    YOUR PRINTER HAS A MARLIN WITH A SERIOUS BUG.  There are lots of bugs in marlin.  Anyway this is how I would fix it - get rid of the speed change, no need to mention Y or Z since they are not supposed to move (and don't):

     

    G1 X10.4 ;Move to side a little

    If it still moves to the center of the bed - just take the damn command out.  It's not really needed.  I'm guessing somehow the speed changes is causing the issue but there is no need to speed up when moving 0.4mm - I mean it's not going to make much difference!

    • Like 1
    Link to post
    Share on other sites
    Posted · How do I turn off this initial triangle?

    What I see in video is if the command was X104 instead of X10.4.

     

    I'm wondering it the period in 10.4 is not a normal period - maybe it's some kind of unicode character?  Or UTF8?  Another thing you could try is just change 10.4 to 11 and get rid of the period.

  • Link to post
    Share on other sites
    Posted · How do I turn off this initial triangle?

    Thank you. I will make the changes and see how it works. I appreciate the help.

     

  • Link to post
    Share on other sites
    Posted · How do I turn off this initial triangle?

    hi guys, i have an ender 5 plus and i am getting this same problem ONLY if i turn on auto leveling. if i turn off AL then the purge line does what it's suppose to do.

     

    considering the gcode remains the same, i'm guessing we need to add a "home" command somewhere before it does the purge line ??

     

    i have no idea how to gcode tho.

  • Link to post
    Share on other sites
    Posted · How do I turn off this initial triangle?

    I updated the gCode - it still does the triangle.  This was also an issue on the last two versions of Cura.  Thanks for you help working on this one.  

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

    ×
    ×
    • Create New...