Jump to content
Ultimaker Community of 3D Printing Experts

Recommended Posts

Posted (edited) · Heatbed problem

Good afternoon! i am a new member of this community.

My name is Valentino. i am 18 years old. I study at a techinical school and i have built a 3D printer.

I am about to finish it but I have a problem with the print bed. At first an error showed up saying "printer halted. kill () called" (something like "stopped printer"). After some research on TouTube I frund out that I have modified the temperature setting "WATCH_BED_TEMP_PERIOD". I have tried many times in pronterface, but I have always got the same message "Paused to use" and the red led in the print bed turns off. 

I would appreciate some help because I do not know  what else to do.

I let you know that I have a 300mm MK2a print bed 12v, also ramps 1.4 and Marlin 1.1.9, just in case it helps.

Thanks again for taking the time to read this message.

Greetings from Argentina!

 

Edited by Valen012
  • Link to post
    Share on other sites
    Posted · Heatbed problem
    14 hours ago, gr5 said:

    @tinkergnome - any ideas?

     

    Marlin 1.1.x is very different compared to the older versions that are used as the basis for Ultimaker firmware(s). So i can only guess.

    "WATCH_BED_TEMP_PERIOD" has something to do with thermal protection, right?

     

    "Paused to use" is not to be found in Marlin sources. But there is "busy: paused for user" - which is a normal "keep alive" message that is sent to the printing host while the printer is performing long-lasting operations.

     

    It's possible to (temporarily) disable "THERMAL_PROTECTION_BED" during the testing period. Just to rule out configuration errors in this area. But don't let it run unattended.

  • Link to post
    Share on other sites
    Posted · Heatbed problem
    Hace 1 hora, tinkergnome dijo:

     

    Marlin 1.1.x es muy diferente en comparación con las versiones anteriores que se utilizan como base para el firmware de Ultimaker. Entonces solo puedo adivinar.

    "WATCH_BED_TEMP_PERIOD" tiene algo que ver con la protección térmica, ¿verdad?

     

    "Pausado para usar" no se encuentra en las fuentes de Marlin. Pero hay "ocupado: en pausa para el usuario", que es un mensaje normal de "mantener vivo" que envía al host de impresión mientras la impresora realiza operaciones duraderas.

     

    Es posible deshabilitar (periódicamente) "THERMAL_PROTECTION_BED" durante el período de prueba. Solo para descartar errores de configuración en esta área. Pero no dejes que operan sin supervisión.

    Good afternoon!

    you are right!

    "WATCH_BED_TEMP_PERIOD" is for thermal protection.

    i'm sorry, when i said "paused to used" i meant "paused for user".

    so, do you recommend deactivating "THERMAL_PROTECTION_BED" in order to rum the temperature test (PID in Pronterface) and then activating it again?

    thanks again for your help, i really appreciate it.

  • Link to post
    Share on other sites
    Posted · Heatbed problem

    We aren't sure what is best as this is a newer version of Marlin than we are familiar with.  I'd disable it for a few minutes to figure out if everything is working - normally you don't need PID for the bed - you might have better luck with "bang bang" mode instead.

     

    Anyway if you disable this, then turn on the bed - pay attention to see if the temperature reading in Marlin is correct.  If not you have to fix that first.  It it is correct then check to see if the bed heats up.  If not then you have to fix that.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    ×
    ×
    • Create New...