Jump to content
Ultimaker Community of 3D Printing Experts
  • Sign Up
Z408

Over-Extrude in corners of top layers

Recommended Posts

Posted · Over-Extrude in corners of top layers

I have set my flow to extrude exactly 0.80 mm when I do two walls.  Each line is set to 0.40 mm.  When I print a cube with no top layer, the corners come out perfect.  When I print the same cube but with 3 top layers, it over-extrudes in the corners.  Please see attached pictures. 

 

Also, it seems to over-extrude or make an additional movement when other features are on the same line.  Not sure if that makes sense.  But basically the corner of this part should be the same in the vertical direction.  For some reason it is not.  

 

Printing with Hatchbox PLA, 190c extruder temp, 60c bed. 0.2 mm layer heights.

 

Thank you.  Any info would be great.

 

https://photos.app.goo.gl/13LYKtTmjBn1H7FQA

Share this post


Link to post
Share on other sites
Posted · Over-Extrude in corners of top layers

I would suggest you embed the pictures in your message, instead of using external links. Then you are more likely to get answers.

 

While writing your text, place the cursor in the desired spot, and drag and drop the picture from Windows Explorer into your message. I guess this should also work on a Mac or Linux.

 

Due to the enormously increased phishing and hacking since the corona-crisis, people are less and less willing to click on links from unknown sources.

 

Share this post


Link to post
Share on other sites
Posted · Over-Extrude in corners of top layers

Adding pictures instead of linking them.  Moderator, please delete my link to pictures in original post.  thank you.

 

 

IMG_20200411_105909.jpg

IMG_20200411_105916.jpg

IMG_20200411_105922.jpg

IMG_20200411_105933.jpg

IMG_20200411_105959.jpg

IMG_20200411_110017.jpg

IMG_20200411_110037.jpg

IMG_20200411_133114.jpg

IMG_20200411_133129.jpg

IMG_20200411_133147.jpg

IMG_20200411_133157.jpg

Share this post


Link to post
Share on other sites
Posted · Over-Extrude in corners of top layers

What kind of printer is that?  Do you know what the acceleration and jerk settings are?

 

Basically the extruder never stops.  Or at least not instantly.  So anytime you slow down or speed up you get over and under extrusion repectively.  So what happens on corners is that the printer slows down for the corners.

 

Ultimaker's solution (in the UMO and UM2) was to really crank up acceleration and jerk settings built into the printer so it barely slows down at all.  The universal solution is to just print slow - printing at the jerk speed is usually slow enough as it means it won't have to slow down at all.  Typical jerk settings for a printer is 20mm/sec so you can print at 20mm/sec and the corners will come out perfect.  For most printers.  You can certainly print faster and still get very good corners.  Say 30mm/sec.

 

If you want to keep good corners but speed up your prints, try increasing layer height and/or nozzle size.

 

Now you have more issues - you have these overextruded layers - most likely your Z axis is not consistent.  You can improve that a little by printing thicker layers but you should fix the root cause.  What kind of printer is this?  Typically this kind of result means you need to clean the Z screw(s).  What is happening is that say your layer height is 0.1mm and it is instead sometimes moving only 0.05mm so it doubly over extrudes that layer and it squeezes out the sides and makes those lines.  Then on the next layer it moves 0.15 or so.  Overall it moves the right amount but the Z axis might be sticking a bit on some layers.  Another solution (if you have a printer where the bed goes down as it prints) is to put a few bricks on the print bed.

Share this post


Link to post
Share on other sites
Posted · Over-Extrude in corners of top layers

Acceleration is set to 5000 mm/s  and jerk is set to 20 mm/s.  I understand what you are staying about every time the extruder slows down.  But if you look at my last picture, on the far right, the vertical edge, right in the middle, it does not over extrude.  Also the cubes with no top that i printed, the corners are perfect.  When I print the cube with the top, the top 3 layers (because I but 3 top layers) have over extrudes in the corners.

 

I am using the Artillery Sidewinder X1.  I think you might be right about the Z axis being dirty.  I remember the printer was pretty pretty well and then all of a sudden it stated to look bad.  What do you use to clean off the Z axis?  

 

thanks.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...