Jump to content
Ultimaker Community of 3D Printing Experts

Recommended Posts

Posted · UM3 Bondtech DDG Install problems...

I purchased the DDG Bondtech extruders due to worn out feeder wheels from abrasive material.  

 

My issue is I am having difficulty getting in to change the new updated firmware; 5.2.11 that is now installed.

 

I have followed Bondtech's instructions;  https://www.bondtech.se/wp-content/uploads/2018/08/Bondtech-DDG-Ultimaker-V2.0.pdf

 

I am on page 10 in this manual and I am successfully connected to my UM3+ printer (in developer mode) and there is no command line associated with my 5.2.11 firmware download.  The manual offers to copy and paste one of the command lines below into my PUTTY client prompt:

 

"Firmware Version Command 
3.6                    vi /usr/share/griffin/griffin/machines/jedi.json 
3.7 – 4.2.5        vi /usr/share/griffin/griffin/machines/um3.json 

 

I tried a pathway for the downloaded 5.2.11 and it does not work.  Would anyone know what the correct command line for the 5.2.11 download I would enter in to PUTTY?

 

Any help is greatly appreciated!

 

  • Link to post
    Share on other sites
    • 2 weeks later...
    Posted · UM3 Bondtech DDG Install problems...

    Thanks a lot!  Huge help.  It worked right away with only a small problem.  I kept getting a 'javaw' pop error.  I installed java which I did not have.  I followed the bondtech instructions exactly and it worked flawlessly!  You are my hero today sir.

     

    Starting the first print with the bondtech ddg's now.....

  • Link to post
    Share on other sites
    Posted · UM3 Bondtech DDG Install problems...

    I am still having problems.  I have successfully installed the firmware from Bondtech into my UM3+.

     

    I am still having massive over extrusion.  I have in Cura reduced the e step setting to 311 and I am getting very poor print quality.  

    It seems that the firmware only helps the initial load filament however prints are not going well at all.  The other issue is the factory extruder motor seems to be struggling.  I have the tension feed just tight enough so the filament does not slip.

  • Link to post
    Share on other sites
    Posted · UM3 Bondtech DDG Install problems...

    Sorry to hear.

     

    I have the Bondtech QR's fitted so don't use the existing stepper motors so unsure how they perform.

     

    I would suggest you log back in via Putty and load up the later firmware json file,

     

    (3.7 – 4.2.5, vi/usr/share/griffin/griffin/machines/um3.json) as I seem to remember that is the latest version (Currently printing so can't confirm but you could just drill down the menus if you know how to in cmd to double check - Then open the file, scroll down and confirm the estep value).

     

    Are you getting the same extrusion issues on both feeders? 

     

  • Link to post
    Share on other sites
    Posted · UM3 Bondtech DDG Install problems...
    14 hours ago, dspy8083 said:

    I have in Cura reduced the e step setting to 311 and I am getting very poor print quality.

     

    I don't think that is possible at all. How have you done that?

     

    The only relevant places are the JSON-files  in /usr/share/griffin/griffin and the "override file" in /var/lib/griffin (if present).

    9066.json belongs to the UM3 and 9511.json to the UM3 extended - both inherit the default steps from um3.json.

    I don't know which file is changed by the Bondtech update tool.

     

    5.2.11 is the current firmware for the UM3 (AFAIK), so that part should be fine.

    If in doubt, make a copy of both folders (with WinSCP or a similar tool) and upload it here (as a compressed zip-file).

     

  • Link to post
    Share on other sites
    Posted · UM3 Bondtech DDG Install problems...

    In the printer settings it allows you to adjust the e steps per mm.

     

    I changed it back to 1600 and went back to the original Extruder.  
     

    Using the:

    The only relevant places are the JSON-files  in /usr/share/griffin/griffin and the "override file" in /var/lib/griffin (if present).

    9066.json belongs to the UM3 and 9511.json to the UM3 extended - both inherit the default steps from um3.json.

     

    i was able to change some configuration lines but the e step alteration was not an option.  
     

    Do you believe I ran into this problem because mine printer is an um3+ ?

    6F386D1D-5A62-4A8C-A637-7BE177E59373.jpeg

  • Link to post
    Share on other sites
    Posted · UM3 Bondtech DDG Install problems...
    7 hours ago, dspy8083 said:

    I changed it back to 1600 and went back to the original Extruder.

     

    7 hours ago, dspy8083 said:

    Do you believe I ran into this problem because mine printer is an um3+ ?

     

    No Ultimaker printer uses 1600 steps/mm for any "original" extruder - and what the heck is an UM3+ ???

    Perhaps you should start over and explain at first what exact (type of) printer you're talking about...and where did you get it?
    Do you have pictures?

     

  • Link to post
    Share on other sites
    Posted · UM3 Bondtech DDG Install problems...

    Also, those printer settings in Cura are part of the 'Printer Settings' plugin in the marketplace. If you do have an UM3, I would suggest you have little need for this plugin.

  • Link to post
    Share on other sites
    Posted · UM3 Bondtech DDG Install problems...

    hi

    I have a problem PuTTY asks me for a password, but I do not have it or where to generate it... 

  • Link to post
    Share on other sites
    Posted · UM3 Bondtech DDG Install problems...
    13 hours ago, micasanueva said:

    hi

    I have a problem PuTTY asks me for a password, but I do not have it or where to generate it... 

     

    If you are still talking about the Bondtech DDG installation, it's on the end of page 9 in the installation manual:

    https://www.bondtech.se/wp-content/uploads/2018/08/Bondtech-DDG-Ultimaker-V2.0.pdf

  • Link to post
    Share on other sites
    Posted · UM3 Bondtech DDG Install problems...

    Did anyone now found a solution to change the steps from 369 to 311?

  • Link to post
    Share on other sites
    Posted · UM3 Bondtech DDG Install problems...

    Just enter the value you want in the json file mentioned here in this thread. You just need to enable the developer mode to be able to ssh into the printer.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
    ×
    ×
    • Create New...