Jump to content
Ultimaker Community of 3D Printing Experts

Ultimaker S3: Camera Not Working

Recommended Posts

Posted · Ultimaker S3: Camera Not Working

Hi all,


I just received a new S3 from 3D Universe last week but have been unable to get the camera to work at all. It's running firmware 5.3.10. In Cura's Monitor tab, when I click the camera icon a grey tint appears on the screen, and the tint goes away when I click again. When monitoring in the web browser (Ultimaker Connect), when I click the camera icon, a black box appears, showing nothing. I know camera dropping is common with the S5 and might be patched in the next firmware (https://community.ultimaker.com/topic/30942-um-s5-camera-feed-stopping/) but wanted to know if anyone had this experience with the S3.


Things I have tried:
- Firmware upgrade
- Power cycled multiple times
- Performed a Factory Reset
- Performed several Cura Connect Resets
- Scanned the printer's IP address ( using nmap. Only port 80 is open, and also 22 if in Dev mode.
- I get nothing when going to "" and ""
- In Dev mode, running "systemctl restart mjpg-streamer@0" had no effect
- Opened up the webcam housing, but all wires seem to be intact.
- Forwarded port 8080 on my router (EdgeRouter X) to
- Tried WiFi and ethernet.


I've attached the boot log; at the end is where I entered Dev mode and tried to restart mjpg-streamer. I think the problem is that port 8080 on the S3 has not been opened, but I don't know how to do that. Appreciate any advice you can give.


  • Link to post
    Share on other sites

    Posted (edited) · Ultimaker S3: Camera Not Working

    After opening up the bottom panel and swapping the USB drive and camera connections, the USB continues to work, and the camera doesn't. So potentially a bad camera, and not a networking port issue. Ultimaker N.A. is helping me fix. Hopefully a camera replacement will do the trick. Thanks.

    Edited by jasonherngwang
  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now

    • Our picks

      • New here? Get ahead with a free onboarding course
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 13 replies
    • Create New...