Jump to content
Ultimaker Community of 3D Printing Experts

Aligning multiple parts accurately


gadg3ts
 Share

Recommended Posts

Posted · Aligning multiple parts accurately

I'm putting together what are basically some coasters with an inlay, and am having two small issues.

The STL files are exported from the same Fusion360 model - one is a base and the other the inlay to fit into it.

If i open them in MeshMixer, they appear in exactly the right places (so the origins seem correct).

However, when I open them in Cura, they don't line up without manual intervention.
So i have two questions:
1) Is there a way to get the two models to (hopefully automatically) align as accurately as possible using the origin co-ordinates of the STL?

2) If I merge the objects to rotate them, they seem to rotate 'in place' rather than as a single object. So they become unaligned and I have to move one against the other again. Is it possible to rotate the two objects keeping the same (relative?) positions?..
This is currently with Cura 4.6.0 on Windows.
 

 

Thanks,

Sean

  • Link to post
    Share on other sites

    Posted · Aligning multiple parts accurately

    That sounds strange, normally they should align also in Cura when they are fine in Fusion. 

    Make sure you have unchecked the option in the settings, to place the objects on the build plate.

  • Link to post
    Share on other sites

    Posted (edited) · Aligning multiple parts accurately

    I had the auto-orientation plugin enabled, so I disabled that (but no change).

    In Preferences -> General:

    "Automatically drop models to the build plate" & "Ensure models are kept apart" are both unticked.

    But when I add new objects to the project, they are appearing at random places (as in X/Y position) in the workspace.

    (almost as if it really thinks they should not be close to each other)

    I've been using Cura for a couple of years now, so I don't think I'm doing anything stupid.

    Is there any way to force objects to insert at 0,0,0 ?

    Edited by gadg3ts
  • Link to post
    Share on other sites

    Posted (edited) · Aligning multiple parts accurately

    Wonderful. Those instructions helped me figure it out.
    This might be a quirk of Fusion360, but it took a couple of attempts to get it working as expected.
    Attempt #1:
    (in fusion 360) Moved the existing objects (the extrudes for the inlay) into the correct positions and exported them (grouped as a component) as an STL. When I 'merged objects' in Cura, the inlay jumped to the position it was in F360 before I moved it.
    Attempt #2:
    Re-extruded the objects for the inlay, *so that they were generated into the positions where they needed to be* (flush with the body they fit into), then exported that as another STL.
    When added to Cura and again 'merge objects', these now appear in the correct places and so should print in the appropriate colours from the specified extruders (selected before the merge!).
    (if that helps anyone else later)

    Thanks,

    Sean

    Edited by gadg3ts
    changing the explanation
  • Link to post
    Share on other sites

    Posted · Aligning multiple parts accurately

    I too have had the same problem, but with TinkerCAD (which is also a Autodesk product like Fusion360). 

     

    I designed a two object model in TinkerCAD in order to print it with two different color filaments on a Ultimaker S3.  These objects are nested together and aligned perfectly in TinkerCAD.  I exported each part separately as .STL files.  I then open these two .STL files in Cura.  Cura places them at different positions - not aligned as they were in TinkerCAD.  

     

    The solution first step in Cura is to right click and select "Merge Models" which snaps the two models into the desired congruence, but makes them one object which prevents separate two color/filament printing.  To solve this, I next select "Ungroup Models" which re-separates the objects BUT keeps them in the same correct nested position!  This  is what I was hoping/expecting in the initial file opening.

     

    I hope this may help others.  I spent a lot of time trying to solve this weird quirk.  I do not understand why Cura does not just bring them in aligned as they were exported from TinkerCAD.  I suggest this is a "bug" or at least a very undesirable feature of Cura.  Some enhancement of Cura is warranted to allow the user to control this.

     

    Thanks to those comments above in this thread that lead me to this solution.

  • Link to post
    Share on other sites

    Posted · Aligning multiple parts accurately

    If you read above - I think all you have to do is disable the 2 features mentioned above?  Something like "automatically keep models apart" and "drop models to bed" and then just load the two STL files.  No need to merge and ungroup.  I've never had to do the merge/ungroup thing but it has been a while since I did a two color.

     

  • Link to post
    Share on other sites

    Posted (edited) · Aligning multiple parts accurately

    I verified that those two options are both disabled in Cura preferences, but the problem still occurs.  I think based on this thread it appears to be some issue with Autodesk (Fusion360 or TinkerCAD) and Cura.  

     

    Note that I am using Cura on MacOS... not sure if this makes a difference.

    Edited by mmuntean
    Additional information
  • Link to post
    Share on other sites

    Posted · Aligning multiple parts accurately

    Merging the models in Cura is indeed the intended way to re-align objects relative to their original origins and eachother. You don't have to ungroup the merged models to select them individually again; you should be able to use ctrl+left mouse button to select one model inside the group, and then change its extruder or per model settings.

  • Link to post
    Share on other sites

    Posted · Aligning multiple parts accurately

    When the models are grouped, ctrl+left mouse brings up the menu to select/group models.  I do not see anyway of assigning an extruder to submodels without ungrouping.  Note that I am on MacOS and perhaps this may be different on Windows.

     

    I also found another issue.  When I merge the models to bring them into alignment, Cura also drops each model flat onto the bed.  This is a problem.  I have a model that is floating on top of another model (letters printed on a top surface).  The dropping of this model to the bed embeds it in the underlying model.  Seems like the only method is to manual raise of the Z position of the desired model.  

     

    Overall the workflow from TinkerCAD though to Cura seems flaky to me.  The set of models are perfectly positioned in TinkerCAD.  This should simply work.

  • Link to post
    Share on other sites

    Posted · Aligning multiple parts accurately

    I just discovered that if I assign the extruders to the models after opening but BEFORE merging the submodels in the group they appear to retain their separate colors after merging.

     

    Here is the project - labels for a herb garden.

     

    image.thumb.png.4fbb07e51fd9e66e9b2a511014db37ea.png

  • Link to post
    Share on other sites

    Posted · Aligning multiple parts accurately

    Ah, yes, OSX. You could try command-clicking instead of control-clicking individual parts in a merged group.

  • Link to post
    Share on other sites

    Posted · Aligning multiple parts accurately

    Yes, the CMD-left click did work for selecting sub models in a group - THANK YOU.

  • Link to post
    Share on other sites

    Posted · Aligning multiple parts accurately

    So now a new question related to Cura and overlapping objects.  To create a two color object I am manually design two perfectly interlocking and non-overlapping models in TinkerCAD and then export each model as a separate .STL file.  I open the two files in Cura, merge the two objects into group, and then rezero them to the work surface and position as desired in XY.   Now using CMD-Right Shift I can select either submodel and assign a filament.color.  All good.

     

    It would be easier however if I did not need to do all the work of assuring carving our the exact holes for any inlay or overlap.  Say for example I want two cylinders to overlap slightly and be different colors, with one "dominate" and filling the area of overlap.  (see below)  I would like to be able to simply import two complete overlapping cylinders, and instruct Cura to have one take precedent over the other in any overlap area to create the desired split color model.

     

    Any way to do this with Cura?  Cura seems to simple alternate layers...  Which ever color is current printing will print first and color the full circle on that layer.  The second color will then print the corresponding crescent.  When it moves to the next layer the second color is active and takes the full circle.  It ends up looking like a deck of shuffled cards...

     

    image.thumb.png.6f78ca88887c4ac9685dde3c1f69f898.png

  • Link to post
    Share on other sites

    Posted · Aligning multiple parts accurately

    See the "Remove Mesh Intersection" and "Alternate Mesh Removal" settings.

  • Link to post
    Share on other sites

    Posted · Aligning multiple parts accurately

    Thank you.  Found the mesh settings and am able to have one cylinder dominate.  I am not sure how Cura selected which object to use to dominate in the the overlapped area.  In this case Cura has selected the magenta cylinder to dominate, which happens to be the first object in the object list (coincidence?).

     

    Is there a way to specify which object actually dominates?  Perhaps by reordering the object list?

     

     

     

     

    image.png

    image.png

  • Link to post
    Share on other sites

    Posted · Aligning multiple parts accurately
    On 9/13/2020 at 7:55 PM, mmuntean said:

     I am not sure how Cura selected which object to use to dominate in the the overlapped area.

     

    Neither am I, to be honest.

     

    The object list is ordered alphabetically, and it is not possible to change the order.

     

    What model is dominant may be affected by which model is more in front. Try moving one of the model more towards the front of the bed to see if that affects the order.

  • Link to post
    Share on other sites

    Posted · Aligning multiple parts accurately
    10 minutes ago, ahoeben said:

     

    Neither am I, to be honest.

     

    The object list is ordered alphabetically, and it is not possible to change the order.

     

    What model is dominant may be affected by which model is more in front. Try moving one of the model more towards the front of the bed to see if that affects the order.


    When I was working how to do multiple models "one at a time" on my big printer, I read somewhere that Cura works with a priority of "left to right". Might this be the same idea?

    (I wondered why I was getting replies to this topic, then I realised after logging in that I'd asked the original question! ;) )
     

  • Link to post
    Share on other sites

    Posted · Aligning multiple parts accurately

    I saw the same post about the order of printing of multiple models.  I tried rotating the test objects about the Z axis 180 degrees and resliced but it did not change the dominant object.  I also tried loading each half in a different order, but it confirmed the object list is alphabetical.  One thing I might try is to rename the objects to change the alphabetical order.

     

    Perhaps I need to accept that my models really need to be on overlapping in TinkerCAD.  The Cura solution would have made the process somewhat easier.

    image.png

  • Link to post
    Share on other sites

    Posted · Aligning multiple parts accurately

    FYI... tried rotating the combined model at every 45 degree position and this had no impact - the dominant disk always remained the same.  Perhaps the issue is object list order based on alpabetical.

  • Link to post
    Share on other sites

    Posted · Aligning multiple parts accurately

    You could try to load the two parts one after the other and check, if the loading order makes a difference

    (at least it seems to make a difference for the one-at-a-time mode).

     

    But even if it does.... i would rather call it a "side effect" than a "feature", i don't think one can rely on this for the future.

    A properly splitted 3D-model is certainly the better option.

  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • The Ultimaker Showcase — October 14. What's new?
        Your dear friends at Ultimaker have some exciting news and insights for you!
         
        • 0 replies
      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 8 replies
    ×
    ×
    • Create New...