Jump to content
Ultimaker Community of 3D Printing Experts

Upgraded to 4.6.1, now Cura won't open


emptyinbox
 Share

Recommended Posts

Posted · Upgraded to 4.6.1, now Cura won't open

Cura doesn't start.  Goes to the splash screen and hangs, then I have to force quit.  Rebooting doesn't fix the issue.  Uninstalling and Re-Installing does not fix the issue.

 

Cura has always taken forever to start, now after 5+ minutes it's still just doing nothing.

 

Any ideas?  I don't see any logs or anything, and there's no console error since it just hangs.

 

I wish Cura would behave like a 21st century program and just update in place instead of having to use InstallShield or whatever and patch over top of itself leading to errors like this.

  • Link to post
    Share on other sites

    Posted (edited) · Upgraded to 4.6.1, now Cura won't open

    Finally fixed my issue by deleting the cura/4.6 path in %AppData% and then uninstalling and reinstalling again.  In the process I lost my configuration settings.  😠

     

    I find it incredibly annoying to open Cura and see "UPGRADE TO 4.6.1 YOU DEFINITELY WON'T REGRET IT". Every. Single. Time.  I'm this close to blocking Cura's internet access so it never knows when there's an update.

     

    /rant

    Edited by emptyinbox
    clarity
  • Link to post
    Share on other sites

    Posted · Upgraded to 4.6.1, now Cura won't open
    8 hours ago, emptyinbox said:

    I'm this close to blocking Cura's internet access so it never knows when there's an update.

     

    In the General preferences, scroll down to the "Privacy" section and uncheck "Check for updates on start".

  • Link to post
    Share on other sites

    Posted · Upgraded to 4.6.1, now Cura won't open

    Look, i believe you didn't find anything in the logs. I also think that we might be able to see things in the logs that don't make sense to you.

    So as always:

    1. Please report bugs / issues on github.

    2. Fill in the entire bug template when doing so.

     

    That being said; How would updating in place prevent this issue?

  • Link to post
    Share on other sites

    Posted (edited) · Upgraded to 4.6.1, now Cura won't open

    I was having the same issue on a 3 monitor setup, Windows 10 x64.

    I had been using Cura 4.6.1 to slice with no issues, I closed the program and then went to re-open about 30 minutes later and it just wouldn't load.  Reboot, reinstall, trying Cura 4.4 which i still had installed, installing 4.7, nothing would make it load on any version.

     

    I eventually found the issue and it's not one I've seen mentioned before so thought I would share.

     

    I run GPUTweak for my graphics card, it has an option for an On Screen Display (OSD) overlay which i never use. 

    Somehow this got enabled (probably via a keyboard shortcut which is the same in another application) and as soon as I disabled this, Cura started.
    I re-enabled it and Cura would fail to load again.

     

    Just something for people to try should they also be running GPUTweak or other software with overlays (FRAPS, MSI Afterburner etc)

    Edited by Slegnor
  • Link to post
    Share on other sites

    Create an account or sign in to comment

    You need to be a member in order to leave a comment

    Create an account

    Sign up for a new account in our community. It's easy!

    Register a new account

    Sign in

    Already have an account? Sign in here.

    Sign In Now
     Share

    • Our picks

      • New here? Get ahead with a free onboarding course
        Hi,
         
        Often getting started is the most difficult part of any process. A good start sets you up for success and saves you time and energy that could be spent elsewhere. That is why we have a onboarding course ready for
        Ultimaker S5 Pro Bundle, Ultimaker S5, Ultimaker S3 Ultimaker 2+ Connect.   
        They're ready for you on the Ultimaker Academy platform. All you need to do to gain access is to register your product to gain free access. 
        Ready? Register your product here in just 60 seconds.
          • Like
        • 11 replies
    ×
    ×
    • Create New...